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Introduction 

This manual is intended to present the users of Priority with the basic 
knowledge needed to begin working with the system. It explains commands 
and keystrokes; the structure of menus, forms, reports and programs; how to 
work with them; how to receive explanations and help from within the system; 
and the like. It does not, however, explain the functional use of the software. 
That is, it will answer such questions as “How do I run a report?” and “How do I 
retrieve data from a form?”, but not “Which form do I use to record a sales 
invoice?” or “How do I view warehouse balances?”  
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How to Enter and Exit the System 

Entering the System 

Opening Priority 

1. Run Priority in your web browser. 

2. Enter your username and password, and click OK. 
Note: The name of the user who last used this workstation appears 
automatically. 

3. If your system maintains several different companies, select the 
company in which you want to work the first time you enter the 
application and click OK. 
Note: In all subsequent entries, the company last accessed by this 
workstation appears automatically. 

4. When you first begin to work with the system, you will receive a 
password from your system manager, which you may be asked to 
change periodically. If, for some reason, you have forgotten your 
password, click the Forgot password message in the login screen to 
receive assistance in restoring your password via an e-mail link. 

Changing Passwords  

 

Figure 1: Changing passwords (the Options Menu) 
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1. Click the Options Menu button , click File and select Change 
Password (see Figure 1). 

2. In the New Password column, record the new password you have 
chosen. 

3. In the Verify Password column, record the new password again. 

4. In the Old Password column, record your previous password. 

5. Click OK. 

Changing Company 

1. Click the Options Menu button, click File and choose Select Company.  

2. Select the company you wish to work in (see Figure 2) and click OK. 

Note: If you have been assigned multiple privilege profiles in the selected 
company, each of which will affect your access to entities differently, also select 
the profile with which to work (see Figure 3).  

 

Figure 2: Select Company pop-up window 



 

Cat.No. LB160681  Ver.04 – June.25,’17 4 

 

Figure 3: Select profile 

Tip: You can switch companies at any time during your work session. 

Customizing Companies 

You can designate a different color for each company environment you work in, 
for easy reference. This will affect the background color of the company name. 
To do so, enter the Companies form and select a value in the Color column 
for each company. 

You can also add user-specific text that will appear in the side menu when you 
are in a form. This text is defined in the Title Bar Text column of the 
Company-Specific Information form, a sub-level of the Personnel File form. 
Whatever text is recorded in this column will appear for the user and company 
in question. 

Note: See Accessing Entities to learn about accessing system forms. 

Automatically Accessing a Menu Item After Login 

You can set up the system so that a given menu item opens automatically 
immediately upon entrance into the system.  
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Example: 

You usually work exclusively with the Sales Orders form. Set it to Open 
After Login and this form will open automatically right after you log in to 
Priority.  

1. Use the directional arrows to navigate the menus until the cursor rests on 
the entity in question.  

2. Right-click the menu item and select Open After Login. 

Exiting the System 

1. At the conclusion of your work session, exit all forms, reports, parameter 
input screens and so on and close the browser. 

Automatic Exit 

The automatic exit feature is set by the system manager. After a specified 
interval of inactivity, you will get a warning that the program is about to end 
automatically. If there is no further response, all open entities will close down, 
except for any programs that are in progress. To continue working, simply 
cancel the warning. If you find that you receive warning messages more 
frequently than you would like, consult your system manager about adjusting 
the automatic exit time interval. 
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The Interface 

The Home Page 

The Home Page (see Figure 4) consists of the following: 

 Main Menu  

 Search Bar 

 Selected Entities 

 Trash Can 

 Add Entity 

 Recent Items List  

 Latest Updates 

 Search for Entity Tool 

 Options Menu Button 

 Active Screens Indicator 

 Priority Home Page Button 

 Favorites Menu 

 Hide/Show Menu Arrow 

 

 

Figure 4: The Home Page 
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The Main Menu 

The Main Menu appears on the top of the screen. Each menu item represents 
a module, a distinct set of sub-menus that comprise a specific topic, such as 
Purchasing or Production. Each Priority package contains a different 
combination of modules; thus, your system may not include all of the modules 
displayed above in Figure 4. 

Each menu contains a variety of entities from which to choose. There are five 
types of entities available in the system, each represented by a unique icon: 

 Menu – Opens a sub-menu, displaying all available items. 

 Form –  Loads a form in which to work (retrieve and update records). 

 Report – Accesses saved reports or runs new ones. 

 Program – Activates a program. 

 Printout – Creates document printouts. 
 

To navigate the Main Menu, click the desired menu. Then click the desired 
entity (or sub-menu). You can also use the keyboard: press Enter or the right 

arrow () to activate the current entity, the up and down arrows ( and ) to 

move within the menu, and the left arrow () to close it.  

 

Figure 5: The Product Bundles (Quotes/Orders) menu 
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Example: 

You are presently in the Product Bundles (Quotes/Orders) menu (see 
Figure 5). You can see the path of menus used to arrive there:  

Price Quotations  Product Bundles (Quotes/Orders)  Product 
Bundles (Quotes/Orders)   

From this menu it is possible, among other things, to: 

 Enter the Product Bundles (Quotes/Orders) form. 

 Print out the Product Bundles report. 

 Run the Product Bundles Wizard. 

Note: On customizing the contents and order of each menu and sub-menu, see 
Basic Customization (p. 116). 

You can copy from the Main Menu to a Windows clipboard the name of any 
given entity, the entity name with a link to it or the full path of an entity. This can 
then be pasted (e.g., in an MS-Word document) using Ctrl+V. To access these 
options, right-click the entity in question and select Copy, Copy Shortcut or 
Copy Path, respectively.  

Search Bar 

 

Figure 6: The Search Bar 

The Search Bar (Figure 6) enables you to locate any document in the 
system by entering a search term (e.g., the name of a customer or an order 
number). The autocomplete feature allows quick access to a single 
document, or you can open a search results form, where a list of the retrieved 
documents can be viewed, conveniently sorted by document type and 
displaying the number of results per type.  

The Search Bar can be accessed from the Home Page (located at the 
center of the screen) or from the top of any other screen. 
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Example: 

You would like to find the sales order you worked on yesterday for a 
specific customer:  

1. In the Search Bar, type in the customer’s name or part of it (e.g., 
Jo).  

2. While you type, you will receive the results of the autocomplete 
(see Figure 7). To view a document appearing in this list, click on 
the desired line or use the keyboard down arrow to navigate to it 
and press Ctrl+Enter. 

 

Figure 7: Search autocomplete 

3. If the document does not appear, click  on the Search Bar or 
press Enter. A form opens displaying all documents that contain 
that name (see Figure 8).If the list is long, it will be divided into 
tabs. The right pane displays the types and amount of documents 
retrieved.  

4. To narrow down results to the sales orders recorded for the 
customer, click on “Sales Orders” in the right pane.  

5. To narrow down results by date, select the relevant option under 
"Filter by Date".  

6. Click the desired document; it will open in Priority.  

7. Click the Search Results program in the Active Screens window 
to return to the Search Results form. 
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Figure 8: Search results  

Using Special Search Characters 

Like in other search engines, you can use special characters to get more 
specific search results. 

 Use quotation marks to search for an exact phrase, for example: 
"Warehouse Management System". 

 Use "+" to indicate that the term must appear in the documents retrieved, 
for example: 

 warehouse + system 

 system + "warehouse management" 

 Use "-"  to exclude a term from the search. For example, to retrieve 
documents that include the word "system", but without the term 
"warehouse management", type: system - "warehouse management". 

 Use "$" to retrieve the root word only without additional forms of the word. 
For example, to search for "warehouses" without returning documents 
with "warehouse", type: $warehouses. 

Selected Entities 

The easiest way to access the entities you use on a regular basis is to assign 
them to your Selected Entities display in the center of the Home Page. You 
can populate this display with links to the system entities that you use most 
frequently, such as the To Do List or the Sales Orders form.  

To add a tile to your Selected Entities, do one of the following:  
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 Click the  icon on the Home Page to open the Add to Home Page 
window. Retrieve the desired entity via the Search window and click 
Add. 

 Navigate to the desired entity on the Main Menu.  Then, right-click the 
entity and select Add to Home Page.  

You can organize the tiles of your Selected Entities by drag & drop, to 
determine the order in which they appear, or remove tiles from the display by 

dragging them to the trash can . 

A triangle in the upper corner of a tile displays the number of documents of that 
type that are assigned to you. Click the triangle to access a display of these 
documents in your to-do list.  

When hovering over a form tile with your mouse, a magnifying glass  and a 

plus sign  appear. Click the magnifying glass to open the form in Query mode 
to retrieve existing records (see p. 53) or click the plus sign to open a new 
record (if you have defined a query in the form, it will not be run). 

Recent Items List 

Entities that were used recently are added automatically to the Recent Items 
list on the Home Page. 

Latest Updates List 

Documents that were revised in the past 30 days will appear in the Latest 
Updates list. The list will include documents in which you changed the status or 
assigned user. The list displays the document type, number and additional 
details.  

The LATESTUPDATES constant (in the System Constants form) limits the 
number of documents that will appear in the Latest Updates list. The 
LOGUPDATE constant (in the same form) determines whether documents in 
which you have revised remarks (in text forms), or to which you have attached 
files, are displayed. 

 The Search for Entity Tool 

The Entity Search tool (Figure 9) enables you to locate any entity in the system 
by its title (or part of the title). 
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Figure 9: The Search for Entity tool 

To activate the Entity Search tool, take one of the following steps: 

 Click the Entity Search tool , on the left 
side of the Main Menu bar. 

 Click the Options Menu button, click Run and select Search for Entity. 

 Press Ctrl+]. 

To search for an entity: 

1. In the Search For field, type in a term, or as much of the entity title as 
you know. The search will be case sensitive unless the Ignore Case box 
is checked. 

2. Click the Search For button or press Enter. All entity titles that contain 
the term will then be displayed in the window. 

3. Once you have located the entity you seek, you can: 

 Click the Start button to activate the entity directly. 

 Click the More button to access several options: 

 Copy (to copy the entity) 

 Copy Shortcut (to copy the entity together with a link to it) 
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 Copy Path (to copy the entity's menu path). The result is saved on a 
clipboard and can be pasted (e.g., in an MS-Word document) using 
Ctrl+V. 

 View the entity's path 

 Add the entity to the Home Page 

 Open the Privilege Explorer, directly accessing privileges for the 
entity. 

 Click the Help button to display the entity’s Help text. This is useful 
when you need to distinguish between several similar-sounding 
entities. 

Options Menu Button 

The Options Menu button , which appears at the top right of the screen, 
provides functions related to the appearance and navigation of the work area, 
the internal mail system and a variety of Help options.  

Example:  

To change your password, click the Options Menu button, click File and 
select Change Password.  

Note: When forms are open, additional functions are available.  

For a full description of each item in the Options Menu, see Appendix C. 

 

Active Screens Indicator 

The Active Screens indicator , located at the top right of the screen, 
shows the number of entities that are currently open. To access any of the 
entities, click on the indicator. A window with the list of entities opens (see 
Figure 10).  



 

Cat.No. LB160681  Ver.04 – June.25,’17 14 

 

Figure 10: Active Screens 

 To open a form (or run a report or program), do one of the following: 

 Click on the desired entity. 

 Use the keyboard up and down arrows to select it and press Enter. 

 To close an entity, hover with your mouse over the entity (it will be 
highlighted in blue) and click the x that appears on the right. 

 To close all entities at once, select Close All.  

 To close the window, click the x on the top right corner. 

Priority Home Page Button 

The Priority Home Page button , located at the top left of the screen, 

enables you to return to the Home Page from any form.  

Favorites Menu 

The Favorites Menu, located at the top left of the screen , is a 
personalized list of entities for quick access to forms, programs or reports 
accessible from any screen. (For more information on how to add, remove and 
organize the Favorites Menu, see p.20). 

Hide/Show Menu Arrow 

The menu arrow is located at the top right corner of the screen. When the 

arrow is pointing upward , the Main Menu is displayed. To hide the Main 

Menu, click on the arrow; it will invert  . 
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Accessing Entities 

In summary, there are several ways to load a form, generate a report or run a 
program: 

 Clicking the tile in the Selected Entities display (see p.10). 

 Selecting it from your Favorites Menu (see p.14). 

 Navigating the menus and clicking the desired entity (see p.7). 

 Running the Search for Entity tool (see p.11). 

 Selecting the entity from your list of Recent Items (see p.11). 

 Selecting a document from your list of Latest Updates (see p.11) 

In addition, there are ways of accessing entities from within other entities, 
which will be discussed in the sections on forms and Help wizards. 

Help 

Several Help features are built into the system, providing you with explanations of 
everything from individual columns to entire work processes. Help regarding form 
columns and input parameters will be covered in the sections regarding Forms 
(see p. 78) and Reports and Programs (see p. 115), respectively. 

The Help Button 

A shortcut to Help options that help you get started, as well as Online Support 
and FAQs , is available by clicking on the Help button  in the upper right corner 
above the Main Menu.  

 

Menu Entities 

To receive an explanation of any entity in the Main Menu, right-click the desired 
entity and select Help. A message box will appear containing a brief description 
of the entity and its functions. 

Note: This is the same description displayed by pressing Ctrl+F1 in an open 
form. 

Help messages may include hyperlinks (in blue) that open other entities. Once 
you leave such an entity, you return to the help message and the Main Menu. 
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Wizards 

Wizards are interactive guides that help you carry out many of the system's 
processes. Each wizard appears in a help window that remains visible as you 
work on the main screen, and accompanies the process step by step. The user 
can even open the screens, reports and programs mentioned in the wizard 
from within the wizard itself. There are several ways to access wizards: 

1. From the Main Menu: Menus and sub-menus contain direct links to wizards. 

2. Click the Options Menu button, click Help, select Help Wizards and 
choose one of the following options: 

 In the Contents tab, navigate until you find the desired wizard. 
Double-click on the title to open the wizard.  

 The General sub-menu in the Contents tab contains a number of 
Main Wizards, whose purpose is to provide a general overview of the 
work processes that take place within an entire module. Each main 
wizard is hyperlinked to all of the wizards available in that module. 

 Click the Search tab, and use keywords to search for the various help 
topics that refer to the desired subject. Double-click on one of the 
displayed topics to open the relevant wizard to the selected topic. 
Note: If you forget where you are, use the Home  button located at 

the bottom of each topic to return to the beginning of the wizard you are 
in. 

Online Help 

Priority's Online Help utility complements screen help by giving you access to 
a variety of aids and documentation that are maintained on the Priority web 
site. You can view up-to-date, topic-specific video clips, standard operating 
procedures (SOPs), frequently asked questions (FAQs) and documents. No 
downloads are necessary. 

To access this utility: 

1. Right-click the entity in question and select Online Help.  

2. A new browser window opens. Click on the line(s) that interest you. 
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Forms 

Introduction 

 

Most of the work in the system is carried out by means of forms. You can use a 
form to add new data to the system, as well as to retrieve existing records for 
review and/or revision. Proficiency in the use of forms is an important first step 
in learning to use Priority. From the application forms you can run programs, 
print reports, and send documents via fax or e-mail. Before giving you an in-
depth explanation of how to work with forms, the following provides an 
overview of the basic concepts you need to know: 

Each record in a given form is made up of several columns. Information 
specified for one column within a given record constitutes a field. 

Most of the basic forms used for data entry initially appear in Full-Record 
Display Mode, in which only one record is presented at a time. This mode 
features a friendly graphic interface that divides the form's columns into tabs. In 
order to see multiple records at one time, you can toggle to Multi-Record 
Display Mode, which presents all of the form's records in a table. This mode is 
particularly useful for viewing retrieved data, and many forms open directly in 
this mode. However, if the form is wide, some of the columns will be hidden 
until you scroll to them. For more details, see p. 23. 

In addition, forms have two primary modes of operation:  

 Data Entry mode, in which you can record new data and update 
existing records, and 

 Query mode, in which you retrieve data. 

You can quickly move between these modes as you are working. 

There are two non-exclusive types of forms: upper-level forms and sub-levels. 
An upper-level form is one that has at least one sub-level. Sub-level forms 
provide further information on a given record in the upper-level form. For 
instance, the Customers form, which stores customer names, mailing 
addresses and phone numbers, can have one sub-level that displays sites for 
each customer and another sub-level that displays all orders placed by the 
customer. Root forms are upper-level forms that are accessed directly from 
menus. 
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Form Display 

 

When a form is opened, the following features appear at the top and sides: 

 Main Menu (for details, see p.7) 

 Shortcuts 

 Form Navigation Window  

 Direct Activations Menu  

 Active Screens Window 

 Favorites Menu 

 Option Menu Button 

 

Figure 11: Form Display 

When a form opens, its title is displayed in the upper left-hand corner of the 
screen. The top section of the form is the active part, in which to record, update 
and/or view data. At the bottom of the active form appear several sub-level 
tabs; these open the sub-level forms of the active form, providing additional 
related data (for details, see p. 67).  

Shortcuts 

The row of icons located at the top of a form includes shortcuts to perform 
frequent actions: 

 New Line (Ctrl+Enter) (see p. 31) 

  Query/Clear Form (F11) (see p. 54) 



 

Cat.No. LB160681  Ver.04 – June.25,’17 19 

  Share. Click this icon to access the following options: Send Record Link 

(see p. 183), Dial or Skype (see p. 176). 

  Delete record (Ctrl+Delete) (see p. 50)   

  Send to spreadsheet (see p.152) 

   Track the document (see p. 48) 

  Undo the last action (Ctrl+Z) (see p. 49) 

  Toggle between Multi/Full-Record Display (F4) (see p. 23) 

  Add the form to Favorites (see p. 20) 

  Close the form (Esc). 

As mentioned, the right pane includes the Form Navigation window, the 
Direct Activations menu and the Active Screens window. The entire pane 
can be hidden (and redisplayed) by clicking on the tab which always remains 
visible. You can hide each menu or window by clicking on the arrow at the top 

of it . 

In addition, you can change the width of the right pane by situating the cursor at 
the edge (so that arrows appear) and dragging them left or right. 

Form Navigation Window 

At the top of the right pane is the Form Navigation window, which provides 
information on your current placement in the form. This window displays: 

  the current company 

 the form title 

 the current form column 

 the current line in the form. 
Note: You can also see the line you are in by placing the cursor anywhere 
along the vertical scroll bar situated to the left of the form.  
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If you move to a sub-level form or use the drill-down mechanism to access 
additional forms, the navigation path appears as well. To return to any form 
within that path, simply click on its title as displayed in this window.  

Direct Activations Menu 

At the center of the right pane is the Direct Activations menu. It contains a list 
of forms, programs and reports that are relevant to the current form. To access 
any of those entities, simply click on its title. For details on Direct Activations, 
see p. 72. 

Active Screens Window 

At the bottom of the right pane is the Active Screens window that lists the 
number of forms that are currently open. To access any of them, click on their 
title. Right-clicking on the form title provides additional options, such as closing 
or minimizing the form. 

Notes:  

 To move between active screens, press Ctrl+ or Ctrl+.  

 This function is also available using the Active Screens indicator 

 on the top right corner of the screen. 

Favorites Menu 

The Favorites Menu, located at the top left of the screen, is accessible from all 
screens (see Figure 12). You can add, delete and organize entities on the 
Favorites Menu at your convenience.  

To add any entity to your Favorites, navigate to the desired entity on the 
Main Menu.  Then, right-click the entity and select Add to Favorites.  

To add forms to your Favorites from within a given form: 

  Click the  icon at the top of the form; it will turn black .  

 To remove the form from your Favorites, click the star again; it will 

become white . 
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Figure 12: Favorites Menu 

You can organize your Favorites to determine the order in which they appear. 
In addition, you can open sub-menus that will appear in the drop-down menu 
and include entities in them. You can also remove an entity from the Favorites 
Menu. 

To organize your Favorites: 

1. Do one of the following: 

 Click  at the top of the screen, right-click any entity and select 
Organize Favorites. 

 Click the Options Menu button, click Design, and select Organize 
Favorites. 

2. In the window that opens, do any of the following: 

 Click the arrows to move items up or down within their existing menu.  

 Click the other buttons to add or delete a sub-menu or to remove an 
entity from your Favorites. 

 Right-click an entity/sub-menu to change its name, delete it or move it 
to a different sub-menu. 

Options Menu Button 

When a form is open, the Options Menu button offers functions unique to the 
operation of forms. For a full list of menu items, see Appendix D. 

Working With Multi-Company Forms 

If you are responsible for managing the data of multiple companies within your 
Priority system, you are likely to work with forms that display data from all or 
some of those companies simultaneously. Your system manager (or anyone 
with Manager privileges) has the option of converting almost any system form 
into a multi-company form (see p. 120). 
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When working with a multi-company form, you have the option of selecting the 
companies whose data you want to view. To do so: 

1. Click the Options Menu, click File and select Define Multiple 
Companies. 

2. Flag each company for which you want to display data. 

The selection that you make affects all multi-company forms in all companies 
within the system, though it does not affect the data that other users see. If you 
enter a different multi-company form and only want to see data for a single 
company, you will need to repeat the above operation and remove the 
unwanted check marks. 

Note: The selection of companies also affects consolidated statements and 
other multi-company reports. 

Each record in a multi-company form may originate from any of the selected 
companies. The company of each line item is designated in the Full Company 
Name column, which appears in all multi-company forms (see Figure 13). 

 

Figure 13: Viewing data in a multi-company form (Multi-Record Display Mode) 

Note: If you do not have the exact same privileges for a given multi-company 
form in all of the selected companies, you will receive an error message and 
the form will open for the default company only. To determine what your 
privileges are in the companies in your system, speak to your system manager. 
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Display Layouts 

As mentioned above, forms have two main types of display layout: 

1. Full-Record Display, in which one complete record is shown. This 
allows you to view all of the columns in one record. However, any 
additional records will be hidden from view until you move to a different 
line. 

Most of the basic forms used regularly for data entry (e.g., invoices, orders, 
price quotes, receipts, customers) open in Full-Record Display Mode (see 
Figure 14). This is a graphic interface that divides the form's columns into 
groups by subject, and presents each group in a tab. This display mode is fully 
customizable, allowing you to organize the columns in a manner that meets 
your needs and display them in custom tabs (see p. 118). 

 

Figure 14: A single GL account (Full-Record Display Mode) 

2. Multi-Record Display, in which several records are displayed 
simultaneously, broken down into frames (see Figure 15). If the form is 
wide, some columns may be temporarily hidden from view. In order to 
see them, you must scroll from one frame to the next. 

Note: The maximum number of records that can be displayed on the screen at 
one time is set by a system constant. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 24 

 

Figure 15: Viewing a number of accounts together (Multi-Record Display Mode) 

In both display modes, in a form in which you can attach files (such as the Part 
Catalogue), any record including an attachment will display an icon of the file 
type (or a thumbnail in the case of an image file). You can prevent icons and 
images from appearing (thus cutting down your work time) by selecting No 
Image Display in the Design menu of the Options Menu.  

To toggle between the two display modes, take one of the following steps: 

 Click  in the row of shortcuts. 

 Press F4. 

 Click the Options Menu button, click Design and select Full/Multi-
Record. 

The choice of display mode is a matter of personal preference. Multi-record 
display is recommended in a form with few columns, as it enables you to see 
several records at once, viewing all their fields. Full-record display is 
particularly useful during data entry, as it enables you to see and easily move 
between all fields in the current record. Indeed, most of the forms that open 
automatically in full-record display are used for this purpose. 

Note: The display mode that is chosen has no effect on the contents of the 
record. The only difference is in the manner in which the data appears. 

The following explanations of form usage often differentiate between the two 
types of display layouts. That is, the steps that you need to take are sometimes 
dictated by the display mode. 

Personalizing the Appearance of Forms 

There are several options for personalizing the appearance of forms. 

Choose between a light or dark color theme by doing the following: 

1. Click the Options Menu button, click Design and select Color Theme.  
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2. Select Light or Dark. 

You can change the font size in forms, which affects Full-Record and Multi-
Record Display modes alike: 

1. Move the cursor to the desired column and do one of the following: 

 Right-click the column and select Change Font Size. 

 Click the Options Menu button, click Design and select Change Font 
Size.  

2. Select the desired font size. 

In addition, you can color-code form records, so that the system automatically 
changes the font color of a record when a given column receives a designated 
value or range of values. 

Example 1: 

1. Use the Search for Entity feature (see p. 11) to find and open 
the Customers form.  

2. Click the Options Menu button, click Run and select Retrieve 
All Records.  

3. Click the Details tab and move to a record with a sales rep.  

4. Right-click the Sales Rep Number column. Select Record Color 

 Define Record Color, select a color and click OK. Each 
customer with the same sales rep will appear in the chosen color.  

    
Figure 16: The Choose color dialogue box 

5. Click F4 and scroll through the records to see which customers 
use the sales rep in question. 
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Example 2: 

To assign a record color for a range of values (when the column in question 
contains a numerical value): 

1. From the Customers form, click the Company Data tab. 

2. Right-click the # of Employees column and Select Record Color 

 Define Record Color. Select a color, indicate the range of 
values (e.g., 0-50) to which you want to assign that record color 
and then click OK.  

 
Figure 17: Setting a range of values in the Choose color dialogue box 

3. Click F4 and scroll through the records to see which customers 
employ the designated number of people (in this example, 
anywhere between 0 and 50 employees). 

Notes:  

 You may define more than one color condition for a single 
column.  

 The Define Record Color command is also accessed from the 
Design menu in the Options Menu (use the Record Color line). 

To remove color conditions from a column: 

1. Move to a record in the form and fill in the value to which the color code 
is attached (e.g., in the first example, specify the sales rep in question in 
the Sales Rep Number column).  

2. Move the cursor to the desired column and do one of the following: 

 Right-click the column and select Record Color  Define Record 
Color. 
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 Click the Options Menu button, click Design and select Record Color 
and then Define Record Color.  

3. Click the No Color option followed by OK. 
Tip: Repeat the process if more than one condition has been defined. 

To remove all color conditions from a form: 

1. Move to a record in the form.  

2. Move the cursor to the desired column and do one of the following: 

 Right-click the column and select Record Color  Define Record 
Color. 

 Click the Options Menu button, click Design, Record Color and then 
Define Record Color.  

3. Click the Reset button at the bottom right of the screen. 

To check the form's current color conditions (see Figure 18), do one of the 
following: 

 Right-click any column and select Record Color  Show Current Record 
Colors. 

 Click the Options Menu button, click Design, Record Color and then 
Show Current Record Colors.  

 

Figure 18: The Current conditions dialogue box 

Navigating Forms 

Moving Within a Form in Full-Record Display Mode 

To move within the current record, simply click on the desired field with the 
mouse. Alternatively, you can use the arrow keys or press Enter, Tab or 
Shift+Tab (to go backwards). 
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To move between tabs, press Shift  and Shift , or press Tab to move from 
the last column in one tab to the first column in the next.  

Note: To move between the main section and the first tab, it is sufficient to use 
the  key. 

To move between records, use the PgUp and PgDn keys, the vertical scroll bar 
at the left of the form or the scroll button on your mouse.  

Moving Within a Form in Multi-Record Display Mode 

To move between rows, you can: 

 Click on the desired row with the mouse.  

 Use the vertical scroll bar to the left of the form. 
Note: The current form line is displayed whenever the cursor is placed 
over this scroll bar. 

 Use the up/down arrow keys .  

 Press Enter to move to the next field. 

 Use the scroll button on your mouse. 

Note: As you move from one row to another, the current row becomes passive. 
That is, the column you are in changes color. 

To move between columns within a row, you can: 

 Click on the desired field with the mouse.  

 Use the left and right arrow keys .  

 Press Tab or Enter to move one column to the right, Shift+Tab to move 
to the left. 

 Use the horizontal scroll bar (that begins after the tacked column – see 
below). 

In a form with many columns, not all can be viewed at once. The tack  that 
is attached to one of the first form columns determines the part of the form you 
continue to see as you keep scrolling to the right. You can drag that tack to any 
column in the form and that column – together with all columns to the left of the 
tack – will remain visible when you navigate to the hidden columns to the right. 
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Data Entry 

When you first enter a form, you are in Data Entry mode, in which you can 
record and update data (as opposed to Query mode, in which you retrieve 
records; see p. 53). The very first field (first column, first line) is highlighted. In 
most cases, no data is visible in the form columns.  

Read-Only and Updateable Columns 

Any column in a form is either read-only or updateable. Some updateable 
columns are mandatory.  

Note: A mandatory column must always be filled in. If it is not, you will not be 
able to update the record or continue work in the form. If you get stuck in a 
record (because you don’t have all the needed mandatory information), you 
have to undo your actions or clear the line (see p. 49). 

Priority features several visual cues to help you differentiate between types of 
columns. Mandatory columns are marked with a red star. Read-only columns 
are gray.  

Shortcut Values 

The plus and minus keys  (+/–) provide helpful shortcuts when recording dates, 
times and numerical values.  

Note: The Default Value command serves the same function as the minus key 
(-). This option may be selected either from the Edit menu (in the Options 
Menu) or from the pop-up menu accessed from the right mouse button. 

Dates and Times 

A date field is distinguished by a small calendar  on the right (which itself 
can be used to select a date; see p. 41). 

 Press + or – to enter today's date automatically.  

 Use the same keys to modify an existing date; press “+” to display the 
next date or press “-“to show the previous one. Press again to continue 
moving forward or backward. 

 These keys have the same effect for columns that display date + time, 
only time or the day of the week. 
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In addition to the above are fields that show a span of time, consisting of a 
three-digit number representing hours, separated by a colon from a two-digit 
number representing minutes. 0’s must be added to the left of any numbers 
that have less than the required amount of digits; for example, 050:20 signifies 
50 hours and 20 minutes, 000:30 indicates 30 minutes. The displayed time 
span can be modified incrementally by minutes via the plus and minus keys. 

Numerical Values 

To increase or decrease a numerical value (for example, a price), press the 
plus or minus key respectively. 

Note: A variety of display formats are available (e.g., 1,234.56 for English-
speaking users, 1.234,56 for Italian users). To change the format, use the 
Languages form. 

Adding Records to an Empty Form 

To add a new record in a form in which no data is displayed, simply type in the 
information you wish to specify (or copy it from elsewhere; see below). If you 
have typed incorrectly, you can backspace and correct the error. Make sure 
that all mandatory columns are filled in.  

You can edit what you have typed by using one of the following methods:  

 Highlight and overwrite: 

1. Drag along the written text with the left mouse button to highlight any 
portion that was incorrectly typed. 

2. Type in the correct characters. Anything highlighted will be 
overwritten. 

 Type in Replace mode: 

1. Switch from Scroll mode to Edit mode (press F2). 

2. Use the left and right arrow keys  to move the cursor within 
the field. 

3. Switch from Insert mode to Replace mode (press Ins on the 
keypad) to overwrite any incorrect character. 

As soon as you add a new record and leave the line, the database is updated 
automatically. This occurs when: 

 You move the cursor to any other line in the form. 

 You move to Query mode. 
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 You exit the form. 

 You enter a sub-level form. 

Example: 

Use the Search for Entity feature (see p. 11) to find and open the 
Customers form. You will notice that several columns are mandatory such 
as the Customer Number and Name. Moreover, a temporary number is 
assigned automatically once a name is designated. So to add a new 
customer, all you need to do is move to the Name column and designate a 
customer name (e.g., “Just Testing”). 

If you wish, you can add other information (like phone number or street 
address), but it is not necessary at this stage. 

Press PgDn to leave the line and update the database. The “Just Testing” 
customer has now been added to the database, and you are positioned to 
add another new customer. 

Note that the customer you have added still appears in the form; you just 
can’t see it, because you are in Full-Record Display Mode and you have 
moved to a new record. Press F4 to move to Multi-Record Display Mode. 
You will see the “Just Testing” customer on the first line of the form and 
your cursor in the second (blank) line.   

Now leave and reenter the form; it will be empty of records. To find “Just 
Testing” again, click the Options Menu button, click Run and select 
Retrieve All Records. All customers, including Just Testing, will be 
displayed. Move to Multi-Record Display Mode (press F4) to view them all 
at once. 

Adding Records to a Filled-in Form 

In order to add new records once existing records appear in the form, you need 
to open a new line. To do so, select one of the following methods:  

 Click   in the row of shortcuts.  

 Press Ctrl+Enter. 

 Click the Options Menu button, click Edit and select New Line. 

 Move to the last line in the form and move down to a blank line. 

The following sections provide additional tips for data entry in forms. 
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Setting Column Width 

Some form columns do not open to their full width, both in Full-Record Display 
Mode and Multi-Record Display Mode. When you place the cursor on such a 
column and begin to type, it automatically opens up to its full width. To expand 
the column to its maximum size without editing the field, press the Shift key. It 
will return to its original size when you move to a different field. 

If you are working in Multi-Record Display Mode, you can expand the column to 
its full width and leave it open until the root form (the form reached from the 
Main Menu) is exited. To do so, do one of the following: 

 Click the Options Menu button, click Edit and select Expand. 

 Right-click the column and select Expand.  

To permanently adjust the width of a form column, you can grab the dividing 
line between column titles and move it to the left or right. The resulting columns 
will retain their new width even after you close the form. To restore all columns 
in the form to their default widths, select the Restore Column Widths 
command from the Design menu in the Options Menu. 

Simple Copy and Paste Features 

Anyone familiar with Microsoft Windows should be adept at using its copy and 
paste features, which are also available for any field in Priority.  

To copy highlighted text, do one of the following: 

 Press Ctrl+C. 

 Click the Options Menu button, click Edit and select Copy. 

 Right-click the column in question and select Copy. 

To paste text that has been copied, move the cursor to the proper line and 
column and do one of the following: 

 Press Ctrl+V. 

 Click the Options Menu button, click Edit and select Paste. 

 Right-click the column in question and select Paste. 

Notes:  

 When pasting large amounts of data into Priority (e.g., from 
Excel), you can stop the action by pressing Ctrl+Break.  
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 When pasting data into Priority, you can also choose the Paste 
Special - Ignore Warnings command (from the Edit or right 
mouse button menus) to paste text from the clipboard without 
displaying system warnings. This is especially useful when 
pasting large amounts of data into Priority (e.g., from Excel). 
However, this operation can result in the corruption of one or 
more records in the database if the data being pasted contains 
errors, and should therefore be used with caution. 

Choosing a Value From a Choose List 

In many form columns, you can choose the value that you wish to enter from a 

short list. These columns are identified by a Choose button  that appears to 
the right of the text box once the cursor is situated in that field. Such a button, 
in fact, appears next to the Sales Rep Number column in the Customers form. 
To choose from a list of possible sales reps, move to the Details tab and click 
this button or press F6 from the column in question. If the column is currently 
empty, you can also open the Choose list by pressing the Space bar. After 

opening the Choose list, the icon changes to . 

To choose the desired value, simply locate and click on that value. All Choose 
lists also feature the following two mechanisms, which are designed to speed 
up the selection process: 

 Sorting mechanism: You can sort a Choose list in ascending or 
descending order by clicking on the list title (see Figure 19). 

 Choose pattern field: You can use the choose pattern field appearing at 
the top of the Choose list (see Figure 19) to help you locate a particular 
value. Initially, this field is filled in with the first value appearing in the 
Choose list, and that value is highlighted. If you begin recording the first 
few letters of the desired value in this field, the system automatically 
jumps to the first line matching the recorded string. Once the cursor is on 
the correct line, press Enter to choose that value. The remaining text is 
filled in automatically. 
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Figure 19: Choosing a value from a Choose list 

The values in each Choose list are taken from a source form that was filled in 
at a previous stage. For example, the Choose list you used in the Customers 
form was taken from the values in the Sales Representatives form. 
Consequently, in order to update the Choose list, you must modify the Sales 
Representatives form.   

After selecting a value, the Choose list icon changes to . You can press 
the left icon (More Information) to access the source form and view details 
regarding the selected value. The breadcrumbs at the top of the form help 
you keep track of your location and serve as links back to previous forms. 
Click one of the links or press Esc to return to the original form. 

Extended Choose lists (see Figure 20) include a second list title. You can sort 
an extended Choose list in ascending or descending order by clicking on either 
of the list titles. The first column in the list is named after the form column you 
are in (e.g., Name, User, Family) and the second is called Description. 

Some extended Choose lists also allow you to select more than one item 
simultaneously. Multiple list items are selected in the same manner as in 
standard Windows tools: 

To select adjacent items: 

 Click on the first item, hold down the Shift key and click on the last item. 
The entire block of items from the first to the last will be highlighted for 
selection. Click OK. 

List Title 

Choose Pattern 
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To select several discrete items:  

 Click on the first item, hold down the Ctrl key and click on each item you 
want to select. Each item will remain highlighted for selection. Click OK. 

 

Figure 20: Example of an extended Choose list 

If the source form happens to be empty of values, you will automatically find 
yourself in the source form, where you can add any records you need. You can 
also reach this form when you want to add to or revise the values in an existing 
Choose list. 

To open the source form, do one of the following: 

 Press F6 from within the list.  

 Click the magnifying glass (that appears when the Choose list is 
opened) next to the column.  

 Press F6 twice from within the column.  

Add the desired record, then copy the newly added value back into the 
original form via the Choose Value utility, which is explained below on p. 39. 
Once there is even one record in the source form, a Choose list will appear.  

Choosing a Value From a Search List 

In some forms a drop-down arrow  opens a Search list rather than a Choose 
list.  

To open the Search window, do one of the following: 

 Click on the drop-down button to the right of the column. 
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 Move to the column in question and press F6. 

 In an empty column, press the Space bar. 

The window is divided into four sections (see Figure 21). 

 The advanced options section that includes: 

o Create a Record – To create a new record in the source form. 

o Advanced Search – To retrieve a record in the source form (for 
more information on data retrieval and queries, see p. 53). 

o Choose Value – To copy a newly added or retrieved value back into 
the original form (see p. 39). 

 The search pattern field, in which the cursor is located. 

 The criterion tab (By Name, By Number, By Other Criterion), 
determining the type of search. 

 The list of retrieved values.  

 

Figure 21: Searching for a warehouse starting with “D” 

Initially, the search pattern field is empty. Depending on the value of the 
EMPTYSEARCH system constant, either all values are retrieved or the list is 
blank. Either way, you conduct the search by specifying search criteria.  

Search Results 

Criterion Tab 

Search Pattern 
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When the Search Only from Beginning of Item option at the bottom of the 
Search list window is flagged, Search lists look for your search pattern at the 
beginning of each list item, returning all values that begin with that pattern. If 
the checkmark is removed from this option, the Search list will look for your 
search pattern anywhere within the items. 

Note: The SEARCHOPTION system constant determines whether the option is 
flagged when you first open a Search list. 

You can also flag the Ignore case option at the bottom of the Search list 
window so that the search is not case-sensitive. 

Follow the example below and practice using the utility to learn how to 
efficiently select values. 

Example:  

Search for The Learning Center customer as follows: 

1. Click the Options Menu button, click File and choose Select 
Company to make sure that you are in the demo company. 

2. Use the Search for Entity feature (see p. 11) to find and open 
the Customers form. 

3. In the Number column, click on the  button to display the 
Search window. 

4. Verify that the criterion tab is entitled “By Name“ (if the tab is 
labeled “By Number” or “By Other Criterion”, keep clicking on it 
with the left mouse button until it switches to “By Name”). 

5. In the search pattern field (where the cursor is located), type in 
the initial letter (e.g., “T”), partial word (“Th”) or complete word 
(“The”) of the customer you are searching for. This immediately 
triggers a mechanism that scans the list of customer names — 
you will see rapid movement in the window — and stops once all 
the customers whose name begins with the value you specified 
are displayed in the left-hand column.  

6. Select the customer whose record you wish to view by using the 
up and down arrows  or clicking on the customer’s name with 
the left mouse button (when the list is long, use the scroll bar to 
move up and down through the list of values). The selected 
customer’s number will automatically be inserted into the Number 
column and the Search window will close.  
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Searches using the Search Only from Beginning of Item option are 
conducted by consecutive initial characters. Thus, specifying “Com” will only 
retrieve names that begin with “Com” (e.g., “Computer Heaven”). Searches 
that do not use this option will also retrieve names that contain "Com", such as 
“NewsCom Services”. Searches that use the Ignore case option will also 
retrieve names that contain "COM" or "com" (e.g., Telecom Ltd.). 

Searching by number is very similar to the procedure described above. Click on 
the criterion tab to select “By Number” and proceed to search for a customer by 
number.  

Use the “By Other Criterion” tab under special circumstances when an 
additional search is possible. For instance, the E-mail Address column in the 
Compose Mail form allows for a search by sender name (“By Name”) and by 
e-mail address (“By Other Criterion”). 

Some Search lists also allow you to select more than one list item 
simultaneously (see Figure 22), in the same manner as in standard Windows 
tools: 

To select adjacent items: 

 Click on the first item, hold down the Shift key and click on the last item. 
The entire block of items from the first to the last will be highlighted for 
selection. Press Enter. 

To select several discrete items: 

 Click on the first item, hold down the Ctrl key and click on each item you 
want to select. Each item will remain highlighted for selection. Press 
Enter. 

 

Figure 22: Selecting multiple Search list items 
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Choose Value 

When you open a Choose or Search list that is empty, you automatically 
access the source form, in which the list values are actually defined and 
maintained. When you first begin working with the system and have not 

recorded much data, you will find the  or  button frequently activates a 

form. Once there is even one record in the source form, a Search or Choose 
list will appear. 

You can also reach the source form manually, in order to add listed values, by 
doing one of the following: 

 When in a Choose/Search list, press F6 or the magnifying glass next to 
the column. 

 When in a Search list, press Create Record. 

After recording the data in the source form, copy the relevant value back into 
the form column you were originally working on by clicking Choose Value (see 
Figure 23), by pressing F8 or by clicking the name of the original form 
displayed in the breadcrumbs at the top of the form. 

Note: Ensure that the cursor is on the correct line before activating this feature. 

 

Figure 23: Choosing a value in a source form 

If you wish to leave the source form without copying any value, click the arrow 
next to Choose Value and select Back, or press Esc. 
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Example: 

You want to assign a shipping zone to the "Just Testing" customer and that 
zone has not yet been defined in your company. 

1. In the Customers form, retrieve all customers (click Retrieve All 
Records from the Run menu on the Options Menu) and scroll 
down (e.g., use the vertical scrollbar) until you reach the line for 
the "Just Testing" customer. 

2. In the Shipments tab, move to the Shipping Zone column. This 
actually comprises two separate columns. Make sure the cursor 
is on the leftmost one.  

3. Click on the  button. As the zone you want to assign does not 
appear on the list, you need to access the source form. Press F6. 
The Shipping Zones form will open automatically. 

4. Open a new line and add the zone you want to assign to the 
customer in question (for example, Zone Code = N; Zone 
Description = North). 

5. Without leaving the line, click the Choose Value button next to 
the form name or press F8. The Shipping Zones form will close 
and the zone in question will be inserted in the Customers form. 
From now on, that zone will appear in the Choose list. 

The example above shows how to include a known value in a Choose list by 
adding it to the source form. Additionally, when in a Search list, you can use 
the Advanced Search button to help you find the value you need. By pressing 
the button, you access the source form in Query mode. You can then retrieve a 
record that includes the data you are missing by inputting data that you know, 
as demonstrated in the example below. 

Example: 

You are recording a price quote for a customer and you are not sure 
of the customer's name, but you recall that their office is located in 
Chicago. 

1. In the Price Quotations for Customers form, click the  arrow 
next to the Customer No. column.  

2. In the Search list that opens, click Advanced Search. The 
Customers form opens in Query mode. 
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3. Move to the City column (in the Address/Phone tab), record 
"Chicago" and press Enter. All customers whose addresses are 
located in the city of Chicago will be retrieved.  

4. Scroll down (e.g., use the vertical scrollbar) until you find the line 
with the customer you are looking for. 

5. Without leaving the line, click Choose Value or press F8. The 
Customers form will close and the number of the customer in 
question will be inserted in the Price Quotations form.  

Choosing a Date From a Calendar 

One of the options you can use to specify a date is to choose it from a pop-up 
calendar (see Figure 24 and Figure 25). This option is particularly useful when 
you wish to record a date in the future and need to know the day of the week on 
which it falls. 

There are two pop-up calendars, one of which features both the date and the time. 

Note: In different Windows versions, the calendar looks and functions slightly 
differently. 

 

 

 

Figure 24: Pop-up calendar  Figure 25: Pop-up calendar with time 

To use the pop-up calendar: 

1. From an updateable Date-type column, do one of the following: 

 Click on the   button. 

 Press F6. 

 If the column is currently empty, press the Space bar. 
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2. The calendar displays the current date by default.  

3. To change the month, do one of the following: 

 Click the arrows  to move between months. 

 Press PgUp and PgDn to move between months. 

4. To change the date, do one of the following: 

 Click the desired date (this confirms the date and closes the calendar). 

 Press the left/right arrows () to move between days and the 

up/down arrows () to move between weeks. 
Note: If you are using the date/time calendar, these arrows are used to 
move between time values. 

5. To confirm the chosen date, press Enter. To leave the calendar without 
changing the date, press Esc. 

Note: Remember that the easiest way to select the current date in an empty 
column is to press the + or – key on the number pad. If a date already appears, 
these keys will move the date one day forward or backward, respectively. 

To use the time feature: 

1. Click the hour or minutes box. 

2. Click the buttons to move forward and backward in time. 

Copying From the Field Above 

Sometimes, when adding new records or revising existing ones, you want a 
given column to repeat the same value. If you are working in Multi-Record 
Display Mode, you can simply copy a value from one row to the next. 

To copy the value in a given field to the same field in the next record, move the 
cursor directly below the value you wish to copy and do one of the following: 

 Press F10 or Ctrl+D. 

 Click the Options Menu button, click Edit and select Copy Field 
Above. 

 Right-click the column in question and select Copy Field Above. 

Note: If you are in Full-Record Display Mode, this function will copy data from 
the same column in the previous record (which is currently hidden). 
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Copying Field Values From a Buffer 

The system provides a more sophisticated mechanism that allows you to store 
the value in a given field into a buffer and then copy that value into another field 
— even one in a different form. 

Example: 

You wish to open a new credit card account and change its currency from $ 
to EUR. To do so, take the following steps: 

1. Use the Search for Entity feature (see p. 11) to find and open 
the Currencies form. 

2. Move the cursor to the field in which EUR appears (in the Curr 
column). 

3. Press Ctrl+F9. A small Copy window will pop up (see Figure 26). 
The default for the number of the cell in which the value is stored is 
"1," but can be revised (useful when storing several different 
values). 

4. Click OK or press Enter. The string “EUR” has been saved in a 
buffer. 

5. Find and open the Credit Card Accounts form. 

6. Type a fictitious value in the Account Code and Credit Card 
Company columns (if necessary, open a new line). Note that the 
latter column expands as you type in it. Also note that the Curr 
column is automatically filled in with the $. 

7. Move to the Curr column and backspace to delete the dollar sign. 

8. Press F9. A Paste window will pop up with the number "1". If you 
stored the value in cell number "1", press Enter or click the OK 
button to copy the EUR value from the buffer into this field. 
Otherwise, first revise the number. 

9. Press Esc to leave the Credit Card Accounts form (if you have 
trouble leaving the form, see p. 52). 
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Figure 26: A Copy window pops up 

You can store a series of values in several different buffers, each identified by a 
unique number. So, you can store the value EUR in buffer 1, the value GBP in 
buffer 2 and so on. 

You indicate the number of the buffer that you wish to use in the Copy and 
Paste windows (before pressing Enter or clicking OK). 

In summary, take the following steps to copy field values: 

1. Place the cursor on the field you wish to copy, and do one of the 
following: 

 Press Ctrl+F9. 

 Click the Options Menu button, click Edit and select Store into 
Buffer. 

 Right-click and select Store into Buffer. 

2. A small Copy window will pop up. Designate the number of the buffer 
you wish to use. The next consecutive number will automatically appear 
the next time that the Copy window pops up. You may use the buffer 
number that appears automatically, or you can erase it and type in 
another number. The system contains 100 of these buffers, which can 
be numbered from 0 to 99. 

3. Move to the field in which you wish to paste the stored value, and do 
one of the following: 

 Press F9. 

 Click the Options Menu button, click Edit and select Retrieve from 
Buffer. 

 Right-click and select Retrieve from Buffer. 

4. A Paste window will pop up. Specify the number of the buffer that holds 
the value you wish to copy. The next consecutive number will 
automatically appear the next time that the Paste window pops up. You 
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may use the buffer number that appears automatically, or you can erase 
it and type in another number. 

Copying an Entire Column 

You can also copy all values from an entire form column and then paste them 
where you like (including into an MS-Word file). 

After retrieving all relevant records in the form in question: 

1. Move the cursor to the column in question, on any line. 

2. Do one of the following: 

 Press Ctrl+H. 

 Click the Options Menu button, click Edit and select Copy Column. 

You can now paste the column of values, using Ctrl+V. 

Note: In order to copy and paste all values from an entire form column, you 
must be authorized to Download Form Data (in the Permissions tab of the 
User Permissions form). 

Copying a Record Link 

Priority enables you to include links to specific form records in a text form or 
external document (e.g., an Outlook message or Word document). The link is 
copied into the Windows clipboard and can then be pasted where desired. 

To copy a record link: 

1. Retrieve the record in question and do one of the following: 

 Press Ctrl+Y. 

 Click the Options Menu button, click Edit and select Copy Record 
Link. 

 Right-click the column in question and select Copy Record Link. 

2. To paste a record link that has been copied, move the cursor to the 
proper place in a Priority text form or external document and press 
Ctrl+V. 

Importing Files to a Form Record 

Several system forms allow you to attach a file to a form record, for example, 
Customer Documents for Task, a sub-level of the Tasks form. In order to 
allow other users in the system to access a file that is stored on your hard disk, 
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use the Import function to copy the file onto the Priority server, in the 
..\..\system\mail directory.  

To do so, do one of the following: 

 Right-click the relevant icon and select Import from the pop-up menu 
(see Figure 27): 

 In the column—a paper clip , or 

 The folder icon  in the Direct Activations menu. 

 Press Ctrl+I. 

 

Figure 27: Importing a file to a form 

Tip: You can attach several files simultaneously by holding down the Ctrl key 
and right-clicking on each item you want to attach. 

In a similar fashion, you can paste a file from a Windows clipboard into an 
attachment column, at the same time importing it into the ..\..\system\mail 
directory.  

To capture files to a Windows clipboard, do one of the following: 

 Copy the desired file from the Windows Explorer or from an MS-Outlook 
attachment (e.g., by Ctrl+C). 

 Capture a screen shot to the clipboard (e.g., using the Print Scrn key or 
Windows Snipping Tool). 

To paste and import the captured file: 

 Right-click the relevant column icon and select Paste and Import from 
the pop-up menu. 

 Move the cursor to the File Path column and press Ctrl+V. 
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Notes:  

 The above instructions also apply when attaching images to a form record 
(e.g., in the Part Catalogue; see Figure 28). 

 Column icons (e.g., a folder or paper clip) will not appear if the No Image 
Display option is flagged (in the Design menu accessed from the Options 
Menu button). 

 

Figure 28: Importing an image to a form record 

Attachment forms also contain a File Status column, allowing you to update 
the attachment's status to Read Only. This is useful when you are working with 
the attached file and you do not want other users to view and/or modify the file 
at the same time. Make sure to return the file's status to Free when you are 
done working with it. 

Copying a Link 

You can also include links to any files that have been attached to form records 
in a text form or external document (e.g., an Outlook message or Word 
document). The link is copied from an attachment column into the Windows 
clipboard and can then be pasted where desired. 

1. To copy a link, do one of the following: 

 Press Ctrl+Y. 

 Right-click the relevant column icon and select Copy Document Link. 

 Click the Options Menu button, click Edit and select Copy Record 
Link. 

2. To paste a link that has been copied, move the cursor to the proper 
place in a Priority text form or external document and press Ctrl+V. 
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Duplicating Attachments 

To duplicate an attachment, right-click the relevant column icon and select 
Duplicate. A duplicate of the file will be created on the Priority server and 
appear as a separate line in the attachments form (i.e., will be attached to the 
same record in the upper-level form). Each copy created from a given file will 
be saved with the same name, and a different sequential number will be 
appended automatically to the end of each file name. Once created, duplicate 
files can be modified as needed. 

Removing Attachments 

To remove an attachment from a form record, right-click the relevant column 
icon and select Clear. The file will be removed from this record, but will not be 
deleted from the Priority server. 

Tracking Documents 

You can track certain documents in Priority. While you are tracking a 
document, every time it undergoes certain changes, you will receive notification 
by e-mail. Additionally, you may retrieve the document in question in the 
Tracking List form. 

To start tracking a particular document, do one of the following: 

 Click  in the row of shortcuts so that it turns black . 

 Right-click anywhere in the form in question, and select Track 
Document. 

 Click the Options Menu button, click Mail, and select Track Document. 

To stop tracking the document, do one of the following: 

 Click so that it turns white . 

 Right-click anywhere in the form in question, and select Stop Tracking 
Document. 

 Click the Options Menu, click Mail and select Stop Tracking 
Document. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 49 

Fixing Mistakes 

Errors and Warnings 

Warning messages appear whenever you make a minor error in form entry or 
revision. In such a situation, you are warned about the consequences of that 
error, but are nevertheless allowed to continue. In contrast, when there has 
been a major error, you receive an error message and must make the 
necessary corrections in order to continue. 

Before you can do anything, you must confirm receipt of the message:  

 In the case of an error message, click OK or press Enter.  

 In the case of a warning message, you may either cancel your last move 
or continue: 

 To cancel, press Esc or click on the Cancel button. 

 To continue, press Enter or click on the OK button. 

Note: Sometimes the message refers you to another form, a program or a 
report that can help you. You can access this entity by clicking on its name in 
the message. 

Undo 

Often the best way to correct an error is to undo previous actions. 

To undo the actions you have performed within a specific field, do one of the 
following: 

 Click  in the row of shortcuts. 

 Press Ctrl+Z. 

 Click the Options Menu button, click Edit and select Undo. 

To undo modifications in several fields in the same record, repeat any of the 
above actions a second time. 

Notes:  

 You can also clear a single field, without affecting any other fields, by 
pressing Ctrl+U. 

 You cannot undo actions once you have left the record (e.g., exited the line, 
moved to Query mode). In such a case, you will have to retrieve the record 
and revise it manually. 
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Clearing the Line 

Sometimes you may find yourself unable to leave the record because of an 
error message. This could occur when you open a new record and then change 
your mind (e.g., because you don’t yet have all the mandatory data that you 
need to complete the record). Or it may happen when you are trying to update 
a record and have deleted necessary data or inputted an unacceptable value.  

Whenever you find yourself in such a situation, the first step to take is to try to 
undo your latest changes, as outlined above. If that does not help, you should 
clear the line. If this is a new, incomplete record, clearing the line will erase it 
altogether. In the case of an existing record, this action will cancel all 
modifications you have made and “hide” the record from the form.  

To clear the line, take one of the following actions: 

 Press F7. 

 Click the Options Menu button, click Edit and select Clear Line. 

 Right-click a column and select Clear Line. 

If you have been working on a new record, you should now begin again. If you 
have been revising an existing record, retrieve it and make your revisions 
again. 

Note: If you succeeded in leaving the line, the record was modified and 
clearing the line will not return it to its original state. You will have to make any 
further revisions manually. 

Deleting a Record 

To delete an unwanted record from the database, position the cursor on that 
record and do one of the following: 

 Click the trash can on the row of shortcuts. 

 Press Ctrl+Del (or Ctrl+Delete). 

 Click the Options Menu button, click Edit and select Delete Record. 

 Right-click a column and select Delete Record. 

In all cases, a window will pop-up requiring you to confirm the deletion. Click 
OK or press the left arrow key, followed by Enter. 
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Note: Not all records can be deleted in this way. For example, you must run a 
special program to delete a part. Moreover, you cannot delete a record that is 
being used elsewhere in the system. For instance, you cannot delete a price 
quotation once an order has been based on it. 
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Troubleshooting 

The following offers concrete suggestions for dealing with problems you might 
encounter in a form. 

 

IF… THEN… 

You are unable to leave the line or 
form because you have filled in 
erroneous information (e.g., when 
recording an order, you specify a 
customer that does not exist in the 
database). 

1. Confirm the error message. 

2. Try to undo your last action 
(press Ctrl+Z). Press it again to 
undo more actions, if necessary. 

You are unable to leave the line or 
form because mandatory data is 
missing. 

1. Confirm the error message. 

2. Fill in the missing information, if 
you have it. If you do not, clear 
the line (press F7). In the latter 
case, the database will not be 
updated. 

You have added a new record and 
don’t know how to confirm the 
update. 

The database is updated whenever you 
leave the line. This can be done in a 
variety of ways: 

 Move the cursor to any other line 
in the form. 

 Move to Query mode (press 
F11). 

 Exit the form (press Esc). 

 Enter a sub-level form (press 
F12). 

You are in Full-Record Display Mode 
and have added a new record. You now 
want to add another record, but don’t 
know how to reach the next line. 

Press PgDn. 
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IF… THEN… 

You are in Full-Record Display Mode 
and the record you have added 
seems to have disappeared. 

It hasn’t disappeared; it’s merely hiding. 
Press F4 to move to Multi-Record 
Display Mode. 

Or stay in Full-Record Display Mode 
and press PgUp to scroll through 
previous records. 

You are unable to add data to the 
form. 

You may be in a query form. If so, you 
can only use this form to view records. 

Or you may be in Query mode (used to 
retrieve records) — check if the field you 
are in is outlined in green (usually, the 
vertical scroll bar is also green). To 
return to Data Entry mode, press Enter. 

 

Data Retrieval (Queries) 

Up till now, you have practiced entering new records into the database. The 
current section explains how to retrieve existing records in a given form so that 
you can view and/or revise them. This is in addition to the option of using the 
Search Bar to find a given record (see p. 8).  

As you’ve already seen, the easiest way to access existing data is to retrieve all 
records. To do so, click the Options Menu button, click Run and select 
Retrieve All Records.  

This method, however, is apt to be unnecessarily time-consuming once you 
have a great many records in a given form. In that case, it is advisable to 
narrow down the retrieval procedure, based on query conditions (also known as 
retrieval criteria).  

Priority provides a variety of techniques for retrieving selected data in the 
system’s forms. By switching from Data Entry mode into Query mode, you can 
define any combination of query conditions by which the desired data is 
retrieved when the query is executed.  

Alternatively, you can run the Query Generator, which features a friendly 
interface for defining query conditions, setting data-sorting parameters, 
executing queries and storing frequently-used queries for easy access. 
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The following section will describe the basic usage of both the Query mode and 
the Query Generator. More sophisticated query tools are described under 
Advanced Data Retrieval and Input (p. 152). 

Working in Query Mode 

There are two modes of working with Priority forms: Data Entry mode for 
recording data and Query mode for retrieving records. When you are in Query 
mode, the magnifying glass icon in the row of shortcuts and the column in 
which the cursor is located are highlighted in green. To move from Data Entry 
to Query mode, do one of the following:  

 Click  in the row of shortcuts. 

 Press F11 or Ctrl+R. 

 Click the Options Menu button, click Run and select Query/Clear 
Form. 

If you are working in Multi-Record Display Mode, your cursor will be in the 
second row of the form, and all the other rows will be blank. 

To exit Query mode without retrieving any data, simply press Enter. 

Note: Query conditions are always designated in the second row of a multi-
record form; the first row is reserved for operators (see p. 159).  

Designating the Query Conditions 

The simplest type of query is one in which you seek to retrieve all records that 
contain any value in one or more specific columns. For this you can use the 
asterisk (*) symbol, known as a wildcard, because it represents an unknown 
quantity of records. 

To retrieve all records that contain a value in one or more specific columns: 

1. In Query mode, move to the desired column and type in an asterisk. 

2. Repeat the process for additional columns, if necessary. 

A narrower type of query is one in which you seek to retrieve all records that 
contain a particular value in one or more specific columns.  

To retrieve all records that contain a given value in one or more specific columns: 

1. In Query mode, move to the desired column. 

2. Specify the desired value, either manually, by Choose list or by Search list. 
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3. Repeat the process for additional columns, if necessary. 

The third type of query is one in which you seek to retrieve all records whose 
values in a given column satisfy a certain condition. 

This is where the asterisk wildcard is most useful, because it can be used in 
conjunction with a string of characters, such as a prefix or suffix. For example, 
if you type 50* in the Part Number column of the Part Catalogue, you will 
retrieve all parts whose numbers begin with 50 (e.g., 501-101, 501-102).  Note 
that this kind of query condition is always case sensitive. 

Note: If you want to record a query condition with a string that includes an 
asterisk (*) as an actual character, use the backslash “\” as a delimiter. For 
example, to retrieve all records that contain an asterisk, type *\**. For more 
details, see p. 158.  

Executing the Query 

To execute a query, do one of the following: 

 Press Enter. 

 Click the Options Menu, click Run and select Execute Query. 

Following execution of the query, the retrieved records will be displayed on 
screen and you will move automatically from Query mode back to Data Entry 
mode. It is now possible to update any displayed records.  

Note: If you are working in Full-Record Display Mode, you will only see the first 
of the retrieved records. Use the PgDn key or the vertical scroll bar to view the 
rest of the retrieved records.  

Examples: 

In the Currencies form, move to the Currency Name column and try out 
the following conditions (remember to enter Query mode): 

1. Type P*. You will retrieve those records whose currency name 
begins with the letter “P” (Pounds Sterling, Price Index).  

2. Type I*s. You will retrieve any currency whose name begins with 
“I” and ends with “s” (e.g., Italian Liras).  

3. Type *n. Any currency whose name ends with the letter “n” will 
appear (e.g., Yen).  
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4. Type D*M*s. This will retrieve any currency that begins with “D”, 
ends in “s” and has an “M” in the middle (Deutsche Marks). 

5. Type *Francs. You will retrieve the records for Belgian Francs, 
French Francs and Swiss Francs. 

Whereas the asterisk replaces an entire string of characters, the question mark 
is a wildcard that replaces a single character. It is generally used in conjunction 
with one or more characters and may even be combined with the asterisk. 

Examples: 

1. Type Y?? in the Currency Name column. You will retrieve any 
currency that is three characters long and begins with “Y” (i.e., 
Yen). 

2. Type D?ll?r?. You will retrieve the record for Dollars. 

3. Type *i?g. This will retrieve any currency whose name begins 
with any string of characters, followed by an “i”, followed by any 
single character, and ending in “g” (e.g., Pounds Sterling). 

Sorting Retrieved Records 

The records that are retrieved in a form are sorted by one or more columns, 
determined by the designer of the form. This is the default sort. However, when 
in Multi-Record Display Mode, you can re-sort records after they have been 
retrieved.  

Clicking once on the title of any column gives you an ascending sort; click 
again and the data will be sorted in descending order. A further click repeats 
the ascending sort. A small triangle appears below the column title when you 
perform a sort – if the sort is ascending, it points up; if descending, it points 
down. 

You can also generate an ascending sort by right-clicking a column and 
selecting Sort from the pop-up menu; select it a second time to obtain a 
descending sort. 

Note: User sorts are always temporary and apply only to the specific query; 
sort conditions always return to the default each time you execute a new query. 

Example: 

Retrieve all records in the Currencies form (click Retrieve All Records in 
the Run menu of the Options Menu). 
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1. You will notice that the default sort order in the Currencies form is 
ascending according to the Position column; i.e., local currency, 
which is assigned position 1, appears in the first form row, the 
second currency (assigned position 2) is displayed in the second 
form row, and so forth.  

2. Click on the Currency Name column heading. Records will be re-
sorted alphabetically by name.  

You can experiment with the effects of sorting by clicking and re-clicking on 
the different columns in the form. 

Note: The generator allows you to set sorting parameters together with the query 
conditions, in advance of the query’s execution (see next section). To learn more 
sophisticated sort methods, see Advanced Data Retrieval and Input (p. 152). 

The Query Generator 

The Query Generator (Figure 29) is a powerful tool that allows you to 
compose, store and reuse queries directed at the specific form in which you 
open it.  

To enter, do one of the following from within a form: 

 Click , located at the top of the screen. 

 Press Shift+F11. 

 Click the Options Menu button, click Run and select Query Generator.  

The first column of the generator lists the titles of all of the fields in the upper-
level form (in Full-Record Display Mode, these are organized according to their 
tabs). The second column is for operators (e.g. >, <), which can be used in 
conjunction with data in the Value column to define the query conditions. For 
example, =>1 in the Exchange Rate column indicates a query for all currencies 
with an exchange rate higher than 1.00. If you use an equal sign (=) without 
specifying a value, you will retrieve all records that have no value in that column.  

Alternatively, you can use the Value and To Value columns to define the query 
conditions as a closed range of values. For example, 1 to 2 indicates a query for 
all currencies whose exchange rates fall between 1.00 and 2.00. 

To retrieve all records that have been flagged in a particular check box, flag the 
box that appears in the Value column of the appropriate line. To retrieve all 
records that have not been flagged in that check box, select an equal sign (=) in 
the operator column (without flagging the box). 
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The Sort column is where you can prioritize your query results on multiple 
levels. The little check box within the Sort column is used to define whether a 
particular sort is in ascending or descending order. For example, a 1 next to 
an upward-pointing arrow in the Currency Name line indicates that the 
retrieved currencies should be listed by name in alphabetical order. If you add a 
2 next to a downward-pointing arrow in the Exchange Rate line, it means that 
any currencies in the alphabetized list that have the same name should be 
listed in order of the highest exchange rate. 

 

Figure 29: The Query Generator run from the Currencies form 

Example: 

1. Enter the Currencies form and open the Query Generator.  

2. In the Currency Name line, type an asterisk in the Value column 
and click the Sort column. 

3. In the Exchange Rate line, type “1” in the Value column and “2” 
in the To Value column.  

4. Click OK to run the query (see Figure 30). 

The resulting query could be written, “Retrieve all currencies with an exchange 
rate between 1.00 and 2.00 and sort the results alphabetically by name”. 

You can also flag the Ignore Case option at the bottom of the generator so that 
the search is not case-sensitive. 
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The Add button at the bottom of the generator allows you to run a new query 
that adds to the data retrieved in the previous query, without overwriting it. The 
Clear button at the bottom of the generator clears the Query Generator interface 
so you can compose a new query. 

 

Figure 30: The example query 

There are two methods of choosing a date value as a query condition: 

 Left-click the calendar icon to choose from a list of relative dates (e.g., 
tomorrow, week end, month start). This is particularly useful when 
creating a query that you intend to save and use again. 

 Right-click the icon to open the usual calendar. 

Example: 

1. Enter the Currencies form and open the Query Generator.  

2. In the Exchange Rate Date line, select the “Greater than 
or equal to” operator (>=), click the calendar icon in the 
Value column and select “Start of this Week”. 

3. Click OK to run the query. 

The resulting query could be written, “Retrieve all currencies whose exchange 
rates were updated since the beginning of this week”. 
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Saving Queries for Repeated Use 

When you open the Query Generator, no parameters are displayed. To 
automatically reuse the last query made to this form, click the Prev button in 

the Last Queries section at the bottom of the generator (or press Shift+). To 
reuse the query made before that, click Prev again. To return from the next-to-

last query to the last query, click the Next button (or press Shift+). The 
generator automatically saves the last five queries. 

In addition, you can save up to nineteen queries of your own choosing for easy 
retrieval. To do so, define the query, record a name for it in the Queries field at 
the bottom of the generator and click Save, before running the query. To call up 
the query, click on the drop-down button to the right of the Queries field and 
choose the query you just defined. You can even run the query from the form 
itself, without even entering the Query Generator. Simply choose the desired 
query from the drop-down list at the top of the screen. To rerun the selected 
query, click Show. 

For additional query design options, click the Design button at the bottom of the 
generator. Use the up and down arrows to the right of the screen to arrange the 
saved queries in the desired order. You can also right-click any query to 
rename or delete queries that you do not need.  

Notes:  

 If you save a query under a name that has already been used for another 
query, a message will appear requesting permission to overwrite the old one. 

 If the Ignore Case option is flagged, this is saved as part of the query. 

 You can also execute any of the first nine saved queries from a given form 
by pressing Ctrl+ plus the number assigned to the query in the Query 
Design screen (for example, if the desired query is assigned the number 3, 
press Ctrl+3). 

 While your saved queries do not affect other system users, your system 
manager can run a program that copies saved queries from one user to 
another. 

The Default Query 

You can choose one query that you always use with a particular form to be the 
default query. After saving the query as usual and assigning it any of the first 
nine positions within the list of saved queries, click the Design button at the 
bottom of the generator, right-click the query in question and select Set as 
Default Query. The number to the left of the query will appear in red, indicating 
that it has been set as the default. The default query executes automatically 
every time you open the form. If you are in Data Entry mode and you want to 
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execute the query again, you can do so either by pressing Ctrl+0, without 
entering Query mode or the Query Generator. You can also execute it from the 
Query Generator by choosing it from the drop-down list in the Queries section 
and clicking OK. 

Notes:  

 To delete the default query, open the Query Generator, click the Design 
button, right-click the query, clear the check mark that appears by the words 
Set as Default Query and, finally, click OK. 

 If you assign the default query a position between 10 and 19 within the list of 
saved queries, it will cease to function as the default query. 

Example: 

1. Open the Query Generator from the Customers form. 

2. In the Name line, specify an asterisk (*) in the Value column. 

3. In the same line, click the Sort column. 

4. Move to the bottom of the Query Generator, record a name for the 
query in the Queries field at the bottom of the generator and click 
Save.  

5. Click the Design button, right-click the query you just defined and 
select Set as Default Query. Click OK to save your selection. 

6. Click OK to run the query. This query simply retrieves all 
customers and lists them alphabetically by name. The next time 
you open the Customers form, the default query will run 
automatically. That is, the form will fill up with all customers, in 
alphabetical order. 

Searching for a Specific Record in Query Results 

Once you have retrieved a number of records, you may want to perform a 
search in order to locate a specific one. A search is carried out in a particular 
column. The first time that you execute a search, you have to define a search 
pattern (one or more characters). The Search box will display the first record 
that matches the designated pattern.  

To do so, after retrieving a number of form records, move the cursor to the 
desired column and perform one of the following: 

 Press Ctrl+F3. 

 Click the Options Menu button, click Edit and select Search. 
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 A Search window appears, in which you specify the pattern (see Figure 
31). If you want the search to be case sensitive, remove the check mark 
from the Ignore Case box. Finally, execute the search by clicking OK or 
pressing Enter.  

 

Figure 31: Example of a Search window 

Example: 

1. Retrieve all records in the Currencies form (click the Options 
Menu button, click Run and select Retrieve All Records.) 

2. Move to the Currency Name column. 

3. Use one of the above options (e.g., Ctrl+F3) to access the Search 
window. 

4. Inside the window, type “x” and check the Ignore Case box.  

5. Execute the search. 

The cursor will automatically jump to the record for Price Index.  

Now, perform the same steps, but type “D” instead of “x”. The cursor will 
jump to the next currency whose name begins with a “D” (e.g., Dollars). 

Once a search pattern has been defined, you can use the Search Again feature. 
This repeats a search utilizing the last defined search pattern. To do so, 
perform one of the following: 

 Press F3. 

 Click the Options Menu button, click Edit and select Search Again. 

Example: 

Search for the next currency with “D” in its name, using one of the Search 
Again options (e.g., F3). This search may lead you to Deutsche Marks. 
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The initial search (when the pattern is first defined) is limited to the column in 
which the cursor rests, scrolling from top to bottom and back to the top. As 
movement is circular, the procedure will move you to the first matching field in 
the form if there is no matching field below the cursor. 

When you repeat a search (using the Search Again feature), it is always 
performed in the same column in which the search pattern was originally 
defined, regardless of where the cursor now rests. The cursor, however, will not 
necessarily move to the matching field. Rather, it will jump to the next matching 
record, remaining in the column in which it rested before the search was executed. 

Hiding Retrieved Records 

Occasionally, after retrieving a number of records, you may prefer to view only 
some of them. You may “hide” certain records so that they are not displayed on 
the screen, although they continue to exist in the database (that is, the records 
are not deleted). 

Records are hidden by clearing the line. There are four ways to do so: 

 Press F7. 

 Click the Options Menu button, click Edit and select Clear Line. 

 Right-click any field in the line and select Clear Line. 

To view hidden records again, simply retrieve them anew. 

Problems Retrieving Records 

You may sometimes find yourself in a situation in which you are trying to retrieve 
a record, yet fail to do so. The reason for this is generally because you forgot to 
enter Query mode; remember, when you first enter a form, you are by default in 
Data Entry mode. First undo your actions (see p. 49). Then simply move to 
Query mode (e.g., press F11), enter the data again and execute the query. 

Query Forms 

The system contains special forms intended for record retrieval only. You 
cannot update or delete records in these forms, nor can you use them to add 
new records to the database. You can only view existing records. If you 
accidentally attempt to make revisions in this type of form, you will receive an 
error message stating, “This is a query form.” 

Accessing Forms Within Forms 

This feature is an efficient way to move from one form to another related one, 
bypassing the menus. It allows you to view pertinent information in the source 
form without ever leaving the original form. In fact, once you arrive at the 
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source form, you can add new records or revise existing ones and then copy 
the value in question back to the original form. 

Not all columns support this feature, only those that display a magnifying glass 

 button to the right of the column.  

To access the target form, do one of the following: 

 Click the  button. 

 Press F6. 

 In an empty column, press the Space bar. 

Example: 

1. Find and enter the Audit Trail form. 

2. Enter the Query Generator and type “Sales*” in the Value column 
of the Inv. Transaction line.  

3. Click OK. All transactions beginning with the word “Sales” will be 
retrieved. Your cursor should be on a line for a Sales Invoice. 

4. Move to the next column (Doc/Invoice Number) and click the 

activation  button. You will now find yourself in the Sales 
Invoices form, in the original record of the transaction.  

5. To return to the Audit Trail form, click the breadcrumb link at the 
top of the form or press Esc. 

Note: It does not matter whether you are in Query or Data Entry mode when 
you access a form. You will return to whatever mode you were in. 

Summed Values 

Priority provides a special data retrieval function in form columns that list 
numerical values (e.g., Actual Cost). To calculate the sum of all values in a 
given number column, move to Multi-Record Display mode (e.g., by pressing 
F4) and right-click the column title. To sum up a portion of the column, move 
the cursor to the desired number column and press Ctrl+F8. The system 
calculates the sum of all values in that column, from the top of the form to the 
line in which the cursor is placed. In either case, the calculated sum is 
displayed in a small pop-up window.  

You can then copy the value from the pop-up window (e.g., by Ctrl+C), and 
paste it into a different column, text form or external document. 
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Note: In order to sum up values in a column, you must be authorized to 
Download Form Data (in the Permissions tab of the User Permissions 
form). 

Online Features 

 The E-mail Address column found in many forms features an E-mail 

 button that opens the Compose Mail form with the address filled in. 

 The Web Site column features a Browser  button that automatically 

opens your web browser to the given URL. 

Updating Data 

Once you have retrieved existing data, you may wish to revise it. You already 
know various methods to do this: 

 Select a (different) value from a Choose or Search list (p. 32). 

 Copy and paste from a Windows clipboard (p. 32). 

 Copy the value from the previous line in the form (p. 42). 

 Copy the value from a buffer (p. 42). 

The following provides some additional tips for updating data. 

Scroll vs Edit Mode 

When you are recording new records or viewing retrieved ones, you want to 
move rapidly through the various fields. But when you are revising an existing 
record, you often need to be able to move within the field. For instance, if you 
have recorded an erroneous part number 165543 and want to correct that to 
195543, you would like the ability to move to the left, past the correct digits, to 
the erroneous “6”.  

You can choose between rapid movement between columns (scrolling) and 
movement within a given field (editing) with the press of a button. You simply 
toggle between Scroll and Edit modes. 

When in Scroll mode, the left and right arrow keys  move the cursor from 
one column to the next. When in Edit mode, the same keys move the cursor 
from one character to the next, within a given field.  

In both modes, you can move to the next column by using the Tab key (or 
Enter key) and move to the previous column by pressing Shift+Tab.  
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To toggle between Scroll and Edit modes, employ one of the following 
methods: 

 Press F2. 

 Click the Options Menu button, click Edit and select Scroll/Edit. 

Note: You are automatically in Scroll mode whenever you enter a form. 

Sub-level Forms 

The forms in which you have worked until now were all upper-level forms (or 
root forms) entered directly from the menu. Most root forms have at least one 
sub-level form connected to them. Sub-level forms provide further information 
on a given record in the upper-level form. For each single record in the upper-
level form, multiple records may appear in the sub-level. The line in the upper-
level form must have data in it. 

Note: There is a design tool for organizing sub-level forms (changing their 
order; hiding those you don't use). For details, see p. 120. 

Example: 

As soon as you open the Currencies form, its sub-level form, Past 
Exchange Rates (a query form), is visible directly below it. 

Entering the Default Sub-level Form 

The tab of the default sub-level form appears in front of the rest of the sub-level 
tabs and its title appears in bold. This default changes dynamically whenever 
you select a different sub-level form.  

To move into the default sub-level form, first make sure a record has been 
retrieved in the upper-level form and then do one of the following: 

 Click on any row in the sub-level form. 

 Press F12. 

 Click on the highlighted sub-level tab. 

 Click the Options Menu button click Run and select Default Sub-level. 

You can view all records connected to the record that is highlighted in the 
upper-level form. Note that you are in Data Entry mode, enabling you to add 
new records and/or revise existing ones in the sub-level. 
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Tip: To enter the sub-level form without retrieving all records, press Ctrl+F12. 
This is useful when there are many such records, which may take a long time 
to load. 

Returning to the Upper-level Form 

To return to the upper-level form from a sub-level, do one of the following: 

 Click anywhere in the upper-level form, using the left mouse button. 

 Press Esc. 

Choosing a Different Sub-level 

Most upper-level forms have several sub-level forms connected to them. When 
the number of sub-levels exceeds the quantity that can be viewed at one time, 
numbered buttons appear to the right of the tabs. Click on the buttons to 
access additional tabs, or use the arrows at either edge of the buttons to 
navigate back and forth (see Figure 32).  

 

Figure 32: Sub-level tabs 

For any given upper-level form, only one sub-level form can be displayed at a 
time. Initially, this is the first one in the list. 

To choose a different sub-level form, do one of the following: 

 Click the tab for the desired sub-level form. 

 Press F5. 

 Click the Options Menu button, click Run and select Sub-levels. 

In the latter two cases, a window will pop up displaying a list of all available 
sub-levels (its contents will be identical to the sub-level tabs).  
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You can move between sub-level forms without going back to the upper-level 
form; either click on the desired sub-level tab, or press Alt  and Alt  to 
move from one sub-level form to another.  

Once you choose a different sub-level form, it temporarily becomes the default 
— until you exit the root form. Its tab will be up front and in bold. As the default 
sub-level, it can now be accessed again, for instance, by pressing F12. 

Active and Passive Modes 

When you are in Data Entry mode, any upper-level form can be either Active 
or Passive. You are in Active mode when you are working in an existing record 
(e.g., revising data, moving from one column to another). You are in Passive 
mode when you are scrolling through records, moving from one row to another.  

The active or passive state of a given upper-level form affects the display of 
records in its sub-level. 

This is best illustrated via a concrete example. 

Example: 

1. Enter the Customers form and retrieve all customer records, then 
switch to Multi-Record Display Mode. Data appears in the sub-
level form. 

2. Move from one form column to another in the same line (e.g., 
from Customer No. to Customer Name). The form remains 
active and data continues to appear in the sub-level form. 

3. Now move down a line. As soon as you do, you will note that the 
sub-level form no longer displays any data.  

4. Remaining in the second line of the form, press any key (e.g., the 
right arrow, the space bar); the sub-level form, which was empty a 
moment ago, now displays data for the second customer. 

As you have seen, in Active mode, the sub-level form displays all records 
connected to the highlighted record in the upper-level form. 

In Passive mode, however, it is not possible to view the records in the sub-
level. This is meant to facilitate the scrolling from record to record in the upper-
level form. If records were displayed in the sub-level during scrolling, the 
movement between records in the upper-level form would become slow and 
cumbersome.  
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In short, whenever you move to a different record in the upper-level form, you 
automatically enter Passive mode. By pressing any key (except, of course, the 
up and down arrows that move you between rows), you enter Active mode. 

Sub-levels of the Sub-level Form 

Any sub-level form can have sub-levels of its own. The sub-level of a sub-level 
functions just like any other sub-level. 

Text Forms 

There is a special type of sub-level form called a text form, which is frequently 
identified by the word “Remarks” in the title. For instance, the Entry Journal 
form, the various invoice forms, and the Compose Mail form (see p. 181) have 
such sub-levels.  

When in a text form, you access the Text Editor, which enables you to type a 
long message using many standard text-editing tools. You can cut, copy and 
paste text freely, add hyperlinks and change the fonts.  

Alternatively, you can enter a text form in read-only mode. To do so, simply 
perform one of the following actions in the upper-level form:  

 If the text form is the default sub-level for this form, press Ctrl+F12. 

 Press Shift+F5 and then select the sub-level in question. 

Using the Text Editor 

Once you enter the text form (see Figure 33), you can: 

 type freely (use Backspace and Delete keys as needed); 

 scroll through the text using vertical and horizontal arrows, or move by 
clicking the mouse (in a long text, use the scrollbar to the right to access 
additional lines); 

 highlight text (e.g., click and drag as you would in a word processor);  

 cut or copy highlighted text and paste it elsewhere; 

 undo the last action performed (Ctrl+Z); 

 redo the last canceled action (Ctrl+Y); 

 change the font type, size and color; 

 set text color; 

 modify text alignment; 

 add numbers and bullets to text; 

 add additional graphic elements such as horizontal lines, images and links; 
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 perform a spell check (on all text or only the selected portion), and 
correct any errors by right-clicking the highlighted text and selecting the 
desired spelling alternative (of course, these highlights will not be visible 
in printed documents or e-mails created from the text in this form); 

 add a comment preceded by a dividing line, the date and time, and 
followed by a greeting and user signature; 

 search for text within the form (Ctrl+F); 

 manually save text without leaving the form. 

Use the Toolbar icons or their shortcut keys to perform the above functions. 

 

Figure 33: The Text Editor 

Notes:  

 Not all of the shortcuts use the standard Windows keys. Hold the 
cursor over each Toolbar icon to display its shortcut. Also see . 

 The HTMLUPDATE system constant determines whether user comments 
appear at the top or bottom of text forms throughout the system. 

 The AUTOSAVETEXT system constant determines how frequently (in 
minutes) text recorded in text forms is automatically saved, throughout the 
system. After the third time the text is automatically saved, the text form is 
closed automatically, enabling other users to access it.  

Once you have finished composing/revising your text, leave the form as usual. 

Adding Pictures to a Text Form 

You can add one or more pictures to a text form, using any type of image file 
(e.g., .bmp, .jpg) by entering the picture's URL (see Figure 34). To do so, place 
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the cursor at the location in the text form where you want to insert the picture 
and then perform one of the following: 

 Click the Picture  icon on the Text Editor Toolbar. 

 Press Ctrl+P. 

Alternatively, if the picture in question has already been imported to Priority as 
an attachment, you can copy a link to the attachment (e.g., by Ctrl+Y) and then 
paste it instead of the URL (e.g., by Ctrl+V).  

Insert the picture by clicking OK or pressing Enter. 

Note: Users of Internet Explorer have the option to browse for the file in 
question. 

 

Figure 34: Adding a picture 

Additionally, you can paste a picture from the Windows clipboard (e.g., a 
screen capture or copied image file) into a text form, which will import the 
picture into the ..\..\system\mail directory.  

Customizing User Comments 

To customize your default comment format, open the File menu in the Options 
Menu and select User Signature. A parameter input screen pops up in which 
to choose between a signature for documents or for text forms. Choose the in 
Text Forms option. 

A second parameter input screen appears, in which you can indicate which 
elements you want to display, choose a font size, and compose a personal 
greeting (see Figure 35).  

User information (e.g., Position, E-mail) is taken from your personnel file. Your 
Name is taken from the Full Name column of the Users form. 
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Figure 35: Defining the default comment format 

Direct Activations 

Many forms offer direct activations of other forms, reports and programs. That 
is, without ever leaving the form that you are working in, you can move to a 
target form, print a report or run a program. 

The Direct Activation feature is useful in a variety of situations. You can use it to: 

 Print out an invoice immediately after recording it. 

 Display a price quote on the screen before printing it. 

 Convert a potential customer into a regular customer. 

 Access the Chart of Accounts Receivable from the Customers form. 

Viewing Available Direct Activations 

Whenever direct activations are available for a form, they appear in the Direct 
Activations menu on the right side of the screen (Figure 36). This menu 
includes all forms, reports and programs that can be reached from this form. 

Note: Click Ctrl+F5 to obtain the same list in a pop-up window at the center of 
your screen. 
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Figure 36: Direct Activations menu in the Customers form 

The icon preceding each entity title in the Direct Activations menu identifies 
each item’s type (i.e., form, report, program). If the list is very long, it is divided 

into parts, which can be accessed by clicking on the numbered buttons . 

Example: 

When you are in the Customers form, the Direct Activations menu 
contains many items. 

Some of the forms that can be opened are: 

 Financ. Parameters for Customers 

 Chart of Accounts Receivable 

 Tasks 

 Projects 

Some of the programs that can be executed are: 

 Convert Potential Cust to Cust 

 Delete Potential Customer 

 Print Customer’s Document Set 

How to Perform Direct Activations 

While you can sometimes perform a direct activation from an empty form, it 
makes more sense to first retrieve pertinent records. For instance, you 
obviously can’t delete a potential customer unless your cursor is presently 
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situated on the record for the potential customer you wish to remove from your 
database. 

When you reach a form by direct activation, you can retrieve, modify and/or 
add records to that form. Alternatively, you can simply leave that form and 
return to the one in which you were originally working (e.g., press Esc). Most 
importantly, you can use the Choose Value feature (see p. 39) to copy a 
column value from the new form into the original one. 

When you directly activate a report or program, input is usually taken from the 
current form record (rather than from a parameter input screen). The cursor will 
return to this same record after the report is printed out or the program is 
completed. If the program has updated a value in the record, you will be able to 
see the updated value (for example, if you have converted a potential customer 
into a regular customer, you will see that a new customer number has been 
assigned). For more on reports and programs, see p. 80. 

Creating and Using Macros 

You will occasionally need to perform a sequence of several actions (mouse 
clicking, keystrokes) in order to carry out a particular operation. When a set of 
actions is used frequently, you can define a macro that will perform them 
automatically. 

Defining a Macro  

To define a macro, carry out the following steps: 

1. Click the Options Menu button, click Run, select Macros and then 
Start Definition. 

2. A dialogue box will pop up in which you are asked to assign a name to 
the macro. This name will later be used to call up the macro, so try to 
make it as intuitive as possible. (If you specify a name that you have 
already assigned to an existing macro, you will receive a warning 
message that the original macro will be overwritten.) 

3. After naming the macro, a row of icons appears in the lower left-hand 

corner of the screen (see Figure 37). The rightmost icon ( ) indicates 

that the macro is being recorded. Perform the actions to be included in 
their normal sequence. This can include any keystrokes and mouse 
actions that you desire. 

4. Once you have finished the entire sequence of actions, select the End 
Definition command (from the same place) or click the middle icon 

( ). 
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Figure 37: Recording the macro 

Example: 

You will now create a macro that deletes records.  

One way to delete a record is to press Ctrl+Delete, then press the left 
arrow (to highlight the OK button in the pop-up window), and finally press 
Enter.  

To define a macro that will perform these three actions, proceed as follows: 

1. Enter the Shipping Zones form. 

2. Situate your cursor on a zone that has not been assigned to a 
customer (e.g., one you added). 
Note: The record will be deleted, and you will not be able to 
recover it by clicking Undo (Ctrl+Z). 

3. Select the Start Definition command. 

4. In the pop-up window, type: Delete. Then click OK or press 
Enter. 

5. Press Ctrl+Delete, then the left arrow key, then Enter. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 76 

6. Select the End Definition command. You can now perform the 
same actions by executing a macro. 

Note: If you placed the cursor on a shipping zone that has been assigned to a 
customer, you will not be able to delete it. Confirm the error message, move to 
a different shipping zone and try again. 

Running a Macro 

To use a macro you have defined, take the following steps: 

1. Situate your cursor in the appropriate column. 

2. Click the Options Menu button, click Run and select Macros. 

3. Do one of the following: 

 Select Execute and choose the desired macro from the list. 

 Click Select a Macro. A list of available macros will pop up (see Figure 
38). Select the one you want and click Execute (or press Enter). To 
delete the macro, click on the Delete button. 

 

Figure 38: Executing a macro 

Notes:  

 When a macro is running, this is indicated by  in the lower left-hand 

corner of the screen. 

 To stop a macro while it is running, press Ctrl+Break or click , also 
located in the lower left-hand corner of the screen. 
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Hot Keys 

To make macro usage even easier, you can assign hot keys to activate each 
one. This eliminates the need to open the Run menu in order to execute a 
macro. Ten hot keys are available: Alt+0 through Alt+9.  

Assigning hot keys is very simple:  

1. Again, activate the Select a Macro command. The list of available 
macros will pop up. 

2. Select the one you want by moving to it with the  arrows.  

3. In the Alt+ field, specify a number between 0 and 9 (or click on the 
arrows until the number you want to use appears).  

4. Click Set Key. Alt+n (i.e., whatever number you designated) is now the 
shortcut for executing this macro.  

5. To use the hot key, press Alt followed by the correct number. 

Recursive Macros 

In order to delete a large number of records, it is possible to define a recursive 
macro. This macro repeats the recorded actions up to 50 times in a row. The 
process for defining this type of macro is very similar to the one for a regular 
macro. The difference is that Select a Macro is included within the definition.  

To define a recursive macro, take the following steps: 

1. Select the Start Definition command. 

2. Assign the macro a name in the pop-up dialogue box (you can use 
“Delete” again and overwrite the existing macro; if you do, confirm the 
warning message that appears). 

3. Perform the actions in question (e.g., press Ctrl+Delete, then the left 
arrow key, and then Enter). 

4. Do one of the following: 

 Click the Options Menu button, click Run and choose Select a Macro. 

 Click , located in the lower right-hand corner of the screen. 

5. Choose the macro you just defined, and confirm. 

6. Select the End Definition command or click  (located in the lower 

right-hand corner of the screen). 
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Again, you will delete a record just by defining the macro. If you now run the 
macro, it will attempt to delete all remaining records in the form. (Of course, the 
attempt to delete any shipping zones already assigned to customers will fail 
and generate an error message.) 

Note: The recursive macro you have just defined is a very powerful one, as it 
deletes up to 50 records in a given form. Use it with caution. (The number of 
recursive macros that can be performed successively can be redefined by the 
system manager via the RECURSIVEMACRO system constant.) 

Help 

In addition to the features accessed by the Help menu in the Options Menu, 
there are several types of on-line help screens available when you are in a 
form. 

Form Help explains usage of the current form. This help can be accessed from 
any column in the form. Do one of the following: 

 Click the  button on the upper right corner of the screen and select 
Form Help. 

 Press Ctrl+F1 from anywhere in the form. 

Column Help explains the contents of a specific form column. To access this 
help, move the cursor to the column in question and do one of the following: 

 Click the  button on the upper right corner of the screen and select 
Column Help. 

 Press F1 from within the column. 

 Right-click the column and select Help. 

You can also access help for any form that appears in the Direct Activations 
menu, as well as any sub-level form whose tab is visible. To do so,  

 Right-click the menu item or the tab title. 

Similarly, you can access help for pop-up lists of Direct Activations and sub-
level forms: 

 Select the desired entity and click the Help button at the bottom of the 
pop-up screen. 

All the above forms of help can be used to access an entity mentioned in the 
text (e.g., open a form). Simply click on the highlighted name of the item 
appearing in the message. 
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Leaving a Form 

To exit a given upper-level form (and all its sub-levels), take one of the 
following actions: 

 Click  in the row of shortcuts at the top of the form.. 

 Click the Options Menu button, click File and select Exit Form.  

 Right-click the form title in the Active Screens menu and select Close. 

 From the upper-level form, press Esc. 

If data are displayed while you are trying to leave a form, you will be asked to 
confirm the exit. This is to prevent you from accidentally leaving a form. This 
warning message can be disabled by the system manager, if desired. 

Note: If you have added or modified the current record, the database will be 
automatically updated as soon as you leave the form (even if you have not 
moved to another line). If you want to cancel the new record or the 
modifications, you must either undo your actions or clear the line before you 
leave it — and before you exit the form. 

You can also minimize a form. To do so, right-click the form title in the Active 
Screens menu and select Minimize. 

Once minimized, the form continues to appear in the Active Screens menu. 
Click on it to view it again. 
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Reports and Programs 

Introduction 

Now that you have a thorough understanding of Priority forms, it is time to 
move on to programs and reports. You will find that many of the features you 
have learned how to use in forms (e.g., Choose lists, Search lists, date 
calendars, wildcards) will also be useful in working with programs and reports. 
As these last two entities work in a similar manner, their treatment is covered 
together.  

Both programs and reports can be activated either from a menu or from within 
a form (by means of direct activation). The latter topic was discussed above (p. 
72); the current section thus deals with running programs and reports from a 
menu. 

This section contains instructions for setting up Business Process Management 
(BPM) flow charts, easy-to-use graphic interfaces through which you can 
control and monitor the progress of most basic system processes. 

Programs 

In a menu, programs are identified by . They perform a variety of actions. For 

instance, you can: 

 prepare, copy and/or update selected price lists 

 assign a group of parts to a family 

 print a batch of invoices, receipts and the like 

 assign discounts to a group of customers 

 copy a part. 

Most programs require input from the user. For example, you might need to 
indicate, among other things: 

 the percentage by which to raise prices in a price list 

 which parts are being added to which family 

 what invoices to print out 

 what customers to assign the discount to. 

Once you have selected a program, a parameter input screen will appear. The 
use of this input screen is identical for programs and reports and is explained in 
detail below (see p. 109). For now, a simple example will suffice. 
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Running a Program 

Example: 

1. Find and run the Assign Preferred Vendor to Part program.  

2. A parameter input screen pops up in which you specify whether 
you want to assign the vendor to specific parts or to entire part 
families. Choose the Part Number option (see Figure 39). 

3. A second parameter input screen appears, in which you specify 
the preferred vendor and the parts to which the vendor will be 
assigned (see Figure 40). The wildcard (*) that appears 
automatically in the Vendor Number field signifies that by default 
the program is run for all vendors. In an input screen, a blank field 
also acts as a wildcard, so clicking OK without specifying any 
particular data will simply assign all vendors to all parts. 
 

 

Figure 39: First parameter input screen 

 

Figure 40: Second parameter input screen 

Of course, that would defeat the purpose of the program, so you need to 
narrow down the effect of the program — say, to a single vendor and a 

single part. One way to do so is to click the  drop-down button next to 
each field and select the desired item. A Search list will appear; use it to 
select one vendor and one part. Click OK. 

Note: For information regarding advanced parameter input, see p. 109. 
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4. A message will appear requesting confirmation of your input 
(Figure 41). Click OK. 
 

 

Figure 41: Input confirmation screen 

5. In this particular program, the system runs a report displaying the 
program results (Figure 42). 
 

 

Figure 42: Partial program report 

Note: You can cancel the program at any point during the process of execution 
and parameter input. 

Explorers 

A special type of program opens an explorer, much like the standard Windows 
Explorer. The best way to explain the usage of this feature is via a concrete 
example. 

Example: 

We will view attributes of specific parts by means of the Part Explorer. 

1. Find and run the Part Explorer. A parameter input screen will 
open, with a wildcard (*) automatically filled in for the Part 
Number. This enables you to call up all parts.  
Note: Again, you can narrow down the effect of the program by 
selecting specific parts.  
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2. Click OK. Results appear in the Part Explorer (Figure 43). Click 
on each item in the left window to see its individual attributes. 

3. To exit the explorer, click the Options Menu button, click File and 

select Exit Explorer or click  in the row of shortcuts. 

 

Figure 43: Viewing results in the Part Explorer 

 

BPM Flow Charts 

Another special type of programs opens a flow chart (see Figure 44), which 
you can use to manage business processes. In this friendly graphic interface, 
you can define statuses and link them together into defined sequences by 
means of paths. Both statuses and the paths that link them may be assigned 
user-defined rules that trigger a variety of automatic features when certain 
conditions are met. The end product is a sophisticated workflow mechanism 
that optimizes the efficiency of the process in question. 

Each major document in a defined work process has its own flow chart.  

If you are working with statuses for the first time, each chart opens to display 
the default statuses predefined for that particular document. You can revise the 
default flow chart by adding statuses, assigning paths and creating rules that 
reflect the company workflow. 
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Figure 44: The BPM flow chart for vendor price quotes 

Note: Flow charts have a Tool Tray in the lower left corner, with shortcuts for 
various actions. There are also certain commands in the Options Menu that 
are only available when in a BPM flow chart, while other commands are 
disabled. 

The Initial Status 

Each BPM flow chart has a default initial status (usually Draft) that is pre-
defined. When you right-click on that status, the Default Initial Status line is 
flagged. This is the status that is assigned to any newly opened document. 

In addition, you can define any number of statuses as a permitted initial status. 
As a result, when users open a new document, even though a default status 
appears, they can change it to any permitted status without having to leave and 
reenter the line. 

To define a status in this way,  

 Right-click it in the flow chart and select Permitted Initial Status. 
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Creating Paths Between Statuses 

Paths determine the available options for moving a transaction document from one 
status to another. Represented by arrows in the flow chart, paths reflect the order 
in which the various processes in a transaction must take place. When attached to 
rules, they may also determine the conditions under which a status may change, 
as well as the way a transaction is processed when it reaches the next status. 

Note: To temporarily disable the paths between statuses in the form in which 
you are working (though properties and rules remain in effect), click the 
Options Menu button, click Edit and select Disable Path Definitions. 

Example: 

To create a path from one status to another, perform the following steps: 

1. Use the Search for Entity feature (p. 11) to find and run the BPM 
Flow Chart – Sales Orders. 

2. Use the mouse to drag the statuses so that they appear in a clear 
hierarchy on the chart (see Figure 45 below). 

3. To add a path between statuses, do one of the following: 

 Click  on the Tool Tray. 

 Right-click an empty area on the flow chart and select Draw 
Path. 

 Click the Options Menu button, click Edit and select Draw 
Path. 

4. Use the mouse to draw a line from the Draft status to the In 
Progress status. 

5. Draw two paths from the In Progress status (one to the 
Confirmed status and one to the Canceled status) and a path 
from the Confirmed status to the Completed status (see Figure 
45).  

6. To save the changes, click  on the Tool Tray; or click the 
Options Menu button, click File and select Save BPM. 
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Figure 45: Drawing paths between statuses for sales orders 

Defining Rules for Statuses 

BPM allows you to monitor workflow by setting up rules that activate system 
responses when certain conditions are met. You can set up automatic e-mail or 
text message notification, re-assign the document to a higher-ranking employee, 
or open a task whenever a document receives a certain status, remains in a 
certain status overlong or receives a date that falls within a certain time period. 
You can use rules in tandem with data fields to define precise conditions for the 
activation of these responses (e.g., the size of the transaction, the importance of 
the customer). 

Note: Text messaging (available in Priority Pro and Priority Enterprise) must 
be purchased in a separate module. 

You can also define a rule such that e-mail or text messages are sent to an 
entire user group rather than an individual user. In this case, the document will 
be assigned to the first user in the group, who can then assign the document to 
another user in that group. 

Note: Groups are an important tool in Priority, with applications in customer 
relations, mailing and business rules. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 87 

 

To define a group: 

1. Enter the Groups form, found in the Contacts menu of the Office 
Management module. 
Note: This is a multi-company form. Any revisions to it affect all 
companies. 

2. Specify a Group Name and Description. If you are defining a group for 
mailing purposes, use the To/Cc/Bcc column to determine in which 
mode each member of the group will receive the message. 

3. Enter the Users in Group sub-level form and list the users that belong to 
it. 

4. To determine the group hierarchy (e.g., for when automatic mail is sent 
to the first person in the group), use the Sort column. 

5. If you are defining a group for mailing purposes, you can enter the E-mail 
Addresses sub-level form and add external e-mail recipients to your group. 

Note: When using BPM to assign a document to a user in the group, if the first 
user is not available, the document is automatically assigned to the next person 
in the group. The availability of the user is determined by defined employee 
hours and absences. 

Assigning a Document to a User 

One of the most frequently used rules is that which determines the user to which 
the transaction is assigned at each stage of the process. 

Example: 

Let’s create a rule by which a sales order that receives the In Progress 
status is assigned to the sales manager when it exceeds a certain value 
and is assigned to one of the members of the "Sales" group when the order 
value is lower: 

1. Follow the instructions on p. 87 to create a group called “Sales”. 

2. In the sales orders flow chart, right-click the In Progress status 
and select Rules. 

3. The Define rules dialogue box opens (Figure 46). In the Rule 
Description column, type "In Progress Status Rule".  

4. In the Do the following section, select Assign it in the first text 
box, group in the second text box, then Sales in the third. Click 
OK. 
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5. Now reopen Rules. The List of Rules dialogue box will appear 
(see Figure 47) displaying the rule you just created. Click New.  

6. In the Rule Description column, type "In Progress Rule: Total 
Price". 

7. In the Do the following section, select Assign it in the first text 
box, then select the username of the sales manager in the third text 
box. 

8. In the If section, select Total Price in the second text box, is 
greater than in the third, and type “5000” in the fourth box that 
appears next to the third. Click OK. 

9. Exit the flow chart (press Esc) and click OK to save your 
changes.  

 

 

Figure 46: The Define rules dialogue box 
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 Figure 47: The List of Rules dialogue box 

You have now defined the following rules for the In Progress status: 

 sales orders in progress that are worth up to 5000 dollars are assigned 
to the first available user in the “Sales” group (based on the defined 
group hierarchy), while 

 sales orders in progress that are worth more than 5000 dollars are 
assigned to the sales manager. 

Open or retrieve a sales order and adjust it so that its total price is over 
5000. Now change its status to In Progress. Click the Scheduling tab and 
you will see the sales manager's username in the Assigned to column. 

Sending an E-mail or Text Message Notification 

It may be sufficient to notify the sales manager in the case of a large order, 
rather than reassign it.  

Example: 

Let’s modify our previous example: 

1. Reopen the flow chart, and right-click the In Progress status. In 
the List of Rules dialogue box, select the second rule we created 
in the previous example and click Edit. 

2. In the Do the following section, replace Assign it with Send e-
mail in the first text-box, and select the sales manager as the e-
mail recipient.  

3. In the Subject column, type "Sales Order Price Update". 
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4. In the message area, type “Sales Order No.”, then click Add Field 
and choose the Order column title from the Choose list under the 
message area. Continue the sentence “ has reached a final price of 
over ”, then click Add Field and choose the Final Price column 
title (see Figure 48). Complete the sentence by adding “dollars.” 
Click OK. 

Now open another order worth more than 5000. You will see that it is still 
assigned to the “Sales” group. Now check your outbox to see that your 
notification was sent to the sales manager. 

 

Figure 48: Illustration of the current example 

Notes:  

 The Add Field Choose list includes selected To Do item fields as well 
as form fields.  

 Use the Add Rule No. to Msg and Add Rule Desc to Msg buttons to 
add the automatically assigned rule number and the description you 
recorded to the text message. 

 You can add a document's attachments to the e-mail sent for the 
document by flagging Incl. Attachments. 
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 Use the If section to define the condition (or conditions) that will cause the 
message to be sent (e.g., when a certain column receives a specific value or 
range of values, or the result of a designated expression). 

 In the bottom When section you can determine that all conditions must occur 
at the same time (the AND condition) in order to trigger the message, or you 
can use independent conditions (the OR condition) where it is enough for 
only one of the conditions to occur in order to trigger the message. 

Transactions That Are Overdue For a Status Change 

As mentioned previously, you can also reassign a document, change its status 
or notify an e-mail or text message recipient when the document has remained 
in a particular status past a defined period of time, or open a task for a 
designated user. 

Example: 

1. Reopen the flow chart, right-click the In Progress status and select 
Rules. When the List of Rules dialogue box opens, click New. 

2. In the upper When section, select the second option and specify 
two days as the permitted processing period. 

3. In the Do the following section, select Assign it in the first text 
box, and the sales manager's username in the third. 

4. Click OK. Save and exit the flow chart. 

From now on, if a sales order remains In Progress for over two days, it will be 
re-assigned to the sales manager.  

Documents That Are Assigned a Given Date 

You can also define a rule that takes into account a date appearing in the form 
in question. 

Example: 

The following rule sends mail to the sales manager when a sales order 
remains In Progress past its defined End Date (the planned date for 
completing the order).  

1. Reopen the flow chart, right-click the In Progress status and 
select Rules. When the List of Rules dialogue box opens, click 
New. 

2.  In the Rule Description column, type "Overdue Date Rule". 

3. In the upper When section, select the third option. Select End 
Date in the first text box, fell in the second text box, then 1 and 
Days in the third and fourth. 
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4. In the Do the following section, select Send e-mail in the first text 
box, and the sales manager's username in the third. 

5. In the Subject column, type "Delayed Processing of Sales Order". 

6. In the message area, type “The processing of Sales Order No. ”, 
then click Add Field and choose the Order column title from the 
Choose list under the message area. Continue the sentence “ has 
been delayed past the defined end date: ”, then click Add Field 
and choose the End Date column title (see Figure 49). Complete 
the sentence by adding a period. Click OK. 

 

Figure 49: Rule based on document date 
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Defining Rules Using Function Expressions 

In the first example, we defined a rule that is activated only if the value of one of 
the form columns (Total Price) exceeds a certain fixed value (5000). You can 
also define an expression in the same text box, using any combination of fields 
and functions, by clicking on the  button that appears to the right of the box. 

Example: 

The following rule sends mail to the sales manager when a sales order 
remains In Progress for more than 10 days, and more than 2 days have 
passed since its defined End Date.  

1. Reopen the flow chart, right-click the In Progress status and select 
Rules. When the List of Rules dialogue box opens, click New. 

2. In the Rule Description column, type "Delayed Processing Rule". 

3. In the upper When section, select the second option and specify 
ten days as the permitted processing period. 

4. In the next section, select Send e-mail in the first text box, and 
the CEO's username in the third. 

5. In the Subject column, type "Delayed Processing of Sales Order". 

6. In the message area, type “Sales Order No. ”, then click Add Field 
and choose the Order column title from the Choose list under the 
message area. Continue the sentence “has not yet been 
completed.”  

7. In the If section, select End Date in the second text box, is 
smaller than or equals in the third, place the cursor in the fourth 
box that appears next to the third and click the function ( ) button 
that appears to the right of the box (see Figure 50). 

8. In the dialog box that opens, click Add Predefined Expression. 
Select the end of last month expression. A function expression 
representing the beginning of the present month less one day 
appears in the dialogue box (see Figure 50). Click OK to exit the 
dialogue box. The function expression you defined now appears in 
the fourth text box in the If section. 

9. Click OK. Save and exit the flow chart. 
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Figure 50: Rule using a function expression 

Finding and Organizing Rules 

There may be many rules defined for each status. In the List of Rules dialogue 
box (which appears after the first rule has been defined, whenever you select 
Rules), you can view all rules defined (see Figure 51). 

 

Figure 51: The List of Rules dialogue box 
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 To search for a specific rule, click the More button and select Search. 
This allows you to do a text search within the list of rules (e.g., search by 
the rule description). Alternatively, select Report to print a report of the 
rules defined for the status. The report includes the Rule Number and 
Rule Description as well as other identifying information useful for 
finding the rule you want.  

 To change the order of the listed rules, use the up and down arrows on 
the left (e.g., put the most important ones at the top for easy access). 

 If you do not want a certain rule to operate, remove the checkmark from 
the Active column, or click Delete to completely remove it. 

Creating New Rules from Existing Ones 

An easy way to create a new rule for both statuses and paths is to copy an 
existing one and revise it. Simply select the desired rule in the dialogue box 
(see Figure 51) and click Copy. A duplicate of the selected rule will appear, 
which you can revise by clicking the Edit button. 

Running the Tabula Task Scheduler 

The sending of time-based messages will only work if the Tabula Task Scheduler 
is running and has been set up properly. The scheduler scans all active 
documents for any defined time limits and activates the notification process when 
it finds an expired limit. It also sends a daily error report for any time-activated 
changes (e.g., status, assigned user) that have malfunctioned. 

Note: It is recommended to decrease the frequency of the scheduler scan to 
once every two hours. 

Basic instructions for setting up the scheduler can be downloaded from the 
Priority web site. In addition, the system manager needs to make sure that: 

 an outgoing mail application other than MS-Outlook is defined on the 
workstation where the scheduler is installed.  

 the Send reminders about document status program is flagged as 
Active in the Define TTS Tasks form. 

BPM Error Reports 

An escalation rule may trigger a change of user or status when such a change is 
not permitted in the document in question, based on defined form logic. For 
example, a Customer Shipment may not receive the “Final” status if it has not yet 
been itemized. In such a case, the form in question presents an error message; 
however, since escalation rules are applied automatically when the form is 

http://www.priority-software.com/
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closed, error messages are not possible. Instead, Priority provides a report 
called BPM – History of Errors (menu path: System Management  System 
Maintenance  Periodic Maintenance  BPM Maintenance) to document 
any actions that fail for this reason.  

You can set the scheduler to send the error report to a designated e-mail 
address at regular intervals, where it can be checked routinely for failed actions. 
To do so: 

1. Open the Define TTS Tasks form. Move to the task named “Send 
Reminders – error log by e-mail (change the address)”. 

2. In the Command column, move to the end of the command line and 
replace the phrase “any_email_address@mycompany.com” with the 
desired address. 

Defining Rules for Paths 

You can further optimize your workflow by assigning rules to the paths between 
statuses, rather than to the statuses themselves. Path rules allow you to assign 
behaviors to a status when it is reached from a specific preceding one. Path 
rules also allow you to designate which users or groups of users are permitted 
to move a document from one particular status to another. As with status rules, 
this rule can be made conditional on document data. 

Note: Paths that have been assigned rules display a small red circle in the 
middle of the line. 

Example: 

Let’s return to our sales order flow chart: 

1. Reopen the flow chart. Right-click the path between the 
Confirmed status and the Canceled status, and select Rules. 

2. In the Do the following section, select Allow status change. In 
the third text box, select any username (except yours). 

3. Click OK. The new rule establishes that once a sales order has 
been confirmed, it can only be canceled by the specified user. 

4. Save and exit the flow chart. 

5. Retrieve a sales order and assign it the Confirmed status. Now 
try to change the status to Canceled. 

If you want to disable a particular rule (for either a status or a path) you can 
remove the check mark from the Active option in the Define Rules dialogue 
box or in the List of Rules dialogue box. 
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Note: To view all rules created for a given status or path, use the List of BPM 
Rules form in the BPM Maintenance menu or click the More button in the List 
of Rules dialogue box, and select Report. 

Revising Statuses 

To revise an existing status, right-click the status and select the desired 
command from the pop-up menu: 

Note: The same commands can be accessed from the Edit menu in the 
Options Menu. 

 Rules: Opens the Define rules… dialogue box, in which you define 
status rules. 

 Properties: Opens the Properties of… dialogue box, in which you 
define attributes of the status, such as whether a document in this status 
can be revised or will be included in your to do list. 

 Set Color: Allows you to select a background color for the status (as 
displayed in the flow chart). 

 Rename: Allows you to choose a new name for the status. 

 Record Remark: Allows you to record a brief remark for the status that 
will appear as a tooltip in the flow chart. 

 Delete: Removes the status and its paths from the flow chart (and 
makes it inactive, that is, the status will not appear in Choose lists). 

Note: Any status that you delete is stored in memory together with all other 
statuses that are not in use in the current flow chart. These statuses appear in 
the Select Status window whenever you add a new status. 

A given document may be assigned numerous statuses. In order to keep your 
flow chart easily comprehensible, special care must be taken both in the color-
coding of statuses, and in their physical grouping. For example, you may want 
to situate all statuses that involve closing, canceling or freezing the document 
at the bottom of the screen, and color them red. In addition, you may find it 
useful to record a brief remark pertaining to each status, which appears when 
you hover over that status in the flow chart. 

Adding New Statuses 

To add a new status to the flow chart, perform the following steps: 
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1. Do one of the following: 

 Click  on the Tool Tray. 

 Right-click an empty area on the flow chart and select Add Status. 

 Click the Options Menu button, click Edit and select Add Status. 

2. The Select Status window will appear. Click the New button. 

3. A dialogue box called Properties of the New Status opens. Record a Name 
for the new status, and flag the appropriate status properties. 

Viewing a History of BPM Flow Chart Changes 

Use the BPM – Track Changes form or report in the BPM Maintenance menu 
to view all changes made in any BPM chart (e.g., new status, path deleted, new 
rule, change in status or status attributes). 

Copying a BPM Flow Chart 

You copy an existing flow chart to a clipboard, from which it can pasted into 
another company or even to another installation of Priority. To do so: 

1. Open the flow chart. 

2. Click the Options Menu button, click Edit and select Copy Flow Chart. 

3. Open the same chart in the target company. 

4. Click the Options Menu button, click Edit and select Paste Flow Chart. 
Note: You can also paste the flow chart into a Notepad file and save it as a 
backup. The saved text can then be copied and pasted into a target chart 
using the Paste Flow Chart option. 

Reports 

In a menu, reports are identified by the  or  icon.  

Report Format 

There are several different types of reports: standard, tables, graphs, 
documents, BI reports and charts. All reports open in your web browser (see 
Figure 52). 
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Figure 52: Example of a standard HTML report 

Tables differ from standard reports in two major areas. First, they summarize 
information. Whereas reports provide a great deal of specific data over several 
pages, tables succinctly provide a broad picture of the situation. Second, tables 
can provide information (e.g., sum totals) per row and column).  

There are several types of graphs: bar, line, area and tree graphs. The key to 
each bar, area or line appears below its appropriate scale. In the key that 
appears below the graph, a bar is denoted by a shaded rectangle, an area by a 
shaded triangle, and a line graph by a line. 

Tree graphs illustrate ratios between parent data and their children, between 
children and their children, and so on down to the lowest level. The ratio 
appears to the right of the line that connects parent to child. A tree that is wider 
than the screen will be divided among several pages. The number of the page 
on which each portion of the graph is continued appears within the parent's 
box, at its right edge. All graphs are printed in landscape orientation. 

Documents are a special type of report whose printout is sent to customers, 
vendors or other external recipients (e.g., customer invoices). A standard 
format is provided for all documents, which can be revised by using the Design 
Tool, discussed in detail under Basic Customization, p. 116. 

On BI reports and charts, see p. 104. 

Running a New Report 

Once you have selected the desired report from a menu, a window pops up in 
which you have to choose between Saved and New reports. 
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To run a new report, make sure that the New option is selected (this is the 
default). Then select the report format. To confirm your choice, click OK or 
press Enter. 

A parameter input screen will pop up. After you have finished specifying all 
required information in that window and all execution steps have been 
completed, the report will be generated (see p. 81 for a simple example of 
parameter input; see p. 106 for a complete explanation of the topic).  

Note: At any point during the process of execution and parameter input, you 
can choose to cancel generation of the report. 

Accessing a Saved Report 

Once a report is run from the menu, it is saved in the database (until it is 
deleted by the user or system manager). In order to view or send report data 
(as e-mail attachment or to Word), select the report in question from the menu 
and click the Saved box. 

Depending on how the system is set up, you may be able to view only your own 
saved reports, those of all users in your user group or those of all users in the 
system. Ask your system manager to change the SAVEDREPORTS system 
constant if you lack access to all the saved reports you need. 

If any saved reports are available (see Figure 53), the dates on which they 
were run will appear in a list, together with the name of the user who ran it, and 
the query conditions used to generate it.  

 

Figure 53: Report pop-up window — saved report  



 

Cat.No. LB160681  Ver.04 – June.25,’17 101 

Select the report you want from that list, using the left mouse button or the  
arrows. Then choose between viewing the report on screen (Display), displaying 
it as an MS-Word file (Display in MS-Word) or creating an e-mail attachment 
(Send…). You can also Delete a report from this screen.  

Viewing the Report on Screen 

If you have run a new report or chosen to display a saved one, an HTML page 
will pop up with the prepared report. You can then use regular web options.  

In addition, you can: 

 freeze titles at the top of the page as you scroll through the data of a 

report (click on the  button at the top of the report; click again to undo). 

 click  to export report data to Excel. 

Note: The report data will be exported to Excel regardless of the value of 
the SPREADSHEET system constant. 

 click  to export report data to Word. 

 click  to export report data to Outlook. 

 click  to send report data as an e-mail attachment via your Priority 
mailbox. 

 (for a tabular report) view the data as a bar graph (click on the  
button at the top of the report, click Back to return to the report). 

 use Explorer-style icons (- and +) to collapse the report (or specific 
sections of it) to display subtotals and totals, and re-expand it to full 
view. 

 access system forms from the page by clicking on items in the report 
(e.g., clicking a part number activates the Part Catalogue form). 

Note: To view graphs, the CHARTTYPE system constant must be correctly 
defined by the system manager. 

Sending a New Report to a Spreadsheet 

To export a report to Excel: 

1. Make sure the SPREADSHEET system constant is set to 1. 

2. Run a new report and select Send to Spreadsheet (see Figure 53). 

3. Select the desired template in the dialogue box. To create a regular 
spreadsheet document, select No Template. 
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4. Fill in the columns in the input screens that open and click OK. A new 
spreadsheet will open in Excel, which you can now edit and print out. 

To export a report to other spreadsheet applications: 

1. Make sure the SPREADSHEET system constant is set to 0. 

2. Run a new report and select Send to Spreadsheet (see Figure 53). 

3. Select the desired template in the dialogue box. To create a regular 
spreadsheet document, select No Template.  

4. Fill in the columns in the input screens that open and click OK. A file is 
downloaded and displayed at the bottom of your browser window. 

5. Click the file to open it in your default spreadsheet application. You can 
now edit the spreadsheet and print it out. 

Notes:  

 Templates created using the .xlt file type will appear in the list of templates, 
but will not be accessible when the SPREADSHEET constant is set to 0.  

 You can only send a new report (not a saved one) to a spreadsheet. 

Using the Print/Send Options 

There are several print/send options to choose from when working with reports 
(see Figure 54). You can: 

 send the entire report or selected pages to your printer. 

 send the report as an e-mail attachment. 

 open and save the report in Word. 

 print the report to a text file. 

 include attachments that have been linked to the record in question 
when printing or sending a report (e.g., as Mail). 
Note: To exclude a specific attachment, flag the Don't Send column in 
the original form.  

 send the report directly to a pre-defined printer (Quick Print), specifying 
the desired number of copies. 
Note: Flagging this option when printing a report sends the report to the 
default printer. 

 save the report as a PDF file and display it in Adobe Reader. 

 save the report as a PDF file and send it as a fax or e-mail attachment. 
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Note: The various send options are only available if you have the necessary 
hardware and software setup for e-mail and/or fax dialing. 

 

Figure 54: Print/Send Options for Reports 

Most of the above options are available only when you are accessing a saved 
report. Note the following exception: 

 You can print a new report to an external directory, but only as a text file. 
Such reports are not recorded in Priority. 

Additional options are available when creating a new document (i.e., a type of 
report whose printout is usually sent to customers or vendors). 

 Print: Prints the document without displaying it. 

 Display: Opens the document in Priority.  

 Mail: Opens an e-mail message in the Compose Mail form with the 
document as an attachment. 

 Automatic Mail: Sends an e-mail to the designated contact with the 
document as an attachment (without opening the Compose Mail form). 

 Automatic Fax: Faxes the document to the designated contact (without 
opening the Compose Mail form). 

Sending an E-mail Attachment 

You can also send a saved report as an attachment to an e-mail message. 

Select the report from the dialogue box and click the Send… button.  
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A new e-mail message will be created with the report title as the topic and the 
report file as the attachment. In fact, the Compose Mail form will open up 
automatically. All you need to do is specify the recipient and send the message. 
(For detailed instructions on using the system’s mail feature, see p. 163). 

BI Reports and Charts 

BI (business intelligence) reports are different than all the above-mentioned 
reports, in that they allow you to analyze data from multiple perspectives. You 
determine the exact cross-section of data to be displayed by drilling down 
within categories and accessing only the specific data that you want to see. For 
example, you can see how a particular part is selling, cross-referenced by the 
type of sale and broken down by the country in which it was sold. Once you 
have achieved the desired display of data, you can export the report to Word, 
Excel or Outlook, send it as an e-mail attachment from the Priority mailbox, or 
save it as an HTML page. For details, see the Executive Reports Wizard. 

There are several methods of accessing BI reports: 

 Enter the Executive Reports module and select the menu for the 
desired analysis (e.g., Sales Order Analysis, Service Call Analysis). 

 Enter the desired analysis menu from within its system module (e.g., 
Purchase Orders  Purchase Order Analysis). 

 Any form column with  next to its title (e.g., customer number, order 

number, part number) indicates that there are related BI reports that can 
be run for retrieved data. Click on the icon; a list of relevant BI reports 
appears, which you can run to display data related to the value of the 
column. 

 Click the Options Menu button, click Run and select the Analysis 
Reports (BI) item, which also displays the same list (i.e., of BI reports 
relevant to the highlighted column). 

Note: To view up-to-date information in an BI report, you need to run a 
preparatory program (e.g., Prepare All for Analysis (BI)) that collects the data 
and prepares it for presentation. This program is usually run automatically each 
night by the Tabula Task Scheduler. 

Defining Periods for BI Reports 

Once you have run one of the BI reports, specify the period and company for 
which to display data. You can specify either an absolute period (e.g., the first 
quarter of 2015) or the range of dates when the period begins and ends (e.g., 
from the start of this quarter to the end of this month).  
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To define the periods and companies for which to display data, do one of the 
following: 

 To specify an absolute period, click the  icon. In the appropriate 
columns, select the Year (e.g., 2010) and the Period in Year (e.g., 
November) for which to display data. 

 To specify a range of dates, click the  icon. You can then choose 
from a list of relative Start and End Dates (e.g., start of last month, end 

of this quarter) or click  to open a pop-up calendar from which to 
choose the exact Start and/or End Date. 

You can also select a Level of Detail for the report. For example, you can run 
a report for a whole year displaying data for each quarter; in this case, the 
Level of Detail would be Quarterly. 

Notes:  

 If you are working in a multi-company environment, you can also 
select the company for which to display data when defining the period 
for the report. 

 Once you have set up a template of periods and/or companies, you 
can save it if desired (by clicking on one of the numbered buttons in 
the Save Template section). 

 Whatever values are currently chosen become the default the next time the 
report is run. To change them, click the appropriate icon and either redefine 
manually or reuse a saved definition by clicking on the appropriate number in 
the Get Template section. 

Drilling Down Within BI Reports 

Begin by selecting the desired Dimensions format (click the  icon). The 
One-dimensional format displays each level of data by itself. That is, once you 
select a dimension by which to slice the data in a given screen, the selected 
cross-section is displayed alone. You can then continue to drill down within the 
data until you reach the cross-section that you want. In order to view data for 
the previous level, you need to return to the previous screen (e.g., by clicking 
the back arrow).  

In contrast, the Multi-dimensional format enables you to drill down and view 
different cross-sections of the data in a single screen, organized within a 
hierarchical tree. When drilling down within the data, each cross-section is 
sliced by the selected dimension. The corresponding node in the tree is 
expanded accordingly (and can later be collapsed). This enables you to view 
values for the entire population as well as zoom in on specific cross-sections 
without losing global context.  
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After selecting the desired Dimensions format, you can begin selecting the 
cross-section of data to be displayed by clicking All. For example, in Sales 
Opportunity Analysis (BI), the input screen that appears lets you choose to 
break down the data by customer number, part number and territory. If you are 
working in One-dimensional format, this input screen also contains Filter by 
and Filter Except for options that allow you to view or eliminate all data that 
match a designated pattern (specified in the Use Pattern column). 
Alternatively, you can choose to total all data in the defined cross-section, by 
choosing the Total by or Total Except for options. 

For example, to eliminate data for customers whose customer number begins 
with the letter T, select Customer Number to break down data by customer, 
choose the Filter Except for option and record the value "T*" in the Use 
Pattern column (see Figure 55). 

 

Figure 55: Options for BI reports 

You can also use any of a number of interactive tools and icons to refine the 
report until you achieve the desired level of detail (e.g., the type of data to 
display) or to export the BI data to an external program such as MS-Excel; for 
details, see the Executive Reports Wizard. 

Dashboards 

Dashboards display pertinent data in various cross-sections, including reports, 
tables, graphs, gauges and pies, and even allow access to relevant BI reports.  

Note: In order to ensure that dashboards display up-to-date information, you 
need to run a preparatory BI program (e.g., Prepare All for Analysis (BI)) that 
collects the data and prepares it for presentation. This program is usually run 
automatically each night by the Tabula Task Scheduler. 
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Multi-colored control lamps and gauges in Dashboards are used to indicate 
profitability and sales target compliance. Users can specify the range of values 
that define the red, yellow and green areas in each control lamp or gauge in the 
Definition of Gauge Scales form. 

Each dashboard is comprised of a number of mini-windows called web parts, 
which can be arranged for your convenience using a built-in design tool. 
External web sites can also be displayed in these windows, provided the sites 
have been properly defined in Priority (usually by the system manager). 

To design your dashboards: 

1. Click the  icon that appears in the upper-right corner of each mini-
window. This will open the Dashboard Design window, which displays 
the arrangement of windows appearing in the dashboard alongside a list 
of hidden windows. 

2. To include additional web parts displaying selected web sites, open the 
Additional Sites Choose list (Figure 56), select a site. The title of the 
web site will appear in the table of displayed windows in the top part of 
the screen. (To include web sites in this list, see below.) 

3. To include additional web parts in your personalized My Dashboard, 
select the desired web part from the Additional Web Parts Choose list. 
This list displays all available web parts for which you have the 
necessary privileges. The selected web part will appear in the top part of 
the screen. 

4. To remove any web part from the dashboard, drag its title to the list of 
hidden windows on the left. 

5. To apply the changes you've made to the dashboard design, click GO. 
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Figure 56: Including external sites 

To define web site addresses for display in dashboards: 

1. Enter the Define Web Sites form in the Priority on Outlook menu (in 
the Office Management module). 

2. Record a name for the site (as you want it to appear in the Choose list), 
and in the URL column, record the full Internet address (see Figure 57).  

 

Figure 57: Defining web site addresses 

The following are tips for using dashboards: 

 To enlarge one of the windows, click the  icon in the upper right 
corner. 

 To determine the date range for which reports are run, click the  icon. 
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 In order to move from the upper to the lower part of the screen, use the 
vertical navigation bar to the right. 

 To change the type of graph displayed, click the  icon. 

Note: In order to use the Graph Type icon, your system manager must make 
sure that the CHARTTYPE system constant is set to 5. 

Parameter Input 

Most programs and reports require user input. Among other things, this input 
determines the records that will be affected by the program or the records that 
will be displayed in the report. 

User input is designated via the pop-up parameter input screen (Figure 58), 
which is comprised of one or more columns, some of which have both right-
hand and left-hand input windows. The right-hand window is for inputting 
values; the left-hand one is for selecting operators (where relevant). 

Use the mouse, Tab key or  arrow keys to move between input columns. Do 
not press Enter until you have finished specifying all input. 

When an input screen opens, it displays the parameters that were used the last 
time the program was run. If you are not interested in using these parameters, 
click the Clear button and enter new ones.  

Parameters must be designated in at least one column in each input screen. This 
is why the first input field in each screen features the default “*” wildcard (see 
Figure 58), despite the fact that an empty input field achieves the same effect 
(i.e., inputs all records).  

The exception to this rule is an input field that requires a single value (e.g.,  From 
Date, To Date), in which case input is mandatory and blank fields are invalid (see 
Figure 59). 
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Figure 58: Standard input screen with wildcard 

 

Figure 59: A single-value input screen 

If you are not sure how to fill in a certain column, put your cursor in the input 
window next to the column in question and do one of the following: 

 Click the Help button at the bottom of the screen. 

 Press F1. 

You will notice that the columns in the parameter input screen are like columns 
in forms: 

 Some have an arrow that opens a Choose or Search list (see pp. 32-35). 
Input values can be taken from this list. 

 The left-hand input window has an arrow that opens up a selection of 
operators. 

 Date columns have a pop-up calendar  (see p. 41), from which a 

date can be selected.  
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 Columns from which you can access a target form (so as to select 

records) display the  button.  

Note: Clicking the calendar icon (or pressing either F6 or the Space bar) opens 
a list of relative dates (e.g., yesterday, next month). Right-click the calendar or 
press Shift+F6 to open the standard pop-up calendar. 

Now confirm your choice by clicking OK or pressing Enter. Sometimes a 
second input screen will appear. In that case, input the second round of 
parameters and confirm your choice. 

Note: The next time you run the program or report, the screen will display 
whatever the input was for the previous run. 

To illustrate how this works, we will practice the procedure when running the 
Daily Exchange Rates report. Note that, if no exchange rates have yet been 
recorded, the report will be empty of values. As you are merely practicing 
parameter input, this is unimportant. It is recommended, however, that you 
delete the values you have input (use the Backspace key) or cancel 
parameter input (click on the Cancel button) after each trial, before beginning 
again. 

Note: If you accidentally click OK or press Enter, you will not do any harm. You 
will just have to wait for the system to attempt to produce the report and notify 
you that there are no values. 

Use the Search for Entity feature (p. 11) to find and run the Daily Exchange 
Rates report. The parameter input screen that pops up requires you to specify 
the currency (or currencies) to be included in the report, as well as the range of 
dates that are covered. We will concentrate on the Curr input column, in which 
the currency code is designated.  

Specifying an Exact Value 

The simplest way to input data is to provide an exact value. So, if you want to 
run the report for Euros, select EUR from the Choose list that opens from the 
right-hand input window of the Curr column (see Figure 60). To run it for 
Pounds Sterling, select GBP from the list. You would consequently obtain a 
report of all exchange rates for the Euro (or Pounds Sterling) over the range of 
dates specified. 
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The problem with the above method is that it only allows you to run the report 
for a single currency. A more useful method is to designate a pattern, using 
wildcards or operators.  

Note: In some cases, such as the From Date and To Date columns, only a 
single value is permitted.   

 

Figure 60: Inputting a single currency for the Daily Exchange Rates report  

Designating a Pattern 

One way to input several records at once is to specify query conditions. You 
can include any of the wildcards or operators used to retrieve records in a form 
(see p. 152). 

Examples: 

 To run the Daily Exchange Rates report for all currencies, 
leave the * in the right-hand input window of the Curr column 
(this appears by default).  

 To input all currencies whose code begins with the letter “F”, 
type: F*. 

 To input all currencies whose code begins with “C” and ends in 
“P”, type: C*P. 

Operators are generally more useful in a column displaying a date or number. 
You will notice that the left input window has an arrow. To change the default 
equal sign (=) to another operator (such as <, <=, >, >=, <>, -), click on the 
arrow and select the desired symbol. 
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Note: The operator button is disabled in any column in which a single input 
value is required (e.g., the From Date and To Date columns in this report). 

You can select multiple values for a given input column, either as discrete 
values (the | operator) or as a range of values (the - operator): 

 OR: Click on the arrow next to the left input window and select the 
vertical bar (|). The input column in question is duplicated. Input the 
desired values, one in each input column. When the report is run, data 
meeting either criterion is displayed. 

 BETWEEN: Click on the arrow next to the left input window and select 
the hyphen (-). The input column in question is duplicated. Input the first 
value in the range in the left input column and the last value in the range 
in the right input column (see Figure 61). When the report is run, only 
data that falls within the designated range of values is displayed. 

 

Figure 61: "Between" operator  

You can also input all records that match a given criterion, while excluding 
those that match a second criterion, by selecting the ! operator. Consequently, 
the input column in question is duplicated (see Figure 62), enabling you to 
specify the criterion for inclusion in the left input column (e.g., 2*) and the 
criterion for exclusion in the right input column (e.g., 21*). In the example 
provided, the result will be all records that begin with the number "2", except for 
those beginning with the numbers "21". 
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Figure 62: "And NOT" operator  

Inputting a Batch of Values 

Suppose you want to run the report for a group of currencies that cannot be 
easily represented by a pattern (e.g. Euros, Pounds Sterling and Yen). In this 
case, you need to select the records in question from a target form.    

To access a target form in a Choose list, do one of the following: 

 Place the cursor in the input column (Curr) and press F6 twice. 

 Open the Choose list (by clicking on the arrow) and then press F6 from 
within the list. 

To access a target form from a Search list, do one of the following: 

 Place the cursor in the input column and press F6 twice. 

 Open the Search list (by clicking on the arrow) and then click Advanced 
Search (or F6) from within the list. 

Note: Clicking the Select Values  icon (that appears next to some input 
columns) also accesses a target form. In certain input screens, this is the only 
method available (i.e., there is no Choose or Search list).  

The target form (Currencies, in this case), opens in Query mode so that you 
can easily retrieve the currencies you wish to appear in the report. You can 
“Hide” any unwanted records that appear by pressing F7 on the line of every 
unwanted currency. 

Once all desired records appear in the form, click the arrow next to the Choose 
Value button and choose Select All; or press Esc. In the Back to Input 
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window that opens, click OK. You will return to the parameter input screen. Any 
records displayed in the form at the time it was exited will be considered part of 
the input batch. A red magnifying glass  will appear next to the Curr input 
column, indicating that the data have been input in this manner. However, the 
column itself will remain blank, as it is impossible to display all the records that 
have been input. 

Note that you can also use the target form to find and input a single value into 
the program when you are not sure of the value, as demonstrated in the 
example below. 

Example: 

Suppose you want to print an Order Confirmation for a customer but you 
are not sure of the order number. 

1. In the Order Confirmation report, click the  icon next to the 
Order column. The Sales Order form opens in Query mode. 

2. Record the Customer No. and press Enter. All sales orders for 
this customer will be retrieved. 

3. Scroll down (e.g., use the vertical scrollbar) until you find the line 
with the order you are looking for. 

4. Without leaving the line, click Choose Value (or press F8). In the 
Back to Input window that opens, click OK. You will then return 
to the parameter input screen and the order in question will be 

inserted in the Order column with the symbol  next to it. 

Help for Programs and Reports 

Most input screens include a Help window that gives a general explanation of 
the program or report being run. In addition, the Help button at the bottom of 
the input dialogue box displays an explanation of the input parameter that is 
selected or in which the cursor is placed (see Figure 63). 

 

Figure 63: Help for a report during parameter input  
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Basic Customization 

 

Customizing the Menu 

As mentioned previously, the system provides a number of tools for 
personalizing the appearance of the menu screen. 

Organizing Menus 

Authorized users can use the Design Tool (Figure 64) to customize the actual 
content of the menu and it sub-levels (as well as forms and reports) by hiding 
unnecessary items and rearranging the rest into the most convenient order. 

 

Figure 64: The Design Tool for the Main Menu 

Notes:  

 To customize the menu, your user record must be flagged in the Form 
and Menu Design column (in the Permissions tab of the User 
Permissions form). 
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 All menu customizations take effect in all companies in the system. While 
they do not affect other system users, your system manager can run a 
program that copies menu customizations from one user to another. 

The first step in redesigning the menu is deciding which sub-menus you will 
actually need in each module, and the order in which you would like them to 
appear.  

To access the Design Tool, move to the menu in question and do one of the 
following: 

 To design one of the menus in the Main Menu (e.g., Financials, CRM), 
click the Options Menu button, click Design and select Design Main 
Menu. 

 Otherwise, right-click the sub-menu in question and select Design 
Menu. 

Use the Design Tool to make any of the following changes: 

 Move a menu item up or down in the list (by clicking the up and down 
arrows or by dragging an item to the desired place within the list). 

 Hide an item from the menu display. 

Each of the above customizations is reversible; furthermore, you can restore 
any menu to its original format by clicking the Restore Defaults button at the 
bottom of the Design Tool screen. 

Example: 

If you work mainly with multi-shipment invoices (rather than sales invoices 
or over-the-counter invoices), you may decide to hide some of the items in 
the Customer Invoices menu. To do so: 

1. Open the Financials menu, its sub-menu, Accounts Receivable, 
and the next sub-menu, Customer Invoices. 

2. Right-click the Customer Invoices menu and select Design 
Menu. A window will open with a list of the items in the menu. 

3. Right-click the Sales Invoices item, and select Hide.  

4. Do the same for all other menu items you wish to hide. 

5. Click OK. You will immediately see the newly designed menu.  

6. To restore the menu to its original form, reenter the Design Tool 
and press the Restore Defaults button. Then click OK.  



 

Cat.No. LB160681  Ver.04 – June.25,’17 118 

Add Items to Menus 

Two more design tools allow the system manager (or anyone with Manager 
privileges) to include additional entities in Priority menus: 

 Add Document File: The system manager can attach any documents 
(such as MS-Office files) or image files to a menu. 

 Add User-Defined Report: The system manager can attach any 
customized report created in a user report generator to a menu. 

To access the above options, right-click the menu in question. 

Customizing Forms 

Each form provides three different Design Tools – one for form columns and 
tabs, one for sub-level forms, and one for direct activations. All three can be 
accessed both in the Design menu, accessed from the Options Menu button, 
or right-clicking any form column and selecting Design. 

Notes:  

 To customize forms, your user record must be flagged in the Form 
and Menu Design column (in the Permissions tab of the User 
Permissions form).  

 All form customizations take effect in all companies in the system. While they 
do not affect other system users, your system manager can run a program 
that copies form customizations from one user to another. 

If the form in question is currently open in Multi-Record Display Mode, the 
Organize Fields Design Tool simply displays the full list of form columns in 
order of their appearance. In Full-Record Display Mode, the Design Tool 
displays the list of form tabs, each of which opens to display its constituent 
columns (see Figure 65). 

In this mode, you can make extensive changes to the appearance of the form, 
such as: 

 Hiding or renaming individual form columns 

 Renaming tabs and rearranging their columns  

 Moving columns from one tab to another 

 Changing the order of tabs, and  

 Creating a new tab and populating it with columns taken from other tabs. 
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Figure 65: The Design Tool for a form in Full-Record Display Mode 

Example: 

To create a custom tab in a sales order that helps you track your sales reps 
at a glance: 

1. Enter the Sales Orders form. 

2. Press Ctrl+B OR right-click any form column, select Design and 
then select Organize Fields. 

3. Click the  icon to the right of the screen. A new tab will appear 
at the bottom of the list, called New Tab. Use the up arrow to 
move it up to the second position in the list (i.e., the first tab to 
appear after the form’s main columns). 

4. Click the arrow next to the References tab. Right-click the Sales 
Rep column at the bottom of the tab and click the Move to… 
command. Select New Tab. Repeat this process for the Type of 
Sale column. 
Note: An arrow next to a column title indicates that the column is 
merged with another column; such pairs behave as a single 
column. 

5. Press OK. The system will automatically refresh your screen, and 
the form will now display the new tab.  
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6. To return the form to its original appearance, open the Design Tool 
and click the Restore Defaults button. 

As previously mentioned, the Organize Fields Design Tool displays all the 
form columns in a single list when the form is open in Multi-Record Display 
Mode. Similarly, the Organize Direct Activations and Organize Sub-levels 
Design Tools display the form’s activations and sub-levels in order of their 
appearance. Use these tools to rename or hide the columns, entities and sub-
levels that you do not need and arrange the rest in the desired order. 

Notes:  

 Changes made to the titles of columns in one display mode remain in 
effect in the other display mode as well. 

 Wizards and online help (F1) refer to tab and column titles as they 
appear in the original form designs. Changing these titles may make it 
difficult to recognize columns and tabs referred to in Help tools.  

System Manager Design Options 

Your Priority system manager (or anyone with Manager status) can use 
several advanced design tools to revise forms for all system users: 

 Add Columns to Form: This program allows the manager to add new 
columns to a form from the database table upon which the form is 
based. A complementary program deletes any added columns. 

 Convert to Multi-Company Form: This program allows the manager to 
convert almost all system forms into multi-company forms, in which the 
user can display data from multiple companies in a single form. A 
complementary program converts such forms back to single-company 
forms.  
Tips:  

 Alternatively, the manager can right-click the form title in the menu and 
select Convert to Multi-company. 

 See p. 21 for instructions on how to work with multi-company forms. 

 Change Form Title: This program changes the title of the form, in both 
display modes, as well as in any other system tools (e.g., Choose lists) 
in which the form is named. 

These tools can be found in the Advanced Form Design menu at the 

following path: System Management  System Maintenance  
Advanced Design. 
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Customizing Reports 

To design a report, right-click its title in the menu, then select Design Report 
from the pop-up menu.  

Notes:  

 To customize reports and documents, your user record must be 
flagged in the Document Design column (in the Permissions tab of 
the User Permissions form). 

 Report customizations affect all users in all companies in the system. 

Most reports consist of a single section composed of the relevant columns. This 
format is designated Basic in the Design Tool, to distinguish it from any variations 
you may choose to create (see Figure 66). Click the arrow next to the format to 
view the report sections (in this case, the only section, which bears the report title). 
Click the arrow next to the section title to view its component columns. 

 

Figure 66: The Design Tool for the List of Customers report 

As with the Organize Fields Design Tool, you can hide and rearrange the 
various report components and their columns, and rename column names. In 
addition, you can revise the appearance of report fields and their titles, and 
create variations of a report by duplicating and revising it.  
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When customizing a report, it is good practice to duplicate the report and 
perform your design changes on the duplicate.  

Example 1: 

1. Navigate the menus to access the List of Customers report.  

Tip: Follow the path CRM  Customers  Customer Reports. 

2. Right-click the report title and select Design Report.  

3. Right-click the format title (Basic) and select Duplicate.  

4. A new report format will appear below the original, titled Copy of 
Basic. Rename the format NameFirst. 

5. Click the arrow next to NameFirst and then the arrow next to 
Customers to display the report columns. Select Customer 

Name and click the second up arrow  to the right of the screen.  

6. Click OK. The new report format displays the same data as the 
Basic format, except that in the new format the customer name 
precedes the customer number. 

7. Run a new List of Customers report. The report dialogue box now 
provides two formats in which to run the report: Basic and 
NameFirst. 

 

Figure 67: Selecting formats in the report dialogue box 

8. To remove the new format, open the Design Tool, right-click the 
format title and select Delete. 

Duplicating the original report may prevent you from having to reconstruct the 
original design, if it is needed at some later date.  
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Example 2: 

To revise the appearance of report columns and titles: 

1. Right-click the List of Customers report and select Design 
Report. 

2. Click the arrows next to the duplicate format title (NameFirst) and 
report title (Customers) to display the report columns. 

3. Right-click the Customer No. column and select Field 
Attributes. Use the Display Attributes dialogue box to change 
the field’s font, font style, font size, color, background color or 
alignment in the space assigned to the field. Click OK. 
Tip: In a field that displays a number, such as Quantity, you can 
also set the number of decimal places to display. 

4. Right-click the column again and select Title Attributes. Make 
any of the changes listed above to the Customer No. column’s 
display title. Click OK. 

5. Run a new List of Customers report and select the Display 
option to see the field’s new appearance.  

6. To undo all changes to the report’s appearance, right-click the 
format name (NameFirst) and select Restore Defaults. 

Document Design 

Documents are reports that are sent outside the company to customers or 
vendors (e.g., printouts of price quotes, sales orders, invoices). 

Most documents are predefined in a variety of formats, each of which 
comprises a different set of document components. Some components are pre-
designed in a fixed style, and you cannot rearrange their columns. Those 
components without a fixed style appear as tables, and their columns can be 
rearranged. As we have seen, simple reports usually consist of only one table 
component, and share the same design options as tabular components in 
documents. 

Note: If you are working in a multi-language environment, documents and 
reports must be designed separately in each language. 

Types of Components 

Most documents can be printed in a variety of formats, such as: Standard 
Format, Detailed Format and W/Extended Part Desc. (see Figure 68). 
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Figure 68: The Design Tool for purchase order printouts 

Each print format comprises a number of discrete document components (e.g., 
Company Details, Vendor and Shipping Information, Items, Totals), which 
are either fixed (pre-designed) or tabular. You may revise either type of 
component, or create your own print format by duplicating an existing one, 
changing its name, and then revising its components. 

Note: Users choose the desired print format in the dialogue box that opens 
(after input is complete) when they run the report (see Figure 69). 
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Figure 69: Select the print format for purchase orders 

Symbols preceding the title of each document component or report field in the 
Design Tool help you to distinguish between types of components and their 
attributes. A red X on the icon indicates that the component or field is hidden: 

  Fixed Components (Figure 70) 

You can hide columns, rename columns, change the style of columns and their 
titles (e.g., font, font style, background color, coloring negative numbers), but 
you cannot change their order (the up and down arrows to the right of the 
screen are deactivated). 

In particular, you can change the general document title that precedes the 
document number (e.g., from “Purchase Order” to “Special Purchase Order”) in 
the Document Number component. 

Tabular Components (Figure 71) 

In addition to the options listed above, you can also change the order of 
columns. 

Note: To hide entire document components, whether fixed or tabular, right-click 
the component title and select Hide. 
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Figure 70: Columns in a fixed document component 

 

Figure 71: Columns in a tabular component 
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Defining Your User Signature 

To customize the user signature that appears in printouts of documents that you 
create, select the User Signature command from the File menu (via the 
Options Menu button). A parameter input screen pops up in which to choose 
between a signature for documents or text forms. Choose the in Documents 
option. 

A second parameter input screen appears, in which you can indicate which 
elements you want to display and compose a personal greeting (see Figure 72). 

User information (e.g., Position, E-mail) is taken from your personnel file. Your 
Name is taken from the Full Name column of the Users form. 

 

Figure 72: Defining the user signature 
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Advanced Topics 

Generators 

In addition to the Query Generator (see p. 57), the system provides additional 
generators that facilitate more advanced processes, such as: 

 creating messages that are displayed/sent when certain conditions are met 

 changing the value of designated columns when certain conditions are met 

 creating a Word document from system data 

 creating a spreadsheet from system data 

 creating labels from system data 

 creating a formatted letter from system data. 

The Business Rules Generator and Data Generator share the same 
intuitive interface as the Query Generator. The Spreadsheet Report 
Generator operates within the spreadsheet environment, while the Word 
Document Generator operates within the Microsoft Office environment. All 
generators are accessed from the Design menu (in the Options Menu), 
except for the Letter Generator, which is accessed at the following path: 

CRM  Customer Relations Management. 

Note: You must have Microsoft Office 2010 or higher installed in order to use 
the Word Document Generator. 

The Business Rules Generator 

The Business Rules Generator (see Figure 73) allows you to define any of the 
following messages: 

 an error message, which prevents you from completing the attempted 
action based on defined conditions 

 a warning, which alerts you to potential consequences that may result 
from the completed action 

 an e-mail, which can be accompanied by an attached printout of the 
current record and sent to a given user, group, e-mail address or contact 

 a text message, which can be sent to any user, group, mobile phone 
number or contact 
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 a task, which can be accompanied by an attached printout of the current 
record and assigned to any user. 

Notes:  

You can only send automatic e-mails to groups to which you have authorized 
access (in the Groups form). Defined in the Groups form, groups may contain 
both system users and external e-mail recipients. See p. 87. 

Whoever is flagged in the Write Business Rules for All column in the 
Permissions tab of the User Permissions form is permitted to define rules 
that apply to all users. 

 

Figure 73: The Business Rules Generator 

 

 

The following options are available for defining business rules: 
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 Beneath the message area, click Add Field to open a Choose list 
containing the list of all column titles in the open form. You can 
use this list to add a field representing the column’s current value 
into the text message. 

 Use the Add Rule No. to Msg and Add Rule Desc. to Msg buttons to 
add the automatically assigned rule number and the description you 
recorded to the text message. 

 Add a document's attachments to the e-mail sent for the document by 
flagging Incl. Attachments. 

 Use the If section to define the condition (or conditions) that will cause 
the message to be displayed or sent (e.g., when a certain column 
receives a specific value or range of values, or the result of a designated 
expression). 

 In the bottom When section you can determine that all conditions must 
occur at the same time (the AND condition) in order to trigger the 
message, or you can use independent conditions (the OR condition) 
where it is enough for only one of the conditions to occur in order to 
trigger the message. 

 The Valid For section determines whose actions will trigger the 
message: 

 Myself: If you are a normal user with standard privileges, leave 
this setting to create messages that work for you alone.  

 Only: If you are a privilege group leader, use this setting to create 
alerts for all users in your group (or for a single privilege group 
member). If you are the system manager, use this setting to 
create messages for members of any given group. 

 All Users: If you are the system manager, have Manager 
privileges or are authorized to Write Business Rules (in the 
Permissions tab of the User Permissions form), use this setting 
to create messages that work for every user in the system. 

Note: If you want to condition the message on columns within a sub-level form, 
you must be in the sub-level form before you open the Business Rules 
Generator (columns in the upper-level form remain available as well). 
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Figure 74: Displaying a warning when an ordered item is too expensive 

In the first example, we’ll practice defining a warning message. 

Example 1: 

1. Enter the Purchase Orders form, retrieve an order, and enter its 
sub-level Order Items. 

2. Click the Options Menu button, click Design and select Business 
Rules Generator. 

3. In the Rule Description column, type "Order Items Rule". 

4. In the Do the following section, select Display warning. 

5. Record the following text in the message area: “At least one item in 
this purchase order has an extended price greater than 1000”. 

6. In the If section, open the Choose list in the second text box and 
select the Extended Price column title. 
Tip: Type “E” to jump to the first column beginning with E. 

7. Open the Choose list in the third text box and select is greater 
than. In the additional text box that appears, type “1000”. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 132 

8. Flag the In All Companies option to make the current message 
effective in all companies in the system.  

9. Click OK to leave the Business Rules Generator. 

10. To see the warning message, open a purchase order that includes 
an item whose extended price is higher than 1000. 

In the second example, we’ll practice setting up an automatic e-mail. This 
particular message will be sent automatically to the purchase manager 
whenever the due date of a purchase order is postponed.  

Example 2: 

1. From the Purchase Orders form, enter the Order Items sub-
level form and reopen the Business Rules Generator. Before the 
generator opens, you will see a dialogue box that displays all of 
the rules defined for the current form (in your case, the message 
created in Example 1). Click New to create a new rule. 

2. In the Do the following section, leave Send e-mail. Select user in 
the second text box, and your own username in the third text box.  
Note: For the purpose of testing your message, we will pretend 
you are the purchase manager. 

3. Type the following in the Subject text box: “Purchase Order ”. 
Click Add Field and select the Purchase Orders – Order column 
title.  

4. Type the following partial sentence in the message area: 
“Regarding Purchase Order ”. Click Add Field and select the 
Purchase Orders – Order column title from the Choose list 
below the text box. Now type a comma and continue “the due 
date of order item”, then click Add Field and select the Part 
Number column title. Finally, type “has been moved to”, click Add 
Field and select the Due Date column title. End the sentence with 
a period (see Figure 75). 

5. In the first line of the If section, open the Choose list in the second 
text box and select the Due Date column title. Open the Choose 
list in the third text box and select increases.  
Note: “Increasing” the due date means that the previous date is 
replaced with a later one.  

6. To avoid triggering this message the first time you record a due 
date, click the + (plus) sign to open a second line of the If section 
and create a new condition: Choose the previous value in the 
first text box, Due Date in the second box, and is not blank in the 
third. 
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7. For the rule to operate according to all the defined conditions, in 
the When section make sure "all conditions are met (AND)" is 
selected. 

8. Click OK to leave the Business Rules Generator.  

9. To test the e-mail message, return to the Purchase Orders form 
and open an order that contains at least one line item (or retrieve 
an existing order). Enter one of the lines and replace the due date 
with a later date. When you see the “Sending automatic e-mail” 
message, enter your inbox to see the e-mail you sent. 

 

Figure 75: Sending an e-mail when the order due date is postponed 
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In the third example, we’ll practice defining an error message that is activated 
when the value of one of the form columns (Start Date) exceeds a value that is 
determined by a function expression (as opposed to a fixed value). 

Example 3: 

1. From the Sales Orders form, open the Business Rules 
Generator. 

2. At the top, select Display error message. 

3. Record the following text in the message area: “The designated 
Start Date is too late. Record a date within the current week.” 

4. In the If section, open the Choose list in the second text box and 
select the Start Date column title. 
Tip: Type “S” to jump to the first column beginning with S. 

5. Open the Choose list in the third text box and select is greater 
than. Place the cursor in the additional text box that appears and 
click the function ( ) button that appears to the right of the box. 

6. In the dialog box that opens, click Add Predefined Expression. 
Select the start of next week expression. The corresponding 
expression appears in the text box in this dialog box (see Figure 
76). In the same text box, type " - 24:00" (indicating one day prior 
to the beginning of the next week). Click OK to exit the dialog box. 
The function expression you defined now appears in the fourth text 
box in the If section. 

7. Click OK to leave the Business Rules Generator. 

8. To see the error message, open a sales order with a Start Date 
that falls a week from today. 
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Figure 76: The Business Rules Generator (illustration of the current example) 

Finding and Organizing Rules 

In the rules dialogue box (which appears after the first rule has been defined), 
you can view all rules defined for the form (see Figure 77). 

 To search for a specific rule, click the More button and select Search. 
This allows you to do a text search within the list of rules (e.g., search by 
the rule description). Alternatively, select Report to print a report of the 
rules defined for the form. The report includes the Rule Number and 
Rule Description as well as other identifying information useful for 
finding the rule you want. 

 To change the order of the listed rules, use the up and down arrows on 
the left (e.g., put the most important ones at the top for easy access). 

 If you do not want a certain rule to operate, remove the checkmark from 
the Active column, or click Delete to completely remove it. 
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Figure 77: Business Rules Generator dialogue box 

Creating New Rules from Existing Ones 

An easy way to create a new rule is to copy an existing one and revise it. 
Simply select the desired rule in the dialogue box (see Figure 77) and click 
Copy. A duplicate of the selected rule will appear, which you can revise by 
clicking the Edit button. 

The Data Generator 

The Data Generator functions in a similar manner to the Business Rules 
Generator; however, instead of displaying or sending a message, the system 
records a designated value in a particular form column after a specific field is 
updated. 

 

Figure 78: The Data Generator 
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In the first example, we’ll practice updating a form column only if the specified 
field is updated in the designated way. 

Example: 

1. From the Purchase Orders form, open the Data Generator (see 
Figure 78). That is, click the Options Menu button, click Design 
and select Data Generator. 

 

2. Select the Date column title in the After updating text box, and 
Details in the set text box. In the as text box, record the words 
“Happy Holiday!”. 

3. In the first line of the If section, open the Choose list in the second 
text box and select the Date column title. 

4. Open the Choose list in the third text box and select falls 
between. In the two additional boxes that appears, right-click 
each calendar and select any two dates. 

5. Click OK to create the rule and exit the Data Generator. 

6. To test the new data, open a purchase order and change its date to 
fall within the defined range. When you leave the Date column, the 
Details column (in the Reference tab) will be filled in automatically 
with the chosen expression. 

In the second example, we’ll practice updating a form column using a function 
expression rather than a fixed value. 

Example 2: 

1. From the Sales Orders form, retrieve an order, enter the Order 
Items sub-level form and open the Data Generator. 

2. Select Part Number in the After updating text box, and Due 
Date in the Set text box. Place the cursor in the as text box and 
click the function ( ) button that appears to the right of the box. 

3. In the dialog box that opens, click Add Predefined Expression. 
Select the today expression to add the current date (without the 
time) to the function expression. This expression appears in the 
text box in this dialog box. In the same text box, type " + 5 * 
24:00" (indicating five days after the current date). Click OK to exit 
the dialog box. The function expression you defined now appears 
in the as text box (see Figure 79). 

4. Click OK to create the rule and exit the Data Generator. 
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5. To test the new data, open a sales order and add a new item to the 
order. When you leave the Part Number column, the Due Date 
column will be filled in automatically with the date that falls in five 
days from now. 

 

Figure 79: The Data Generator (illustration of the current example) 

Notes:  

 In the When section you can determine that all conditions must 
occur at the same time (the AND condition) in order to trigger the 
message, or you can use independent conditions (the OR 
condition) where it is enough for only one of the conditions to 
occur in order to trigger the message. 

 The same rules and limitations that apply to the Valid For section 
of the Business Rules Generator apply to this generator as well.  

 In the Data Generator dialogue box you can view all rules defined 
for the current form. To search for a specific rule click the More… 
button and select Search. To print a report of the rules defined 
for the form, select Report. You can change the order of the 
rules by clicking the arrows on the left. If you don't want a certain 
rule to be activated, remove the checkmark from the Active 
column or click Delete to remove it completely.  

 An easy way to create a new rule is to copy an existing rule and 
revise it. To do so, select an existing rule and click Copy. A copy 
of the rule appears in the list, which you can then revise by 
clicking Edit. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 139 

The Word Document Generator 

The Word Document Generator allows you to produce an infinite variety of 
form-based documents that display only those data fields you want to appear, 
exported to a Word file from the system via XML tags.  

Each XML tag represents a column from a specific Priority form. When such a 
tag is implanted in a Word template, it can receive whatever value is currently 
stored in that column. For example, the Document column tag will receive the 
document number of the form record whose data are sent to the template. 

In order to use XML templates, you must have Microsoft Office 2010 or higher 
installed at your workstation, and you must be authorized for document design 
(in the Permissions tab of the User Permissions form). 

Note: Office 2010 requires a special add-in, which may be downloaded from 
http://xmlmapping.codeplex.com/. 

There are two aspects involved in generating Word documents from system 
data: creating Word templates and sending a specific form record to the 
template to generate a document.  

To create a Word template:  

1. Open the Priority form whose data you want to export. For our example, 
we will use the Price Quotations for Customers form. 

2. Click the Options Menu button, click Design and select Word 
Document Generator.  

3. Record a name for the template in the New Template dialogue box (see 
Figure 80). 
Note: After the first template has been created for this form, the Design 
Templates dialogue box opens, in which you can choose between 
editing an existing template for the current report, deleting it or adding a 
new one.  

4. Click New. The template file is downloaded.  

5. Click the file to open it in Word. 

http://xmlmapping.codeplex.com/
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Figure 80: Creating a new Word template  

6. Design the general layout of the document to conform to your company's 
standards. For example, you might add your corporate logo in the 
document header and contact information in the footer. This will provide a 
visual frame of reference for your template. 

7. The first time a template is opened in Word, make sure the Developer tab 
is enabled; you will be primarily working with the tools in this tab.  
Tip: To enable the Developer tab in Word 2010/2013: Open the FILE > 
Options window and select Customize Ribbon. Flag the Developer 
option in the Customize the Ribbon list. 

8. From the Developer tab, select XML Mapping Pane. 

9. From the Custom XML Part list, choose the Priority form from which 
you opened the Document Generator–in our example, Price Quotations 
for Customers (see Figure 81). The XML Mapping Pane now displays a 
list of all form columns available to the template. Below the upper-level 
form columns are the sub-level forms and all of their columns (see below 
for more details). 
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Figure 81: Choosing the Priority form in the XML Mapping pane 

10. To add a column from the upper-level form to the template, right-click 
the column name, and choose Insert Content Control > Plain Text 
(see Figure 82). The column now appears in the template as an XML 
tag. Continue designing the template and adding columns as desired. 
Note: Unlike in earlier versions of Priority, from version 16 you should 
not add tags of the names of any forms (upper- or sub-level) to the 
template, as that could have adverse effects. 

 

Figure 82: Adding XML tags to the template 
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Figure 83: A Word template design including sub-level tags 

 

11. To insert a column from a sub-level form of line items (e.g., Itemized 
Quotation), it is recommended that you first create a table comprised of 
two rows and the desired number of columns (using Word's built-in table 
tools). In the first row, enter the column headings as you would like them 
to appear and place the XML tags representing the sub-level form 
columns in the second row. In the example above (see Figure 83), the 
table displays a list of items included in the quote, including their part 
number, description, quantity and price. Although the table in the 
template only contains one row (besides the headings), when a given 
document (in our example, a price quote) containing multiple rows is 
sent to Word from Priority, the table will automatically grow to 
accommodate them (e.g., if the sub-level form contains five rows, Word 
will add five rows to the table in the final document).  
Note: Use this table exclusively for columns from this sub-level form. 

12. If you anticipate that the data in a particular form will cause the document 
to spill over onto a second page, use a Section Break to create a new 
page, then disable the Same as Previous option in its header. This will 
restrict the company letterhead to the first page of the document. 

13. Save the template. Make sure the file is saved as a template file with the 
.dotx file extension. 
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14. Import the new template to the system by clicking the  in the Word 

Document Generator dialogue box (see Figure 84). 

15. If you want to define the new template as read-only, so that users will 
not be able to edit documents that use this template, flag the  

checkbox next to the template. 

 

Figure 84: Importing a new template 

Editing and Deleting XML templates 

To  edit an existing template for a form:  

1. Open the form in question. 

2. Click the Options Menu button, click Design and select the Word 
Document Generator.  

3. In the Word Document Generator dialogue box that opens, move to 

the line of the template you want to edit and click the  icon (see 

Figure 85). The file is downloaded. 

4. Click the file to open it in Word. Edit the template as desired and save it, 
then close the file.  

5. Import the revised template by clicking the  icon in the Word 

Document Generator dialogue box. 

6. If you want to define the new template as read-only, so that users will 
not be able to edit documents that use this template, flag the  

checkbox next to the template. 
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To delete a template for a form: 

1. Open the form in question and retrieve any record. 

2. Click the Options Menu button, click Design and select the Word 
Document Generator.  

3.  In the Word Document Generator dialogue box that opens, move to 

the line of the template you want to delete and click the  icon. 

 

Figure 85: The Word Document Generator 

Exporting Form Data to Word 

Once you have defined your template, you can use it to create documents from 
individual form records. To do so from the Price Quotations for Customers form: 

1. Retrieve the record (or records) whose data you wish to export. 

2. Click the Options Menu button, click File and select Send to Microsoft 
Word.  

3. Select the desired template in the Choose Template dialogue box and 
choose one of the following options: 

 Print: Prints the document without displaying it. 

 Display: Opens the document in Word.  

 Mail: Opens an e-mail message in the Compose Mail form with the 
document as an attachment. 
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 Automatic Mail: Sends an e-mail to the designated contact with the 
document as an attachment (without opening the Compose Mail form). 

 Automatic Fax: Faxes the document to the designated contact 
(without opening the Compose Mail form). 

4. Flag the All Form Records option to print, display or send all of the 
records currently retrieved in the form (for example, if you retrieved all 
price quotations opened on a particular date). Each record will appear 
on a separate page. 
Tip: You do not have to be in Multi-Record Display Mode for this option 
to work. 

5. Flag the Save as Attachment option if you want to attach the Word 
document to the current record. 

6. Flag the As PDF option to save the document as a PDF file and send it 
as an e-mail attachment. 
Note: This option appears only if Office 2010 is installed on the 
computer from which you are working. 

7. Click OK. A new document is created in Word, in which each XML tag is 
replaced by its corresponding column value in the current form record. You 
can now edit the document, if necessary, and print it out for your customer.  
 

The Spreadsheet Template Generator 

This feature allows you to create spreadsheet templates based on data 
exported from Priority forms and reports. 

Priority provides two methods of working with spreadsheets: via a direct 
interface with Excel or by exporting files to additional spreadsheet applications 
(see p.148). By default, Priority exports data directly to Excel, but this setting 
may be revised by your system administrator by changing the SPREADSHEET 
system constant. 

Generating Templates via Excel 

To design a template for form data: 

1. Open the form whose data you want to export and retrieve any record. 

2. Click the Options Menu button, click Design and select the 
Spreadsheet Template Generator. 

3. Record a name for the template in the New Template dialogue box (see 
Figure 86).  
Note: After the first template has been created for this form, the Design 
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Templates dialogue box opens, in which you can choose between 
editing an existing template for the current form, or adding a new one.  

 

Figure 86: Creating a new Excel template from a form 

4. Click OK. Excel will open automatically, displaying the data from the 
current form record in an .xlt file. Use the formatting tools in Excel to 
design the spreadsheet exactly as you want it (e.g., change fonts, add 
text, hide columns). 

5. Use Excel’s PivotTable and PivotChart options to create the desired 
graphic presentation of your data. 

6. Save the template. 
Warning: Do not use Save As or change its name; also, do not change 
the name of the .xls sheet called DataSheet, where the Priority data is 
stored, and do not perform any changes to it that are not design-oriented 
(for example, deleting columns, defining expressions). Such changes 
should be made in a new sheet, where they will be preserved. 

To  edit an existing template for a form:  

1. Open the form in question and retrieve any record. 

2. Click the Options Menu button, click Design and select the 
Spreadsheet Template Generator.  

3. In the Design Templates dialogue box that opens, move to the line of 
the template you want to edit and click Edit.  The file opens 
automatically in Excel. 

4. Edit the template as desired and save it according to the instructions 
above.  

To delete a template for a form: 
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1. Open the form in question and retrieve any record. 

2. Click the Options Menu button, click Design and select the 
Spreadsheet Template Generator.  

3. In the Design Templates dialogue box that opens, move to the line of 
the template you want to delete and click Delete. 

To design a template for report data: 

1. Locate the report in the Priority menu. Right-click the report title and 
select Spreadsheet Template Generator. 

2. Record a name for the template in the New Template dialogue box.  
Note: After the first template has been created for this report, the 
Design Templates dialogue box opens, in which you can choose 
between editing an existing template for the current form, or adding a 
new one. 

3. Click OK. The report’s input screens will appear, as you will now be 
running a new report. Continue running the report. 

4. Excel will open automatically, displaying the results of the report in an .xlt 
file. Use the formatting tools in Excel to design the spreadsheet exactly 
as you want it (e.g., change fonts, add text, hide columns). 

5. Use Excel’s PivotTable and PivotChart options to create the desired 
graphic presentation of your data. 

6. Save the template.  
Warning: Do not use Save As or change its name; also, do not change 
the name of the .xls sheet called DataSheet, where the Priority data is 
stored, and do not perform any changes to it that are not design-oriented 
(for example, deleting columns, defining expressions). Such changes 
should be made in a new sheet, where they will be preserved. 

To edit an existing template for a report: 

1. Locate the report in the Priority menu. Right-click the report title and 
select Design Spreadsheet Templates. 

2. In the dialogue box that opens, move to the line of the template you want 
to edit and click Edit.  The file opens automatically in Excel. 

3. Edit the template as desired and save it according to the instructions 
above. 

To delete a template for a report: 

1. Locate the report in the Priority menu. Right-click the report title and 
select Design Spreadsheet Templates. 
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2. In the dialogue box that opens, move to the line of the template you want 
to delete and click Delete. 

To export data to Excel: 

1. For a form, retrieve the desired record and click  in the row of 

shortcuts. Or click the Options Menu button, click File and select Send 
to Spreadsheet. For a report, run the report, selecting the New and 
Send to Spreadsheet options. 

2. Select the desired template in the Choose Template dialogue box. To 
create a regular Excel document, select No Template. 

3. A new spreadsheet opens in Excel, which you can now edit and print out 
for your customer. 

Generating Templates via Export to Spreadsheet Applications 

To design a template for form data: 

1. Open the form whose data you want to export and retrieve any record. 

2. Click the Options Menu button, click Design and select the 
Spreadsheet Template Generator.  

3. Record a name for the template in the Design Templates dialogue box 
(see Figure 87).  
Note: After the first template has been created for this form, the Design 
Templates dialogue box opens, in which you can choose between 
editing an existing template for the current form, deleting a template or 
adding a new one (see Figure 89).  

 

Figure 87: Creating a new spreadsheet template from a form 
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4. Click New. The file is downloaded  

5. Click the file to open it in your default spreadsheet application. The 
spreadsheet will open, displaying the data from the current form record in 
an .xlsx file. Use the formatting tools in the spreadsheet to design it 
exactly as you want it (e.g., change fonts, add text, hide columns). 

6. Use the spreadsheet's PivotTable and PivotChart options to create the 
desired graphic presentation of your data. 

7. Save the template. 
Warning: 

 Do not use Save As or change the file name. 

  Do not change the name of the .xlsx sheet called DataSheet, where 
the Priority data is stored, and do not perform any changes to it that 
are not design-oriented (for example, deleting columns, defining 
expressions). Such changes should be made in a new sheet, where 
they will be preserved. 

8. Import the new template by clicking the  icon in the Design 

Templates dialogue box (see Figure 88). 

 

Figure 88: The Design Template dialogue box 

Note: Templates created using the .xlt format will appear in the list of templates 
but will not be accessible when the SPREADSHEET constant is set to 0. 
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To  edit an existing template for a form:  

1. Open the form in question and retrieve any record. 

2. Click the Options Menu button, click Design and select the 
Spreadsheet Template Generator.  

3. In the Design Templates dialogue box that opens, move to the line of 

the template you want to edit and click the  icon (see Figure 89). The 

file is downloaded. 

4. Click the file to open it in your default spreadsheet application. Edit the 
template as desired and save it according to the instructions above, then 
close the file.  

5. Import the revised template by clicking the  icon in the Design 

Templates dialogue box. 

 

Figure 89: The Design Template dialogue box 

To delete a template for a form: 

1. Open the form in question and retrieve any record. 

2. Click the Options Menu button, click Design and select the 
Spreadsheet Template Generator.  

3. In the Design Templates dialogue box that opens, move to the line of 

the template you want to delete and click the  icon. 

To design a template for report data: 



 

Cat.No. LB160681  Ver.04 – June.25,’17 151 

1. Locate the report in the Priority menu. Right-click the report title and 
select Design Spreadsheet Templates. 

2. Record a name for the template in the dialogue box.  
Note: After the first template has been created for this report, you can 
choose between editing an existing template for the current form and 
adding a new one. 

3. Click New. The report’s input screens will appear, as you will now be 
running a new report. Continue running the report. 

4. The file is downloaded and displayed at the bottom of your browser 
window. Click the file to open it in your default spreadsheet application. 
The spreadsheet will open, displaying the results of the report in an .xlsx 
file. Use the formatting tools in the spreadsheet to design it exactly as 
you want it (e.g., change fonts, add text, hide columns). 

5. Use the spreadsheet's PivotTable and PivotChart options to create the 
desired graphic presentation of your data. 

6. Save the template.  
Warning:  

 Do not use Save As or change the file name.  

 Do not change the name of the .xlsx sheet called DataSheet, where 
the Priority data is stored, and do not perform any changes to it that 
are not design-oriented (for example, deleting columns, defining 
expressions). Such changes should be made in a new sheet, where 
they will be preserved. 

7. Import the new template by clicking the  icon in the open dialogue 

box. 

To edit an existing template for a report: 

8. Locate the report in the Priority menu. Right-click the report title and 
select Design Spreadsheet Templates. 

9. In the dialogue box that opens, move to the line of the template you want 

to edit and click the icon. The file is downloaded. 

10. Click the file to open it in your default spreadsheet application. Edit the 
template as desired and save it according to the instructions above, then 
close the file. 

11. Import the new template by clicking the  icon in the report dialogue 

box. 

To delete a template for a report: 



 

Cat.No. LB160681  Ver.04 – June.25,’17 152 

1. Locate the report in the Priority menu. Right-click the report title and 
select Design Spreadsheet Templates. 

2. In the dialogue box that opens, move to the line of the template you want 

to delete and click the  icon. 

To export data to a spreadsheet: 

1. For a form, retrieve the desired record and click in the row of 

shortcuts. Or click the Options Menu button, click File and select Send 
to Spreadsheet.  

Note: For a report, see Sending a New Report to a Spreadsheet (p.101). 

2. Select the desired template in the Choose Template dialogue box. To 
create a regular spreadsheet document, select No Template. 

3. The file is downloaded. Click the file to open it in your default 
spreadsheet application. You can now edit and print it out. 

The Label Generator 

This feature allows you to create labels from a given form, using data that is 
taken automatically from designated form columns. The Label Generator 
program automatically populates the Label Preparation Work Area form with 
values from the designated form and/or its upper-level forms. Labels that are 
prepared in this fashion can then be edited in the Label Preparation Work 
Area and/or printed. 

Note: In order to make full use of these features, you must have a label printer 
and label printing program, such as CodeSoft or BarTender, installed on your 
computer (for details, see the Help for the Print Labels program, located at the 
following menu path: Inventory  Label Printing). 

Designing Labels for a Form 

Use the Label Generator form and its sub-level to design a label for any form, 
based on the values of the designated form columns. When the Label 
Generator is run from that form, each variable will be populated automatically 
with the value of the linked form column.  

In the following example, we’ll practice designing a label for sold parts. 
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Example: 

1. Enter the Label Generator form and retrieve the Order Items 
form. 

2. Select "Orders" as the Type of Label and indicate the Quantity of 
Labels to be prepared for each order item. 

3. Move to the Label Parameters sub-level form. 

4. In the line for the first Parameter, select "Part Number" as the 
Form Column.  

5. Move to the next line and select "Unit Price" as the Form Column 
to be linked to the second Parameter. 

6. In the third line, flag the Upper-level Form Col column in order to 
link the third parameter to a column that appears in the upper-
level Sales Orders form and then select "Order" as the Form 
Column. 

7. Do the same in the fourth line, and select "Date" as the Form 
Column. 

Creating Labels Using the Label Generator 

Once you have designed a label for a given form, you can use it to generate an 
unlimited number of labels from individual form records. When a label is designed 
for a sub-level form (as in the above example), you can choose between preparing 
labels for the record on which the cursor is located and preparing them for all 
displayed records in the sub-level form. You can also choose between editing the 
label data in the Label Preparation Work Area or printing the labels 
immediately. 

Example: 

1. In the Sales Orders form, retrieve the order for which you wish to 
create labels and move to the Order Items sub-level form. 

2. Click the Options Menu button, click Design and select Label 
Generator. 

3. In the dialogue box that opens (Figure 90), select the desired 
label type. 

4. Flag the All Form Records option to create labels for all of the 
records currently retrieved in the form (all items in the current 
order).  
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Figure 90: Creating a new label from a form 

5. Flag the Print Labels option to print labels immediately. 

6. Click OK. The new labels are loaded into the Label Preparation 
Work Area, in which each variable is populated by its 
corresponding column value in the designated form records, and 
they are printed immediately. 

The Letter Generator 

This feature allows you to produce an infinite variety of pre-formatted letters 
which can be sent to customers, vendors and contacts, based on data fields 
taken from the relevant Priority forms. You can also include one or more 
attachments with each letter. After creating the letter, you can print it or send it 
via e-mail to a designated third party (or group).  

In the following example, we’ll practice designing and creating a letter to send 
to customers. 

Example: 

1. Enter the Letter Generator form and move to a blank line. 

2. Record a Letter Name (e.g., "Rewards Program Invitation"). 

3. In the Create Letters Using column, choose the appropriate 
program (e.g., "Letter to Customer"). 

4. Enter the Remarks sub-level form to design the letter (see Figure 
91). 
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Figure 91: The Letter Generator 

5. Record the following text in the message area: “Dear ”. Click the 

 button on the form's Toolbar to access a list of column titles 
and choose the Customer Name column. 

6. Press Enter to move to a new line and record the desired text. 

7. Use the  button and accompanying text to design a signature. 
For example: 
"Kind regards, " 
Title, User Name " - " Position 
"E-mail: " E-mail 
"Phone: " Phone Number ", " Cell Phone 

8. To send the letter to one or more customers, run the Letter to 

Customer program (CRM  Customers  Customer 
Reports). 
Note: You can also retrieve the desired customer in the 
Customers form and run the Letter to Customer program by 
direct activation. 

Similarly, you can design and create letters to vendors and contacts. 

Advanced Data Retrieval and Input 

In the first Data Retrieval section (p. 53) you practiced retrieving records by 
means of column values and wildcards (the asterisk and the question mark). 
You also learned how easy it is to execute complex queries with built-in sorting 
of results using the Query Generator. The following sections describe more 
advanced methods of honing your query. 
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Note: All of the following examples refer to an upper-level form (Currencies). 
While you generally don’t need to retrieve records in a sub-level (all records are 
retrieved automatically), you can execute a query there to limit the records 
displayed.  

The AND Condition 

Among the capabilities of the Query Generator is to specify multiple conditions 
in a single query. You can achieve the same result in Query mode by simply 
specifying values in more than one form column. 

Example: 

To retrieve any currency whose exchange rate is 1 and whose smallest unit 
is cents, take the following steps (remember to press F11 to enter Query 
mode): 

1. Enter the Currencies form. 

2. Type 1 in the Exchange Rate column. 

3. Type Cents (or C*) in the Subdivision column. 

4. Press Enter to execute the query. 

The above is considered an AND condition. You have asked to retrieve any 
record whose exchange rate is 1 and whose smallest subdivision is cents. 

Whenever you use an AND condition, remember to specify all query conditions 
in the various columns before executing the query.  

The OR Condition 

One function that is not supported by the Query Generator is to specify more 
than one query condition in the same column. This method is used when you 
want to retrieve all records that fill any of a set of query conditions. 

Example: 

To retrieve the records for both U.S. Dollars and Euros, perform the 
following actions: 

1. In Query mode, in the Curr column, type $ (or select it from the 
Choose list). Do not press Enter. 

2. Return to Query mode (press F11 again) without executing the 
query. The dollar sign that you just typed in will disappear, but it is 
held in memory. 
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3. In the Curr column, type EUR (or select it from the Choose list). 

4. Execute the query (press Enter). 

The above is considered an OR condition. You have asked to retrieve any 
record whose currency code is either $ or EUR (the result, of course, is two 
separate records).  

You can also use an OR condition by specifying query conditions in more than 
one column.  

Example: 

To retrieve any currency whose code is EUR or whose exchange rate is 1, 
do the following: 

1. In Query mode, type EUR in the Curr column. 

2. Return to Query mode without executing the query. 

3. In the Exchange Rate column, type 1. 

4. Execute the query. 

In sum, whenever you want to use an OR condition, remember to: 

1. Designate the first query condition (be sure you do so in Query mode). 

2. Return to Query mode without executing the query. 

3. Designate the next query condition. 

4. Repeat steps 2 and 3 as many times as necessary. 

5. Execute the query. 

Multiple Conditions Enclosed in Brackets 

You will recall that query conditions are case sensitive. What, then, do you do 
when you want to retrieve all records having a given value, but are not sure if 
the string is in capitals or lowercase letters?  

The solution is to enclose the possible characters (e.g., D and d) inside a pair 
of vertical lines || (in most keyboards, the vertical line is accessed by pressing 
Shift+\). Any record that meets either of these conditions will be retrieved (just 
like an OR condition). This feature is available both in Query mode and in the 
Query Generator. 
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Example: 

Type  |Dd|ollars. You will retrieve the record for Dollars, regardless of 
whether it begins with a capital or lowercase letter. 

You can use the same method to retrieve several records simultaneously. 

Examples: 

 Type |DF|*. You will retrieve all records that begin either with 
the letter D or the letter F (e.g., Dollars, French Francs).  

 Type *|sn|. You will retrieve any currency whose name ends 
either in s or in n (e.g., Dollars, Yen). 

The above examples placed only two characters between the pair of vertical 
lines. You can, however, specify as many characters between the lines as you 
wish. If the characters in question are sequential, you can specify the first and 
last ones, separated by a hyphen, to represent the entire range. 

Example: 

Type |D-J|*. You will retrieve all records that begin with the letters D to J 
inclusive (e.g., Deutsche Marks, French Francs, Italian Liras). 

Backslash Delimiter 

If you want to record a query condition with a string that includes one of the 
wildcards (*,?, |) as an actual character, use the backslash “\” as a delimiter. 
This feature is available both in Query mode and in the Query Generator. 

Note: The following examples are hypothetical. They will not produce results in 
the Currencies form. 

Examples: 

 To retrieve a record with the value of “A*” in its field, type A\*. 

 To retrieve “ABC?”, type ABC\?. 

 To retrieve “ABC|”, type ABC\|. 

 To retrieve all records that contain an asterisk, type *\**. 
Note: The two outer asterisks serve as wildcards. 

Retrieving Null Values 

You will recall that the Query Generator allows you to retrieve null values by 
combining an equal sign with an empty column value. Alternatively, you can 
enter Query mode and type NULL in the appropriate column. 
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Example: 

Move to the Subdivision column of the Currencies form and type NULL. 
You will retrieve the Price Index record (which has no value in this column). 

Note: You can only type NULL in a column of String type.  

Using Operators 

In a column requiring a numerical value (e.g., number, date, time), you can use 
operators to specify an exact value or a range of values.  

For your convenience, you can choose the desired operator by clicking on the 

 button that appears to the right of the column in question (see Figure 92). 

Operators can only be accessed from an odd line (Ln 1, Ln 3, etc.). Specify the 
query condition on the following even line. 

 

Figure 92: The list of operators 

To tell whether you are on an odd or even line: 

 The  button that appears on an odd line includes a list of operators. 

The same button appearing on an even line accesses a Choose list. 

Note: You can also use operators with strings. 
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Example: 

1. Move to the Curr column.  

2. By selecting “>“ from the list of operators and typing PS in the 
second line, you can retrieve any currencies whose code is 
“greater than” PS (e.g., SEK, XEU). 

Note: You can use several operators together to obtain, for instance, values 
greater than X and less than Y. In this case, you need to use one set of odd 
and even lines to define the X condition, and another set of lines to define the Y 
condition (see Figure 93). However, this result is much easier to achieve using 
the Value and To Value columns in the Query Generator.  

 

Figure 93: Retrieving records by a range of dates 

Advanced Sorting of Retrieved Records 

As we have seen, the Query Generator allows you to presort your query results 
within the definition of the query itself. The same functionality is also available 
outside the generator, though without the benefit of saving your conditions for 
future queries. 

The system enables you to sort by several columns at once, ranking them in 
order of importance. The column with the highest priority (the lowest integer) 
will be sorted first (primary sort), data in the column with the next priority will be 
sorted next (secondary sort), and so on. To sort by more than one column at a 
time, sort conditions are set before retrieving the data records. 

In order to sort by more than one column, you must prioritize the sort. The 
order in which the columns are sorted is specified by a number, i.e., 1 = the 
primary sort, 2 = the secondary sort, 3 = the tertiary sort, and so forth. The type 
of sort is determined by the line in which the sort is specified; ascending sorts 
are specified in the first form line, descending sorts in the third. This is best 
explained by an example.  
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Example: 

To sort currencies by exchange rate (descending primary sort) and then by 
name (ascending secondary sort), take the following steps (see Figure 94): 

1. Enter Query mode. 

2. Place the cursor in the Curr column, and type * (to indicate that 
you intend to retrieve all records; this is the query condition) 

3. Move to the Exchange Rates column. 

4. Move the cursor down to the third line in the form (to obtain a 
descending sort by exchange rates). 

5. Type 1 in the column (to indicate that this is the primary sort). 

6. Now move to the Currency Name column. 

7. Move the cursor up to the first line in the form (to obtain an 
ascending sort by name). 

8. Type 2 (to indicate that this is the secondary sort). 

9. Execute the query. 

 

Figure 94: An illustration of the above example 

Consequently, all records will be displayed by the following criteria: 

 The currency with the highest exchange rate will be displayed in the top 
form row, followed by all other currencies in descending order of their 
exchange rates (this is the prime Exchange Rates descending sort). 

 Wherever there is an instance of two currencies having an identical 
exchange rate, they will be listed in ascending alphabetical order (this is 
the Currency Name sort).  
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In sum, remember the following rules when sorting records by more than one 
column: 

 Use integers to designate sort priority (1 for the primary sort, 2 for the 
secondary sort, and so on). 

 Designate sort priority on Ln 1 to obtain an ascending sort; use Ln 3 to 
yield a descending sort. 

 Do not forget to specify one or more query conditions, together with the 
sort criteria. 

 Do not execute the query until you have recorded all query conditions 
and all sort priorities. 

Efficient Use of Queries 

The number of records in the database varies from one table to the next. For 
instance, the Currencies table is unlikely to contain more than a dozen 
records, whereas the Chart of Accounts is apt to hold a large amount. 

When the number of records in a certain table is small (less than 100), the time 
needed to retrieve the records from the database is extremely short, even when 
all records are being retrieved.  

When the number of records in a table is relatively large, it is recommended 
that you try to execute efficient queries that will cut down on retrieval time. For 
instance, instead of retrieving all records, try to limit the number being retrieved 
(e.g., with the help of wildcards).  

A highly efficient technique is to designate the beginning of a name or 
description followed by a wildcard. In contrast, retrieval by a wildcard followed 
by the end of a name or description is extremely slow, as it requires the system 
to search through all the records in the table in order to find those which meet 
the query conditions. 

Think of a regional telephone book. If you know the last name of the person 
whose number you are seeking, you can generally limit the search to one or 
two pages. Even if you only know the first two letters of the last name, you can 
probably narrow down your search to about 50 pages. But if you only know the 
last five letters in the person’s last name, you would have to search through 
every single entry in the phone book!! 

Examples: 

 Suppose you wish to retrieve all expense accounts from the 
Chart of Accounts that begin with the number 6 and end with 
the suffix “-99”. An efficient query would be 6*, whereas *-99 
would yield a long search for records.  
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 If the description of all expense accounts begins with the word 
“Expense”, you can designate an efficient query: Expense*. 
However, if some other string sometimes precedes the word 
“Expense”, you would need to designate an inefficient query 
(*Expense*), which would take a long time. In that case, it 
would be wiser to find some other criteria with which to retrieve 
the accounts (e.g., their number, as in the previous example). 

An inefficient query in a large table requires a massive database search. When 
that happens, you will receive a warning or error message (depending on 
whether or not your system manager has decided to permit massive searches). 
If possible, change the retrieval query and try again. If problems are 
encountered, ask your system manager for assistance.  

Note: The greater the number of records in a table, the more important it is to 
perform efficient queries and the slower the retrieval time for inefficient queries. 

File Explorer 

The File Explorer enables you to organize the files and folders you use in 
Priority, just as you use Windows Explorer to organize the files and folders on 
your computer. Once you are in the File Explorer, you can copy, move, 
duplicate and rename files and folders, create new folders, and move files and 
folders to and from the Priority database. Any folders you use on a regular 
basis can be added to your Favorite Links, where they can be arranged in the 
most convenient order. You can also assign permissions for each folder you 
create to the desired privilege group leaders. After adding a file to the File 
Explorer, you can view any additional system locations to which the same file 
has been linked. In addition, you can lock a file for editing from the File 
Explorer and unlock a file you have locked. 

Note: Use of the File Explorer requires the purchase of a separate module. 

To run the File Explorer, click the Options Menu button, click File and select 
File Explorer (Figure 95). Click on any folder in the left pane to view its 
contents (in a hierarchical structure). Individual files and sub-folders appear in 
the right pane.  

To open a file or folder: 

 Double-click it. 

 Right-click it and select the Open command. 
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 Select the file or folder, and then click the Options Menu button, click 
File and select Open. 

 Select it and press Enter. 

To exit the explorer, click the Options Menu button, click File and select Exit. 

Note: You will not be able to modify files that have been assigned a Read Only 
status (indicating that this file is being used by someone else), although you 
can work on a copy of the file. You can view a file's status and the name of the 
user who locked the file for editing in the Status and Locked by columns, 
respectively. For more details, see Managing a File's Status. 

 

Figure 95: Viewing results in the File Explorer 

You can add items to the File Explorer, using any of the following options: 

 Import a file or folder onto the Priority server. 

 Copy or duplicate an existing file or folder, or create a new folder. 

Items that are stored on the Priority server can be accessed at any time, by 
any user with the necessary permissions. 

Importing Items into the File Explorer 

In order to allow other users in the system to access a file that is stored on your 
hard disk or network drive, use the Import Files command to copy the file onto 
the Priority server, in the ..\..\system\mail directory. To do so, open the File 
Explorer, right-click the sub-folder in which you want to add the file (within 
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either the left or the right pane), and select Import Files from the drop-down 
menu. In the dialog box that opens, locate and double-click the desired file. 

Tip: You can import several files simultaneously by holding down the Ctrl key 
and clicking on each item you want to import. 

In a similar fashion, you can copy a file or folder from the Windows Explorer or 
from an MS-Outlook attachment (e.g., by Ctrl+C), and paste it into the File 
Explorer, at the same time importing it into the ..\..\system\mail directory. 

To paste the copied item into the File Explorer, do one of the following: 

 Right-click the relevant sub-folder and select Paste & Import from the 
drop-down menu 

 Select the desired sub-folder and then click the Options Menu button, 
click Edit and select Paste & Import  

 Press Ctrl+V. 

Copying or Duplicating Items in the File Explorer 

You can also copy or duplicate files within the File Explorer. When you copy a 
file, this creates a shortcut pointing to the original file (or folder) stored on the 
Priority server, which can then be pasted into another system location (either 
within the File Explorer or as an attachment to a system record). In contrast, 
when you duplicate a file, this creates a new copy of the file on the Priority 
server. 

To copy a file (or folder), do one of the following: 

 Right-click the item in question and select the Copy command. 

 Select the desired item and then click the Options Menu button, click 
Edit and select Copy. 

 Select the desired item and press Ctrl+C. 

You can then paste a shortcut to the copied item into the desired folder (e.g., 
by Ctrl+V or Paste & Import).  

Alternatively, simply drag any file or folder directly into another folder, thereby 
creating a shortcut to that item in the desired folder. 

To duplicate a file, do one of the following: 

 Right-click the file in question and select the Duplicate command.  

 Select the desired file and then click the Options Menu button, click 
Edit and select Duplicate.  
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A duplicate of the file will be created on the Priority server and stored in the 
same folder within the File Explorer. Each duplicate created from a given file 
will be saved with the same name, and a different sequential number will be 
appended automatically to the end of each file name. The duplicate file can 
then be opened and its contents modified at any time, like any other file. 
Duplicate files can also be renamed and/or copied into another folder, as 
needed. 

Viewing Additional Links to the File 

You can view a list of any system locations to which a particular file has been 
linked, such as an attachments form (a sub-level of a number of Priority 
forms). simply right-click the desired file and select Links to File. 

To view additional system locations - including other File Explorer folders - to 
which the file has been linked: 

 Right-click the file in question and select Links to File. 

Note: You can also view a list of links to attached files from within various 
system records. 

Creating a New Folder and Assigning Permissions 

To create a new folder in the File Explorer, do one of the following: 

 Right-click the folder in which you want to add a new sub-folder (within 
either the left or the right pane) and select New Folder from the drop-
down menu. 

 Select the folder in which you want to add a new sub-folder (within either 
pane) and then click the Options Menu button, click File and select 
New Folder. 

You can then modify the folder's name by clicking on it and recording the 
desired name. 

To assign and/or modify permissions for the folder you created: 

1. Do one of the following: 

 Right-click the folder and select Permissions. 

 Select the folder in question and then click the Options Menu button, 
click Edit and select Permissions. 

2. A window opens in which you can see the types of permissions that are 
assigned to different privilege groups for that folder (i.e., R = read, W = 
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write, A = administrator, N = navigation, X = none; see Figure 96). 
Right-click the privilege group for which you want to modify permissions. 

3. In the pop-up menu that opens, choose the level of permissions to be 
assigned to users in that privilege group for the current folder and its 
contents. 
Note: The permissions defined for a folder are automatically applied to 
any sub-folders at lower levels in the Explorer, as are any later changes 
in these permissions. You can then directly modify the permissions for 
any sub-folders you created, as necessary. 

4. Do the same for any additional privilege groups. 

5. Click OK. 

 

Figure 96: Permissions in the File Explorer 

Note: Administrator Permission (A) enables users in the designated privilege 
group(s) to assign permissions for that folder to other privilege groups (as well 
as full write permission). Navigation Permission (N) enables users in the 
designated privilege group(s) to view sub-folders, but not files, within that 
folder. 
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Managing a File's Status 

The File Explorer also enables you to manage the Status of individual files. 
The system automatically assigns each file a Read Only status whenever it is 
opened. This status indicates that the file can only be opened in read-only 
mode, ensuring that several different users do not attempt to modify the file 
simultaneously. The name of the user who is currently using the file appears 
automatically in the Locked by column. The file's status reverts back to Free 
(i.e., the Status column is cleared) automatically once it has been closed and 
updated on the server, indicating that the file is now free for editing. 

You can also change a file's status manually. To do so, do one of the following: 

 Right-click the file in question, select Change Status and then select the 
desired status from the drop-down menu (e.g., Read Only). 

 Select the file in question, select Change Status from the File menu (in 
the Options Menu) and then select the desired status from the drop-
down menu (e.g., Read Only). 

Note: Only the user appearing in the Locked by column can change the status 
of a file that has been assigned the Read Only status.  

Adding & Organizing Favorite Links 

The easiest way to access folders that you use on a regular basis in the File 
Explorer is to link to these folders from your Favorite Links. You can then 
arrange your Favorite Links in the desired order or delete any links that are no 
longer in use. 

To create a shortcut for a given folder under Favorite Links, simply right-click 
the desired sub-folder (within either the left or the right pane) and select Add to 
Favorites from the drop-down menu. Once folders have been added to your 

Favorite Links, click the  arrow next to the Favorite Links folder to view its 
contents. 

To move a folder up or down within the list, right-click the folder in question and 
select the desired option (e.g., Move Down, Move to Bottom). 

To remove a folder from your Favorite Links, do one of the following: 

 Right-click the folder in question and select the Remove from Favorites 
command. 

 Select the desired folder and then click the Options Menu button, click 
Edit and select Delete. 
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 Select the desired folder and press Del. 

Designing the File Explorer 

You can further personalize the appearance of the File Explorer by hiding 
unnecessary columns (e.g., Date Created or Date Modified) and arranging the 
rest into the most convenient order. Use the mouse to drag any column to the 
desired position or use the Arrange Columns dialog box, as follows: 

1. Click the Options Menu button, click Design and select Arrange 
Columns. 

2. Use the dialog box that opens to make any of the following changes: 

 Move a column up or down in the list (by clicking the up and down 
arrows or by dragging an item to the desired place within the list). 

 Hide a column. 

Each of the above customizations is reversible; furthermore, you can restore 
the File Explorer to its original format by clicking the Restore Defaults button 
at the bottom of the Arrange Columns screen. 

Exporting Items from the File Explorer 

To export a file or folder from the File Explorer and save it to your hard disk or 
network drive, you can either copy it into the Windows Explorer (e.g., by Ctrl+C 
and Ctrl+V) or drag and drop the item in question from the File Explorer into 
the desired location within the Windows Explorer. Alternatively, you can right-
click the relevant item and select Save from the drop-down menu (or from the 
Edit menu in the Options Menu). In the dialog box that opens, locate the 
desired folder, then click OK. 

Copying a Link 

You can also copy links to any files maintained in the File Explorer into a text 
form or external document (e.g., an Outlook message or Word document). The 
link is copied into the Windows clipboard and can then be pasted where 
desired. 

1. To copy a link, select the file in question and do one of the following: 

 Press Ctrl+Y. 

 Right-click the relevant file and select Copy Document Link. 

 Click the Options Menu button, click Edit and select Copy Record 
Link. 

2. To paste a link that has been copied, move the cursor to the proper place 
in a Priority text form or external document and press Ctrl+V. 
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Removing Items from the File Explorer 

To remove a file or folder from the File Explorer, do one of the following: 

 Right-click the item in question and select Delete. 

 Select the desired item and then click the Options Menu button, click 
Edit and select Delete. 

 Select the desired item and press Del. 

Note: Deleting a file removes it from its current location in the File Explorer, 
but does not delete the file from the Priority server. 
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Mail 

Introduction 

The Priority mail facility includes e-mail, intranet capabilities (communication 
between system users) and text messages.  

In order to make use of these features, you must have an e-mail client such as 
MS-Outlook installed on your computer, or have an account with Gmail or 
another mail service, and a text message account and provider for text 
messaging. Intranet capabilities alone, however, can be implemented via the 
network.  

The various mail features can be accessed in a number of ways: 

 From the Mail menu in the Options Menu. 

 From the Mail menu accessed from the Office Management module. 

The following sections explain: 

 Account configuration 

 Composing and sending outgoing messages 

 Receiving and replying to incoming messages. 

Configuring Your Mail Account 

Mail Options 

You can set up mail to use Outlook, Gmail, or other email servers. Priority will 
use the mail service that was most recently defined. For example, if the mail 
setup program last run was for Gmail, messages will be sent and received 
using Gmail. 

Setting Up Mail Using MS-Outlook 

Click the Options Menu button, click Mail and select Mail Options  Outlook 
 Mail Options. This opens the Mail Options dialogue box (Figure 97).  

If you do not want any automatic checking or notification of new/unread mail, 
simply flag the Don’t check messages option. When this option is chosen, you 
can check for new messages manually. 

If you do want automatic notification, choose between the following options:  

 Check for new messages at the specified interval. 
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 Check for unread messages at the specified interval.  

Don’t forget to specify the desired interval (15 minutes appears by default). 

 

Figure 97: Mail Options dialogue box 

In the next section of the dialogue box, decide whether you want the system 
to check for mail immediately upon logging in. This may be inconvenient if 
you are in a rush to log in. 

In addition to or instead of automatic checking, you can check for mail manually 
at any time. To do so, do one of the following:  

 Click the Options Menu button, click Mail and select Mailbox or Check 
for New Messages. 

 Open the Mailbox form from the menu path: Office Management  
Mail. 

External Mailbox 

The mail utility enables you to receive external e-mail in your Mailbox. If you 
run MS-Outlook, you can transfer any messages received in that Inbox to your 
internal mailbox. To activate this option, flag the Retrieve e-mail messages 
too option. To save these messages in your external inbox (even after they 
were read), flag the Leave messages option as well. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 173 

In addition, the system allows you to avoid pop-up messages that are sent by 
Outlook to prevent viruses from spreading. To do so, flag the Without Outlook 
security messages option. This is particularly useful when you are sending the 
same message to hundreds of external addresses. 

When using Outlook as your mail service, by default, outgoing mail messages 
opened from within a form (e.g., when sending a link to a record) or report will 
automatically open in Outlook. Flag the Use Compose Mail form option if you 
want these messages to open in the Compose Mail form in Priority (see p. 
181). 

Customer/Vendor Tasks 

In addition, you can flag the Record e-mail as customer/vendor tasks option 
in this dialogue box to have each e-mail that you send to or receive from a 
customer or vendor recorded in the system as a marketing task, retrievable in 
the Tasks form. 

Note: Depending on how the system is set up, this option may be disabled for 
all users in your user group or for all users in the system. Ask your system 
manager to change the MAILCRM system constant if you need access to this 
option. 

Setting Up Mail Using Gmail 

Click the Options Menu button, click Mail and select Mail Options  Gmail 
 Mail Settings.  

Note: This program is also accessible from the Office Management > Mail > 
Gmail Mail Options/Calendar Sync > Mail Options for Gmail menu. 

A new tab will open in your browser asking you to allow Priority access to your 
Gmail account. After clicking Allow, a window will open, displaying an access 
code to your account. Copy the code to your clipboard and return to Priority in 
your browser, where a dialogue box will open (see Figure 98). 

Note: If you are not connected to your Gmail account on your workstation, you 
will be prompted to login before beginning. 
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In order to access your Gmail account, paste the access code that you copied 
in the previous step into the Google Access Code column. Also define the 
following settings: 

 Flag the Record Email as Task option to have each e-mail that you send to 
a customer or vendor recorded in the system as a marketing task, retrievable 
in the Tasks form.  

Note: Depending on how the system is set up, this option may be disabled for 
all users in your user group or for all users in the system. Ask your system 
manager to change the MAILCRM system constant if you need access to this 
option. 

 

 

Figure 98: Setting up mail using the Gmail dialogue box 

 Flag the Use Outlook option in order to send and receive Gmail messages 
using Outlook. 

 Flag the Send Test Message option in order to have the system send a test 
message to the defined Gmail account. 

Sending Mail Using Other Servers 

Priority provides the option of sending mail using an SMTP server (e.g., 
Hotmail or Yahoo) rather than MS-Outlook or Gmail. To do so: 

1. Click the Options Menu button, click Mail and select Mail Options for 
Other Servers. 
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Figure 99: Set up mail using other servers 

2. In the Parameter Input dialogue box, fill in the necessary definitions (see 
Figure 99). 

From now on, all the user's external mail will be sent using the defined server. 

Other E-mail Server Definitions 

It is important to define whether you want to receive your internal mail solely in 
your Priority mailbox, solely in your external Inbox (e.g., MS-Outlook), or in 
both. These settings may only be performed by authorized users. To do so, 
they should perform the following for all employees that wish to use external 
mail: 

1. To be performed by an employee with appropriate Human Resources 
permissions: Enter the personnel file in question (Human Resources  
Personnel File), click the Address & Phone tab and make sure that the 
correct external e-mail address is recorded in the E-mail column. 

2. To be performed by the system manager: Retrieve the record in question 
from the User Permissions form (System Management  System 
Maintenance  Users), and record one of the following values in the 
Redirect E-mail column: 

 Leave the column blank to use your mailbox exclusively. 

 Select E to route your internal mail to your external inbox. 

 Select B to receive your internal mail in both mailboxes. 



 

Cat.No. LB160681  Ver.04 – June.25,’17 176 

E-Documents 

E-documents are digitally signed documents (e.g., invoices and receipts) that 
are sent to designated customers (which have given approval for such) via e-
mail, instead of printing and mailing them. Priority allows you to send digitally 
signed documents. Before you can send them, you must purchase a signing 
key from an authorized company. After you have purchased the key, run the 
Set Up PDF Document Signature program (Office Management  Mail). In 
the Parameter Input dialogue box, record the name and password of the PFX 
file that was purchased, or the certificate serial number and password. From 
now on, documents will be sent by the system with digital signatures. 

To automatically send digitally signed documents (using defined mail settings): 

 In the Financ. Parameters for Customers form, flag the Receives e-
Documents column for the relevant customers. 

Note: When sending a digitally signed PDF file, the file will be saved in the 
Attachments sub-level form of the relevant invoice. 

Additional Contact Methods 

Besides e-mail, Priority provides the following additional contact methods 

 Dial a phone number (using Windows Phone Dialer) 

 Dial a phone number or Skype account (using Skype)  

Note: The relevant service or application must be active before you can use 
these contact methods. 

To contact a third party from within a form, do one of the following, click the 
Options Menu button, click Run and select Contact, then choose the desired 
method of contact. 

Alternatively, you can associate a Skype ID with a specific company or 
individual in the Set Up Skype sub-level of any of the following forms: Sales 
Representatives, Customers, Customer Contacts, Leads, Contacts, 
Vendor Contacts, Vendors, Personnel File. Subsequently, you can select the 
Skype command from the field containing that company or individual's 
identifying code in any Priority form.  
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Incoming Mail  

Use the Mailbox form to read your mail messages. This is equivalent to the 
Inbox designation used in most e-mail applications. 

The Mailbox form (Figure 100) may be accessed in several ways: 

 Click the Options Menu button, click Mail and select Mailbox. 

 Use the menu path: Office Management  Mail.  

 In addition, this form opens automatically whenever you authorize the 
pop-up message that notifies you of incoming mail. 

 

Figure 100: The Mailbox form 

The subject of the message appears in the Topic column. The message itself 
is viewed in the sub-level form, Message.  

Other pertinent information regarding received mail is displayed in the 
remainder of the Mailbox form columns, e.g., the sender, the time, date and 
day of the week the message was sent, and so forth. If the mail was sent to all 
members of a group, the group will be displayed as well. (On defining groups, 
see p. 87.)  

Once you have read an incoming message, flag the Was Read column (in the 
General tab). If you do not, the system will continue notifying you of incoming 
mail until you flag the column or delete the message. 

Printing Received Mail 

If you wish to print a given message, move to the record in question in the 
Mailbox form. Then run the Print Message report by direct activation. 
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Opening Attachments 

If your mail includes an attachment, a check mark will appear in the 
Attachments column.  

To view attachments: 

1. Open the Attachments sub-level. Each attached file is displayed in a 
separate line of the form. 

2. Move to the line representing the desired attachment. 

3. To open the file, do one of the following: 

 Click the icon representing the attached file that appears to the right of 
the Attachments sub-level form. 

 Click the file icon that appears in the list of Direct Activations. 
Tip: If the attachment is an image file, hover the cursor over the 
magnifying glass to view a thumbnail. 

 Click the Options Menu button, click File and select Open. 

Saving Attachments 

To save an attached file to a location in your hard disk or network: 

 Right-click the file icon (in the form or the list of Direct Activations) and 
select the Save As command. 

Forwarding Messages 

You can forward a received mail message to a third party by doing the 
following: 

1. Enter the Forward Mail sub-level of the Mailbox form.  

2. Specify the mail recipient (e.g., by username, external e-mail address; 
see p. 181 for details). 

3. Record any desired remarks in the Message sub-level of the Forward 
Mail form. 

4. Return to the Forward Mail form and run the Send Mail program by 
direct activation. 

Replying to Mail Messages 

There are two sub-level forms in which you can reply to received mail:  

 Reply to Mail – the topic of the original message appears in the reply.     
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 Reply (Copy Original Message) – in addition, the original message is 
included in the body of the reply. 

In both cases, the mechanism for replying to mail is identical: 

1. Open the desired sub-level form. 

2. A new message will be created, which you can later retrieve in the 
Compose Mail form. By default, the sender appears in the form as the 
designated recipient and the topic of the original message appears in the 
Topic column, preceded by “RE:”. However, both addressee and topic 
can be revised. You can also designate a third-party recipient in the 
Send Copies to: sub-level form. 

3. Open the next sub-level form, Message, and compose your reply.  

4. If you want to include an attachment, use the Attachments sub-level 
form (see p. 182 for details). 

5. Return to the reply form and select either Send Mail or Send Mail & 
Delete from the Direct Activations menu.  

Note: You can also delete the reply by directly activating the Delete Message 
program from within the reply form. 

Viewing Old Mail 

As mentioned earlier, the Mailbox form opens and automatically retrieves all 
unread mail. However, you can also use Query mode or the Query Generator 
to find specific messages. 

Example: 

To view all mail received today: 

1. Enter the Mailbox form and enter Query mode (press F11). 

2. Press the minus key (-) in the Date column to retrieve today’s 
date. 

3. Press Enter. All mail you received today will be retrieved. You 
can now scroll through the records by pressing PgDn/PgUp, or 
press F4 to view them all together. 

4. Enter the Message sub-level form to view the contents of each 
message. 
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Deleting Old Mail 

Your system manager may periodically delete your old received items (e.g., 
anything dated more than a month ago may be deleted in a batch). You may, 
however, have old mail that you need to save. If that is the case, flag the Block 
Delete column of the Mailbox form for this particular message. No one will be 
able to delete this record until the flag is removed. 

If you want, you can delete a batch of your old received items yourself. To do 
so, take the following steps: 

1. Run the Empty Own Mailbox program, accessed from the Mail menu in 
the Office Management module. 

2. Select Received Mail from the pop-up menu. 

3. Specify the Date until which to delete all incoming mail, and click OK. 

Any message received on or before that date will be erased. (Of course, any 
record flagged in the Block Delete column will not be affected.) 

You can also delete individual received items yourself, by selecting Delete 
Message from the Direct Activations menu when in the Mailbox form. 

Outgoing Messages 

There are several options for sending mail messages: 

 Sending single mail messages to individual system users (an intranet 
utility). 

 Sending single messages to individuals who are not system users (i.e., 
via their Internet address). 

 Sending an identical message to all members of a group.  

In all of the above cases, you can also send a copy (cc:) or hidden copy (Bcc:) 
of the message to a third party (or group). 

The steps for sending messages to an individual user and to a group are 
virtually identical: 

1. Composing the message. 

2. Designating the recipient(s). 

3. Sending the message. 
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Composing Messages 

Use the Compose Mail form to write outgoing messages (see Figure 101). 
This form may be accessed in several ways: 

 Click the Options Menu button, click Mail and select Send Mail. 

 Click the E-mail  button next to the E-mail Address column in any 

form in which it appears. The address of the new message is filled in 
automatically.  

 Use the menu path: Office Management  Mail.  

To compose an outgoing message: 

1. Type the subject of your message in the highlighted Subject column. 
Alternatively, if the message is short, you can record it here. The date 
and time of the message appear automatically in the Date column. 

2. Use the Message sub-level form to write your outgoing message. This 
form uses the HTML Text Editor (see p. 69).  

 

Figure 101: The Compose Mail form 

Tip: You can copy an entity name, a link to the entity or its menu path by right-
clicking the entity in the menu. You can then paste the results (Ctrl+V) directly 
into your mail message. 

Addressing the Mail 

Return to the Compose Mail form and indicate the recipient of the message: 

 If the addressee is a system user (intranet), select the correct username 
from the Choose list in the To User column. 

 If the recipient is a customer or vendor, record its number and e-mail 
address in the To Customer or To Vendor tab, respectively. 
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 If the recipient is not a system user, customer or vendor, fill in the E-mail 
Address column. You can use the Search list if the person in question 
appears in the Contacts form (see p. 185). 

 To send the message to an entire group, click the To Group tab and 
designate its name in the Group Name column. (On defining groups, 
see p. 87.)  

 To send copies of the message to a third party, enter the Send Copies 
to: sub-level form and indicate the party’s username, e-mail address or 
group name (whichever is appropriate). In the To/Cc/Bcc column, use 
the Choose list to select the appropriate sending mode.  

Creating an Attachment 

You can attach any file (e.g., a Word document) to a mail message.  

To add an attachment: 

1. Do one of the following: 

 Click the folder icon. 

 Right-click the folder icon and select Import. 

 Click the Options Menu button, click File and select Import. 

2. In the Explorer window that opens, select the desired file. 

To attach additional files: 

1. Move to the Attachments sub-level form and do one of the following:  

 Click the  button.  

 Click the folder icon in the list of Direct Activations. 

 Click the Options Menu button, click File and select Import. 

2. In the Explorer window that opens, select the desired file. The full path of 
the attached file will now be displayed in the Attachments form.  

3. Move to the next line and repeat for any additional attachments. 

Sending Mail 

Once you’re ready to send the message, return to the Compose Mail form and 
do one of the following: 

 Select Send Mail from the Direct Activations menu. A check mark will 
appear in the Sent column. 

 Select Send Mail & Delete instead, to delete the message from the 
Compose Mail form as soon as it is sent. 
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If you forget to send a message, you will be notified when you try to exit the 
form. You can find the unsent message as follows: 

1. Enter Multi-Record Display Mode (press F4). 

2. Enter Query mode and type a minus sign in the Date column. Today’s 
date will appear. Press Enter. 

3. Look for a message with no check mark in the Sent column. 

4. Send the message by direct activation. 

Sending Record Links 

When working in any of the system’s forms, you can send a mail message that 
links to the record currently displayed.  

To send the current record: 

1. Do one of the following: 

 Click in the row of shortcuts and select Send Record Link. 

 In the Top Bar, open the Mail menu and select Send Record Link. 

 Press Ctrl+S. 

2. A mail message is opened automatically, with the name of the form and 
the record’s identifying number as the subject. The same information, 
including the link itself, appears in the message itself. 

3. Send the message by direct activation. 

Note: When using mail services other than MS-Outlook, ask your system 
manager to change the GMAIL system constant so that it will enable recipients 
to open the attached link. 

Sending Task Links to Participants 

When working in task forms, you can also send a mail message to all task 
participants that links to the task currently displayed.  

To send the current task to participants: 

1. Do one of the following: 

 Press Ctrl+O. 
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 Click the Options Menu button, click Mail and select Send Link to 
Participants. 

2. A mail message is opened automatically, with the task’s Subject and 
identifying number as the subject. The same information, including the 
link itself and any text recorded for the task in the Notes sub-level form, 
appears in the message itself. The message is addressed automatically 
to all participants defined for the task. 

Viewing Old Outgoing Mail 

You can view any messages you have composed (and not deleted) by entering 
Query mode and retrieving them.  

Example: 

To view all mail you have sent to a particular user: 

1. Enter the Compose Mail form. 

2. Enter Query mode (press F11).  

3. Select the user’s name from the Choose list in the To User 
column. 

4. Press Enter. All mail you have addressed to this user will be 
retrieved. You can now scroll through the records by pressing 
PgDn/PgUp, or enter Multi-Record Display Mode (F4) to view 
them all together. 

5. Enter the Message sub-level form to view the contents of each 
message. 

Printing Outgoing Mail 

If you wish to print a given outgoing message: 

4. Retrieve the message in the Compose Mail form.  

5. Select Print Message from the Direct Activations menu. 

Deleting Old Outgoing Mail 

Your system manager may periodically delete your old outgoing items (e.g., 
anything dated more than a month ago may be deleted in a batch). You may, 
however, have old mail that you need to save. If that is the case, flag the Block 
Deletion column of the Compose Mail form for this particular message. No 
one will be able to delete this record until the flag is removed. 
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If you want, you can delete a batch of old outgoing messages yourself. To do 
so, take the following steps: 

1. Run the Empty Own Mailbox program, accessed from the Mail menu in 
the Office Management module. 

2. Select Sent Mail from the pop-up menu. 

3. Indicate the date up to which to delete mail and click OK. Any message 
composed on or before that date will be erased. (Of course, any record 
flagged in the Block Deletion column will not be affected.) 

Creating E-mail Lists via the Contacts Form 

The Contacts form in the Office Management module can be used to list 
persons with whom you maintain contact via Internet mail (i.e., non-system 
users). Although it is mainly used for recording a variety of phone numbers, it 
can also be used for e-mail addresses. By storing these addresses here, you 
will be able to retrieve them quickly from a Search list whenever necessary 
(i.e., in any E-mail Address column). 

Note: There is no need to record e-mail addresses for system users (anyone 
appearing in the List of Users form), as mail is sent to them directly by 
username.  
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Priority on Outlook 

Running Priority on Outlook 

Introduction 

With the proper license and setup, you can run Priority seamlessly on MS-
Outlook by means of a variety of dashboards.  

All parts of the dashboard are fully interactive. For example, you can navigate 
the menus, activate forms and display report data in various cross-sections.  

For details on designing and using dashboards, see p. 106.  

Note: Unless you are working from an SaaS installation, your system manager 
must install the Priority on Outlook module before you can begin. For 
instructions, download the appropriate installation document from the 
Downloads section of the Customer Zone on the Priority web site, at: 
http://www.priority-software.com/customer-zone. 

Choosing the Dashboards to Display in Outlook  

1. Run the Priority on Outlook program, accessed from the Priority on 
Outlook menu in the Office Management module. 

2. Click the Dashboards tab and flag each dashboard that you want to be 
available in Outlook (see Figure 102). 

3. Click the BI Reports tab and flag each report that you want to be 
available in Outlook. 

4. Click the CRM tab and flag each item you want to include in Outlook. 

Note: Every user is permitted to choose the screens that will be displayed in 
his/her personal Outlook. This choice does not affect the display of any other 
user in the system or the dashboards that are available in Priority menus. 

http://www.priority-software.com/customer-zone-2/
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Figure 102: Selecting dashboards 

Displaying the Dashboard 

1. Enter Outlook and click the Shortcuts  icon in the navigation window to 
the left, or press Ctrl+7.  
Tip: Shortcuts to the dashboards and BI reports that you chose appear 
under the titles Priority Dashboards and Priority BI Reports, 
respectively. If the symbol + appears to the right of one of these titles, 
click the symbol in order to display the shortcuts. 

2. Click on one of the dashboards in the list. The dashboard will be 
displayed in the main area of the screen (see Figure 103).  
Note: The first time you work with Priority on Outlook, click on the User 
Dashboard and make sure the User Definitions window is visible. Use it 
to set up the data you will be viewing (e.g., to select a company). 

3. In order to move from the upper to the lower part of the screen, use the 
vertical navigation bar to the right. 

Tip: In order to display the dashboards in a wider window, press Alt+F1 to 
close the navigation window to the left of the screen. To restore the navigation 
window, press Alt+F1 again. 
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Figure 103: Displaying a dashboard 
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Appendices 

Appendix A: Keys and Functions 

Key Function 

Basic Keys 

Enter Execute 
Move to next column 

Esc Exit/cancel 

Ctrl+Enter Open new line 

Ctrl+Del Delete record 

F7 Clear the line (record) 

F2 Scroll/edit mode 

F4 Full/multiple record display 

Navigational Keys 

Tab Move to next column 

Shift+Tab Move to previous column 

Shift+ Move to next tab 

Shift+ Move to previous tab 

Alt+ Move to next sub-level 

Alt+ Move to previous sub-level 

Ctrl+ Move to next form/menu 

Ctrl+ Move to previous form/menu 

Ctrl+` Open the Options Menu 

PgUp Previous record/page 

PgDn Next record/page 

Home Edit mode: First char. in column 
Scroll mode: First field/column 

Ctrl+Home Move to first record 

End Edit mode: last char. in column 
Scroll mode: Last field/column 

Ctrl+End Move to last record 

Ctrl+G Go to line 

Ctrl+F2 Change writing direction 

Edit Keys 

Ins Replace/insert 

Del Edit mode: Delete current character 

Backspace Delete previous character 

Ctrl+U Delete entire field 

Ctrl+C Copy 

Ctrl+V Paste  

Ctrl+H Copy entire column 

Key Function 

Edit Keys (cont.) 

Ctrl+Y OR 
Ctrl+L 

Copy record link 

F8 When drilling down, return to 
form/input screen and paste 
current value 

F10 Copy field from previous record 

Ctrl+Z Undo 

+ Empty field: Default value 
Filled field: Increase value 
Next date/hour 

- Empty field: Default value 
Filled field: Decrease value 
Previous date/hour 

Ctrl+F3 Search for value in this field 

F3 Search again for value in this field 

Ctrl+F9 Store into buffer 

F9 Retrieve from buffer 

Ctrl+F7 Clear the form 

Shift Expand column 

Left-click 
form column 
title 

Sort data by values in this column 

Right-click 
form column 
title 

Calculate column total (sum 
values) 

Ctrl+F8 Calculate column total (sum 
values) up to current line 

Action Keys 

F11 Move to Query mode 

Shift+F11 Run Query Generator  

Ctrl+0 Run the Query Generator’s 
default query 

Ctrl+1-9 Run up to nine saved form 
queries 

F12 Enter default sub-level  

Ctrl+F12 Enter default sub-level, but do not 
retrieve records (if text form, enter 
in read-only mode) 

F5 Choose sub-level form 

Key Function 
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Key Function 

Action Keys (cont.) 

Ctrl+F5 Choose a Direct Activation 

Ctrl+/ Run Enterprise search 

Ctrl+] Search for entity (form, report, 
program) 

Ctrl+M OR 
Ctrl+F11 

Update screen (refresh) 

Alt+0-9 Run up to ten saved macros 

Ctrl+Break Stop action 

Ctrl+S Send record link – create mail 
message with current record link 

Ctrl+O Send link to participants – create 
mail message addressed to all 
task participants with current 
record link 

Ctrl+[ Access to do list 

Ctrl+B Organize fields 

Ctrl+I Import file 
 

Action Keys (cont.) 

Shift+F5 Choose sub-level form, but do not 
retrieve records (if text form, enter 
in read-only mode) 

Right-click in 
form 

Access context-sensitive menu 

More Keys 

F1 Column help in form/input screen 

Ctrl+F1 Form help 

F6 OR 

Space key in 
blank 
column 

Choose; search; activate form; 
select date 

Ctrl+F6 Skip Choose list and go directly to 
search 

Shift+F6 Open Explorer 
Report input: Open date calendar 

Shift+Mouse Select sequential Choose list items 

Ctrl+Mouse Select non-sequential Choose list 
items 

 

 

Date Calendar 

Key Function 

  (right) Move up one day 

  (left) Move back one day 

  (down) Move up one week 

  (up) Move back one week 

PgUp Move up one month 

PgDn Move back one month 

Enter Select displayed date 

Esc Exit calendar 
 

 

Appendix B: Right Mouse Button Menu (Menus)  

The following commands appear in a pop-up menu accessed by clicking the 
right mouse button from a menu entity (menu, form, report, program). 

Help: View help text for the current entity. 

Online Help: Accesses documentation from the Priority web site. 

Design Report: Open the report design tool. 
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Design Spreadsheet Templates: Create templates for spreadsheets, into 
which report data can be loaded (active only for reports). 

Copy: Copies the entity name. 

Copy Shortcut: Copies the entity name with a hyperlink. 

Copy Path: Copies the menu path that accesses the entity. 

Open After Login: Open this entity automatically every time this user enters 
the system. 

Design Menu: Determine the order in which entities appear in the menu. 

Add to Favorites: Add this entity to the Favorites menu.  

Add to Home Page: Add to the Selected Entities displayed on the Home 
Page. 

Open in the Privilege Explorer: Open the Privilege Explorer, directly 
accessing privileges for this entity. 

Change Font Size: Select the size of the menu font. 

Add Document File: Include an external file (e.g., an MS-Word document) in 
the menu. 

Delete Document File: Remove this external file from the menu. 

Add User-Defined Report: System managers: Include a customized report, 
designed by a user, in the menu, so it is available to all users. 

Delete User-Defined Report: Remove this customized report from the menu. 

Appendix C: Options Menu (Home Page) 

File  

Select Company: Choose a different company. 

Define Multiple Companies: Select companies for multi-company forms and 
consolidated reports. 

Who Am I?: Display current user. 

Change Password: Change your own user password. 

User Signature: Customize your default comment and document printout 
formats. 
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Language: Switch to a different language (provided dictionaries are available). 

File Explorer: Organize system files and folders. 

Mail 

Send Mail: Open form to compose outgoing mail message. 

Mailbox: Open mailbox (inbox) to view/reply to incoming mail messages. 

Check for New Messages: Check for new and/or unread mail in mailbox.  

To Do List: View your list of assigned tasks. 

To Do List History: View a history of assigned tasks. 

Tracking List: View a list of documents that you are currently tracking. 

Bulletin Board: View the latest postings on your company’s Bulletin Board. 

Mail Options: Choose the user's mail service and define relevant mail settings. 

 Outlook: Set up Priority to use Outlook. 

o Mail Options: Configure automatic notification of new/unread 
mail and appointment reminders. 

o Synchronize with Outlook: Set up and run interface between 
Priority and MS-Outlook. 

o Priority on Outlook: Run the program by which you define the 
Dashboards to display in MS-Outlook. 

 Gmail: Set up Priority to use Gmail. 

o Mail Settings: Set up e-mail with Gmail. 

o Calendar Sync Options: Define settings for synchronizing your 
Priority and Gmail calendars. 

o Synchronize Calendars: Synchronize your Priority and Gmail 
calendars now. 

 Other Servers: Set up Priority to use an SMTP server. 

Design 

Design Main Menu: Determine the order in which the root menus appear in the 
Main Menu. 
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Organize Favorites: Arrange entities in your Favorites menu. 

Design Tool Tray: Determine the order of Tool Tray items. 

Color Theme: Choose between a Light/Dark color theme in forms. 

Run 

Check Operating Speed: Check the speed of recent operations (used for 
debugging). 

Search for Entity: Search by keyword for form/report/program and then run it. 

Run Entity (Advanced): Advanced method for running applications 
(programmers only). 

Help 

Help Wizards: Access to all Priority wizards. 

User Interface Guide: Access this Guide.    

Keys and Functions: Access the table of shortcut keys to use for common 
actions (see Appendix A). 

FAQs: Find and display Frequently Asked Questions (FAQs) by topic. 

Learn Priority: Watch video clips explaining how to work with the system. 

Priority Web Site: Direct access to the Priority web site (http://www.priority-
software.com). 

Online Support: Access to the Customer Zone on the Priority web site. 

Priority Information Center: Open your personal inbox for messages from the 
Priority Information Center. 

About Priority: System version and registration details. 

Appendix D: Options Menu (in Form) 

File  

Who Am I?: Display current user. 

Change Password: Change your own user password. 

User Signature: Customize your default comment and document printout 
formats. 

http://www.priority-software.com/
http://www.priority-software.com/
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Select Company: Choose a different company. 

Define Multiple Companies: Select companies for multi-company forms and 
consolidated reports. 

Language: Switch to a different language (provided dictionaries are available). 

File Explorer: Organize system files and folders. 

Import: Open window from which to select a file (relevant in forms that include 
an attachment column, such as the Attachments form). 

Open: Open file in current line (relevant in forms that include an attachment 
column, such as the Attachments form). 

Send to Spreadsheet: Transfer displayed data to a spreadsheet file. 
Note: The SPREADSHEET system constant determines whether data are sent 
to MS Excel or to your workstation's default spreadsheet (e.g., Open Office). 

Send to Microsoft Word: Transfer displayed data to predefined Word 
template. 

Exit Form: Exit current form (upper-level and sub-levels). 

Mail 

Send Mail: Open form to compose outgoing mail message. 

Mailbox: Open mailbox (inbox) to view/reply to incoming mail messages. 

Check for New Messages: Check for new and/or unread mail in mailbox.  

Send Record Link: Open an e-mail that includes a link to the record currently 
displayed. 

Send Link to Participants: In a task, open an e-mail addressed to all 
attendees that includes a link to the task currently displayed, as well as the 
notes recorded for the task. 

To Do List: View your list of assigned tasks. 

To Do List History: View a history of assigned tasks. 

Tracking List: View a list of documents that you are currently tracking. 

Bulletin Board: View the latest postings on your company’s Bulletin Board. 

Track Document: Start tracking the current document. When certain changes 
are made to the document, you will receive e-mail notification. Tracked 
documents may be retrieved in the Tracking List form. 
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Stop Tracking Document: Stop tracking the current record (once you have 
flagged it for tracking). 

Mail Options: Choose the user's mail service and define relevant mail settings. 

 Outlook: Set up Priority to use Outlook. 

o Mail Options: Configure automatic notification of new/unread 
mail and appointment reminders. 

o Synchronize with Outlook: Set up and run interface between 
Priority and MS-Outlook. 

o Priority on Outlook: Run the program by which you define the 
Dashboards to display in MS-Outlook. 

 Gmail: Set up Priority to use Gmail. 

o Mail Settings: Set up e-mail with Gmail. 

o Calendar Sync Options: Define settings for synchronizing your 
Priority and Gmail calendars. 

o Synchronize Calendars: Synchronize your Priority and Gmail 
calendars now. 

 Other Servers: Set up Priority to use an SMTP server. 

Exchange Data: Transmit the current form data via the Priority Data 
Exchange. 

Edit  

New Line: Open new line. 

Clear Line: Clear (hide) current line (does not remove record from database). 

Delete Record: Remove record from database. 

Clear Form: Clear form of all records, remaining in Data Entry mode (does not 
remove records from database). 

Copy: Copy highlighted text. 

Paste: Paste text. 

Copy Record Link: Copy link to current record. 

Store into Buffer: Store contents of field in which cursor rests into a buffer. 
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Retrieve from Buffer: Insert content stored in designated buffer into field in 
which cursor rests. 

Copy Field Above: Clear anything currently in the field where cursor rests and 
copy to it the contents of the same field in the previous record. 

Copy Column: Copy all values in current column. 

Special Paste - Ignore Warnings: Paste text without displaying system 
warnings. 

Store Records: Store all records in current sub-level form into buffer. 

Retrieve Records: Retrieve all records stored in buffer and insert them in 
default sub-level form. 

Sort: Sort all values in current column. Selecting this function once gives you 
an ascending sort; select again and the data will be sorted in descending order.  

Expand: Temporarily expand width of field in which cursor rests, and leave 
column expanded until the root form is exited. 

Default Value: Fill in default value (e.g., current date). 

Scroll/Edit: Toggle between Scroll (move between columns) and Edit (move 
within column) modes. 

Undo: Replace original text in current field, provided that cursor has not left 
line. 

Sum Values: Total all values in column, from top of form to cursor, provided 
this is a number column (total appears in separate window). 

Goto Line: Move cursor to designated line; indicate line number in pop-up 
window. 

Search: Search for given pattern in current column. 

Search Again: Search for next instance of pattern defined during last search. 

Design 

Organize Fields: Hide, rename and rearrange the form’s tabs and columns. 

Organize Direct Activations: Determine the order in which direct activation 
options appear. 

Organize Sub-levels: Determine the order in which sub-level forms appear as 
tabs underneath the form. 
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Restore Column Widths: Undo changes in column width performed manually 
(by dragging) in Multi-Record Display Mode. 

Design Main Menu: Determine the order in which root menus appear in the 
Main Menu. 

Organize Favorites: Arrange entities in your Favorites menu. 

Record Color: 

 Define Record Color: Determine the color of record values for this 
form, when a given field displays a predefined value or falls within a 
defined range of values. 

 Show Current Record Colors: Display the color options which have 
been set for the fields in this form. 

Change Font Size: Select the size of the form font. 

Color Theme: Choose between a Light/Dark color theme in forms. 

No Image Display: Display records without any attached images or icons 
(improves speed). 

Business Rules Generator: Set up error, warning or e-mail messages that are 
triggered automatically when certain conditions are met. 

Data Generator: Set up changes to the data recorded in the current form that 
are triggered automatically when certain conditions are met. 

Spreadsheet Template Generator: Create templates from which to generate 
spreadsheets that display form data. 

Word Document Generator: Design MS-Word templates from which to 
generate Word documents that display form data. 

Label Generator: Create labels for the current form, using customized label 
types. 

Highlight Mandatory/ReadOnly: Highlight mandatory and read-only columns. 

Full/Multi-Record: Toggle between full display of all columns in a single record 
(Full-Record Display Mode) and display of multiple records (Multi-Record 
Display Mode). 

Run 

Query Generator: Define, save and run custom queries for the current form. 

Query/Clear Form: Move into Query mode; clear all data in form. 
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Retrieve All Records: Retrieve all records in form, placing you in Data Entry 
mode. 

Default Query: Execute the default query, as defined in the Query Generator. 

Refresh: Update data displayed in form, based on recent record updates 
(updates generally result from changes made by another user after you 
retrieved data into form). 

Direct Activations: Open menu of forms, reports and/or programs that can be 
activated from within the current form. 

Sub-levels: Access menu of sub-level forms. 

Default Sub-level: Open default sub-level form. 

Search for Entity: Search by keyword for form/report/program and then run it. 

Analysis Reports (BI): View a list of BI reports relevant to the form, which you 
can run in order to analyze data related to the current record.  

Contact: 

 Skype: Use Skype to dial a landline, cell phone 
or Skype account. 

 Dial: Dial a phone number (using Windows Phone 
Dialer). 

Calculator: Opens the Windows calculator. 

Map: Display current address in Google Maps. 

Macros:  

 Select a Macro: View a list of macros (sequences of keystrokes and/or 
mouse actions) defined for the current form. You can then execute, 
delete or assign a hotkey to any of these macros. 

 Execute: Choose and run macro. 

 Start Definition: Begin defining new macro. 

 End Definition: Select after you have finished defining macro. 

Run Entity (Advanced): Advanced method for running applications 
(programmers only). 

Check Operating Speed: Check the speed of recent operations (used for 
debugging). 
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Help 

Quick Help: View a list of basic operations. 

User Interface Guide: Access this Guide.    

Keys and Functions: Access the table of shortcut keys to use for common 
actions (see Appendix A). 

Learn Priority: Watch video clips explaining how to work with the system. 

Column Help: View help text for column on which cursor rests. 

Form Help: View help text for current form. 

Help Wizards: Access to all Priority wizards. 

Online Help: Accesses documentation from the Priority web site. 

FAQs: Find and display Frequently Asked Questions (FAQs) by topic. 

Priority Web Site: Direct access to the Priority web site (http://www.priority-
software.com). 

Online Support: Access to the Customer Zone on the Priority web site. 

Priority Information Center: Open your personal inbox for messages from the 
Priority Information Center. 

About Priority: System version and registration details. 

Appendix E: Text Editor Toolbar 

 Set Text Color (Ctrl+O) 

 Cut (Ctrl+X) 

 Copy (Ctrl+C) 

 Paste (Ctrl+V) 

 Bold (Ctrl+B) 

 Italics (Ctrl+I) 

 Underline (Ctrl+U) 

http://www.priority-software.com/
http://www.priority-software.com/
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 Undo (Ctrl+Z) 

 Increase Font Size (Ctrl+E) 

 Decrease Font Size (Ctrl+D) 

 Align Left (Ctrl+L) 

 Align Center (Ctrl+M) 

 Align Right (Ctrl+R) 

 Numbering (Alt+N) 

 Bullets (Alt+B) 

 Decrease Indent (Ctrl+<) 

 Increase Indent (Ctrl+>) 

 Horizontal Line (Ctrl+H) 

 Hyperlink (Ctrl+Q) 

 Picture (Ctrl+P) 

 Add a Comment (Ctrl+K) 

 Spelling (Ctrl+G) 

 Save (Ctrl+S) 


